Overclock.net banner

1 - 20 of 87 Posts

·
Registered
Joined
·
829 Posts
Discussion Starter #1
Ok... I just upgraded from an E8400 to a Q9550 assuming that my fps would increase and not dip to 30 all the time like it did with my duo. Well, that sure was a dumb investment, because my performance is basically identical to what it was before. I am ready to cry right now.

The cores on my CPU are all ~60% usage while in-game... except for the 4th core (core 3) which stays at ~100%. My GPUs are getting ~40% usage each.

So, I ask you, fellow overclockers:

WHAT THE HELL IS GOING ON???

Please, if anyone else knows what's going on or has the same problem, post. It might make me hate myself less for that $240 investment.
 

·
Registered
Joined
·
591 Posts
Have you messed around with your settings.ini file? It's a common misconception that setting DxVersion=9 will improve your performance. On my machine, it actually lowers fps by 10 or 15 compared to leaving it at auto.
 

·
Registered
Joined
·
829 Posts
Discussion Starter #4
It's at 3.825 GHz right now because that's what I could get stable so far.
 

·
Banned
Joined
·
697 Posts
Very few games rely on the cpu for graphic rendering, as we all know the cpu can't touch the performance of GPU rendering, so having a 260 sli setup is what you need to look at. Or if your online what is your network conection?
I am downloading the game as I type, to play with my clan, and I have a 275 sli setup-phenom x4 @ 3400mhz...with everything overclocked and I will reply at what my avg frames are...
You need to also include what settings you are using so others can compare, and help you
 

·
I'm gonna need a sweeper
Joined
·
7,568 Posts
Quote:


Originally Posted by Arrec Barrwin
View Post

It's at 3.825 GHz right now because that's what I could get stable so far.

What drivers are you using? AFAIK only the 196.75's that got pulled had SLI support in BC2. Could be wrong on that though.
 

·
Registered
Joined
·
829 Posts
Discussion Starter #9
Quote:


Originally Posted by AxEmAn
View Post

Very few games rely on the cpu for graphic rendering, as we all know the cpu can't touch the performance of GPU rendering, so having a 260 sli setup is what you need to look at. Or if your online what is your network conection?
I am downloading the game as I type, to play with my clan, and I have a 275 sli setup-phenom x4 @ 3400mhz...with everything overclocked and I will reply at what my avg frames are...
You need to also include what settings you are using so others can compare, and help you

I already have SLI.
The settings are 1920x1200 res, all settings on high except for sound quality (low), overgrowth and undergrowth (medium), AA is at 1x, AF is at 8x, HBAO and Vsync are both OFF, and bloom is set to FALSE. My CPU render ahead limit is at 3, and my FOV is at 65.
 

·
Registered
Joined
·
829 Posts
Discussion Starter #10
Quote:


Originally Posted by srsparky32
View Post

few games utilize the quad cores. you should have purchased a bigger gpu like a 5850 or larger.

What are you talking about? Have you guys read any of the BC2 performance threads? This game uses quad cores and dual cores have been getting half the performance. GPU power is not what is needed in my case at all. A 5850 would be a downgrade.
 

·
Registered
Joined
·
1,755 Posts
Sounds like Sli isn't actually being utilized here. Try different drivers and then test BC2.
 

·
I'm gonna need a sweeper
Joined
·
7,568 Posts
Try forcing it to DX9 and then see how well it runs - it hardly looks different (except from the AA, but you had that on 1 anyway)
 

·
Registered
Joined
·
307 Posts
Didn't the game have a problem with bad fps with nvidia cards and increased load times with ati cards on dx 10 and 11?

The game does use 4 cores for those who keep saying it doesn't. In theory, what you did should be an upgrade, not a trade off.
 

·
Registered
Joined
·
2,782 Posts
Quote:


Originally Posted by milkcow500
View Post

I have yet to see an fps increase going from my 4ghz dual core 555be to a 4ghz quad core 555be. All I've gotten is a decrease in load times for the maps.

I saw around a 30 FPS (maybe more) increase going from my E6600 to my I5-750, but that was between beta and release and the difference in 1 GHz.
 

·
Registered
Joined
·
1,716 Posts
you are on sli 260 and you dip below 30 fps alot?

Im on a single 4890 and I rarely go below 30fps, with settings on high hboa off at 1920x1080 window mode

It sounds like software problem.
 

·
Initializing...
Joined
·
23,786 Posts
You should try out the XG 187.66 drivers they run great for me very smooth for BC2.

Get them here:
Forum Link
Download Link
 
1 - 20 of 87 Posts
Top