Overclock.net banner

1 - 10 of 10 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1 (Edited)
Starting a new Build for 2018.

Equipment choice:


Case: Bitfenix Prodigy M (White)
CPU: Intel i7 8700K
Motherboard: Asus ROG z370-G (AC)
Memory: Corsair Vengeance 32GB (2x16GB) DDR4 3000 (PC4-24000) C15 for DDR4 Systems, White LED (CMU32GX4M2C3000C15)
PSU: Enermax Platimax D.F. 80 PLUS Platinum Certified Full Modular 850W Power Supply
FAN'S: Corsair SP Series, SP120 RGB LED With Controller x3
Video Card: GeForce GTX 1080 SEA HAWK EK X

Storage:
Primary - Corsair Force Series MP500 480GB M.2 NVMe PCIe Gen. 3 x4 SSD (Linux)
Secondary - Corsair Force Series MP500 120GB M.2 NVMe PCIe Gen. 3 x4 SSD
x2 Samsung EVO 860 SSD 250GB on RAID 0

Water cooling Parts and other accessories:

CPU Waterblock: EK-FB ASUS Z270/Z370 Strix RGB Monoblock

Reservoir: Watercool HEATKILLER® Tube 100 DDC
Reservoir Accessories:
Watercool HEATKILLER® Tube - stuts 100mm - raw aluminum
HEATKILLER® Tube - MultiPort Top 100
Watercool HEATKILLER Tube - Stand (short)

Water Pump: EK-DDC 3.2 PWM (12V PWM pump)

Radiator:
Alphacool NexXxoS ST30 Full Copper 240mm
Alphacool NexXxos ST30 Industry HPC Series 120mm radiator

Fittings: All fittings are by Bitspower (Deluxe White)
Mayhems Pastel Coolant Premix - 1L -Pastel Purple
Mayhems Blitz Cleaning System



All equipment is in and I will be uploading pictures soon.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #2
I do not have an SLR camera so here is my poor's man attempt to some good shots :p
Here is the case at it's raw stage :D



PSU and MB in:




Here I am testing the RAM, Both nvme, PSU, and MB (All working as expected):




Monoblock and vid card are in:




In this one I decided to see how things mount and line up and found that the RAD with fans get on the way of the top PCI lane so the video card cant go there.... I also found that the top PCI lane is only 8x so down it goes :D




This one is a detail pic of another problem... Cabling on the way:
Had to flip the PSU the other way to make cabling a bit more manageable.





Reservoir is in and looking how it will all fit together :D :




Detail shot of fittings and custom drain ports... I also started the tube bending at this point (My friend R0B0T was in charge of tube bending)... (Yes I know is not perfect some tubes will get re-done.... :) )



Closer look at the drain port:





Here is am doing Part one of the blitz cleaning... (12hrs later)




Here is a shot at how things are coming along.... Notice the wrong fitting on the vid card? :D Yes I borrow a fitting so we can get the tube bend till the correct color fitting arrives :p
I also flipped the front rad fan to avoid negative pressure :)




Things still to come:


Correct rotary 90 degree fitting male to female for vid card.
Mayhems Purple Pastel.


I will do second part of the blitz cleaning tonight.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #4
Did the leak test last night and found several issues.

Reservoir had a leak by the o-ring. Got it fixed.
Top Rad had a leak on the left fitting. Fixing it today.
 
1 - 10 of 10 Posts
Top