Overclock.net banner

1 - 5 of 5 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter · #1 ·
Hi, I've recently purchased the 7950 and am having graphical anomaly while playing the Witcher 2. I just arrive to the Flotsam Forests and there are these flickering white flashes whenever I move my character. And the shadows just look weird.

I am playing on stock clock speed, and the temp stays under 60c. I've tried every drivers from 12.5 to 13.2 beta and the same flickering still persist. Tried 3dmark11 and Unigine Heaven and experience neither crash nor artifacts

The weird thing is, when I tried to record this flickering using Fraps and Afterburner, the flickering stopped. As soon as I disable the recording, the flickering comes back. I also noticed that if I disable Fullscreen, there would not be any flickering.

Tried the game on windows 7, reset my CPU to stock speed, problem still persist.

Do you guys think this is a hardware - related problem? If so I need to RMA the card ASAP.

P.S. I currently only have the Witcher 2 so I can't try other games.

System Specs:
i5-3570k
HD 7950
8 GB RAM
Windows 8 Pro

Thanks
 

·
Registered
Joined
·
96 Posts
Discussion Starter · #3 ·
The game is legit. I bought the game from Steam and then got the backup copy from GOG.com. I've tried both version (steam and gog) and experience the same issue.
 

·
Registered
Joined
·
96 Posts
Discussion Starter · #4 ·
Can there be a possibility that the card is faulty? I've spent too much time troubleshooting and would rather go through the RMA process. However, they'll just send me back the same card if there is nothing wrong with it.
 

·
Registered
Joined
·
96 Posts
Discussion Starter · #5 ·
Update:

I swapped in my old 5770 and there is no more flickering. Time to RMA I guess...

I am guessing it has something to do with the 7950's GPU usage? When I use a recording software to record gameplay. the GPU usage drops to about 80's (from 99%) and there is no flickering. So does that mean when the gpu is in full load it will produce flickering? However, when I benchmark using 3dmark11 and Unigine Heaven (both stress GPU to 99% usage) there is no artifacts...,at least none that I notice.
 
1 - 5 of 5 Posts
Top