Overclock.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,562 Posts
Discussion Starter · #1 ·
Hello,

A bit of info first... I bought the ASUS N750JV laptop (it says R750JV on the label at the bottom side of the laptop, but the case says N-series)

It came pre-installed with Windows 8, which I upgraded to 8.1, but I still hated it.

So I formatted it and put Win 7 on it.

There are no drivers for Win 7 on the ASUS site, but before the format I found the drivers (in Win 8.1) on the recovery partition or any other partition, I don't know anymore --> many of them are WIn 7 and 8 compatible, not the LAN or WLAN...)

Anyway, everything works, but for some reason it does not auto-switch between wireless or LAN, when I plug in the LAN cable. So I have to disable the WiFi adaptor in networkcenter...

When disabled only the LAN adaptor is enabled, thus plugging in the cable works.

When I unplug the LAN cable, ofcourse the WiFi does not turn on again as I shut down the adapter...

I had a few little problems installing (finding) the correct drivers (LAN and WLAN) in the beginning so I don't know if anything is conflicting...

All I want is the auto-switching ability back (I tried a piece of software that would do that, but nope...) --> hence it should be automatic as always, with all my previous laptops, including this one when in Win 8.1

I don't know if this screen looks normal? As I don't know if you can have 2 connections one 1 network connection? --> see image



EDIT: And this is a screenshot of device manager, showing all adapters are installed (and I can go on internet with them anyway...)

And another screenshot of ALL the stuff already installed after the Format C --> to give you guys info iff any LAN or WLAN driver/soft could conflict...



 

·
Registered
Joined
·
2,562 Posts
Discussion Starter · #2 ·
Oh yeah, the internet speedtest is horrible slow...

Also with cable it's not getting max speed, tho a lot better than wifi (duh)

LAN is supposed to be 150Mbps and I get 145 with main PC. If I use same cable, on laptop I get max 90

WiFi was 40 yesterday and today 6??? --> fixed this with removing the Intel WiFi driver... Why did it install in the first pleace??? The WiFi card is an Atheros one???

I mean, it was I who installed the driver because there where this 2 drivers on the ASUS site... but why can't/doesn't the intel one said: no compatibel hardware found or something???

Anyway, the speed is back between 40-60Mbps wireless... but the autoswitching between wifi and lan is still a no go
 

·
Registered
Joined
·
2,562 Posts
Discussion Starter · #3 ·
UPDATE: I tried these things as well, but nope
tongue.gif


I went into the network control panel and clicked on the "change adapter settings". I tapped the ALT key once (it shows the "hidden" menu bar) and selected "Advanced", and then "Advanced Settings".

There I could use the up and down keys to arrange the network list... But it did not work
thumb.gif


Then I tried to change the "Automatic Metric" function of the network adaptors and gave the LAN nr 2 and the WiFi nr 3 (1 was occupied already) --> but also not working
thumb.gif


So the only thing I can do is to en/disable the adaptors manually
smile.gif


I can live with it, but I never knew/heard of it until I threw off Win 8
 

·
Premium Member
Joined
·
14,051 Posts
Some machines have an option in BIOS to auto-prefer an interface or disable wireless when wired is connected/etc.

We have a few at work that utilize this feature when docking, but enable wireless once undocked.
 

·
Registered
Joined
·
2,562 Posts
Discussion Starter · #5 ·
Thx for the tip, didn't nknew that either!

But only thing in BIOS I can find related to networking is Network Stack (or something
tongue.gif
) --> It's disabled by default.

When I enabled it there were some option like wake on IP4 or IP6 stuff, but no "auto-prefer-stuff"
 

·
Registered
Joined
·
20 Posts
Win 7 does not automatically set the LAN connection as the top priority when both WLAN and LAN are active. This is by design in Windows 7, but Windows 8 corrected this by what I believe is putting the WLAN connection to sleep when a fully functioning LAN connection is detected. You may be able to set the priority in the network connections area of the control panel but if you want the auto switch to occur most effectively you'll need Win 8, a 3rd party program, or a bios which support the disabling of the WiFi adapter when a LAN connection is detected.
 

·
Registered
Joined
·
2,562 Posts
Discussion Starter · #7 ·
Weird... My VERY OLD laptop is an ASUS SINGLE CORE P4
tongue.gif
1.7GHz with 2x 512MB DDR2 RAM and a GeForce 7300GS with 512MB and it had XP on it.

A few years ago I installed Win 7 on that and it does work on that laptop...

Now I do it with a freshly bought laptop, came with Win 8, threw Win 7 on it, and it started
tongue.gif


I searched the (latest) BIOS settings and 3th party soft but no go.

But now it seems they work "simultanious" (at least they connect simultaniously) --> only the WiFi symbol stays ahead of the LAN symbol in system tray.

Cause when I do a speedtest (with both WiFi and LAN connected) it shows the LAN speed --> with the WiFi symbol

And when I plug the LAN out, the WiFi takes over IMMEDIATLEY (so no few seconds "connecting" symbol)

So basicly that means... the problem is solved I guess? It's just the symbols that does not change??? Or what??? Or was it a 1 time event
tongue.gif
???

But going to sleep now ZZZZZZZZZZZZZZZZZZZZZ
 
1 - 7 of 7 Posts
Top