Overclock.net banner

1 - 20 of 51 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter #1
I recently purchase a corsair h50 mounted in my case with push and pull configuration in an antec 1200 see picture 1.ok and my temps ar verry bad see picture 2 3 for idle load temps.i did not make any change in my bios all set to defaun cpu not OC is at stock and i get that stupid temps.......what is the problem.....please HELP me or i will commite suicide(joking)



 

·
Banned
Joined
·
3,749 Posts
I don't know what it is about the H50, but it seems to be a coin toss as to whether or not it performs good or bad. Some people report great temps, others report temps worse than the stock cooler. Personally, I think there are too many variables that can cause this cooler to underperform. You generally don't see the drastic variations in temps on air cooling that you see with the H50, because an air cooler is just a solid piece of metal.

I know this rant doesn't really solve your problem, just giving my reasoning behind it. How do you have the rad positioned/mounted?
 

·
Registered
Joined
·
154 Posts
Quote:


Originally Posted by F1ForFrags
View Post

I don't know what it is about the H50, but it seems to be a coin toss as to whether or not it performs good or bad. Some people report great temps, others report temps worse than the stock cooler. Personally, I think there are too many variables that can cause this cooler to underperform. You generally don't see the drastic variations in temps on air cooling that you see with the H50, because an air cooler is just a solid piece of metal.

I know this rant doesn't really solve your problem, just giving my reasoning behind it. How do you have the rad positioned/mounted?

Agreed with f1 : .....I had to remount my h50 several times before I got within the desired range.

Re-mount sounds so dirty when you type it .
 

·
Registered
Joined
·
3,318 Posts
granted you chip is a c0 stepping. But my d0 here on air cooling (one of the better one) Is now folding (2 fold @same time) load temps are 44 degs hottest. Im runing 0.975 volts. You mite want to go to a store get some new tim. like ocz freeze or mx-2 tx-2 or something in that range and try again. With my pc overclocked to 4.095 mhz i hit 80 deg. i would image you would hit like 100+ deg.
 

·
Registered
Joined
·
163 Posts
Discussion Starter #9
my temp in my chamber is 27 celsius degrees and i didn't use the paste from corsair that was put on h50 i use my Tim AC mx-2 i applied on my cpu and on h50 paste here is the pic with the h50 mounted in my case also i clean the cpu&h50 with artic clean kit
LL
LL
 

·
Registered
Joined
·
524 Posts
Well, from my own testing with the H50, you want the inlet and outlet ports for the radiator on the bottom, with the fans as intake. Outlet fan position will lower case temps a bit, but it will raise your temperature on the cpu at the same time since you are pumping air fresh off the mosfets through the radiator.

Intake fan orientation lowered my temperatures by ~2C. Also, like has been previously said, if the plate for the H50 isn't perfectly level and down tight, your temperatures will be much higher than expected. It took me a good 3 or 4 shots before I finally got it right.

Are you running the the stock corsair fan with the aftermarket one? The stock corsair fan is kind of horrible. Upgrading to a single ultra kaze dropped my temperatures another 7-8C.
 

·
Premium Member
Joined
·
2,794 Posts
just an FYI the TIM that comes with the corsair h50 is shin etsu, some of the best TIM around.

secondly do you have your fans pulling air into the case or sending air out of the case? It is recommended you have it so it pulls air into the case, which also means you should be turning a front fan around so it is an exhaust.

And tbh the temps dont look all that bad considering the i7's put out a lot of heat.
 

·
Registered
Joined
·
154 Posts
Quote:

Originally Posted by Alexander99 View Post
yes 1 fan is corsair and the other-one is from the case running full speed.you are saying to me that the corsair logo must pe Straight???(the plate)??
In all of the ones that I have seen mounted correctly....The Corsair Logo is straight. IMO.
 

·
semi-legit
Joined
·
7,980 Posts
Quote:

Originally Posted by Alexander99 View Post
my temp in my chamber is 27 celsius degrees and i didn't use the paste from corsair that was put on h50 i use my Tim AC mx-2 i applied on my cpu and on h50 paste here is the pic with the h50 mounted in my case also i clean the cpu&h50 with artic clean kit
The TIM that comes with the H50 is actually Shin Etsu X-23, it is VERY good stuff.

Also try flipping between intake/exhaust with your fans to see what give you better temps (you'll need to redirect other fans though if using as intake).
Reseating may need to be done a few times as said, it is a bit tricky to mount.

Only other things to look into are make sure the pump is running at 100% and maybe look into some better fans and/or shrouds.
2x 38mm fans / controller would certainly do the trick, or you could pick up a few 1850RPM Gentle Typhoons if you value your ear drums
 
1 - 20 of 51 Posts
Top