Overclock.net banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I am running 2x ATI 5970 on my ASUS P6X58D. With 2 cards im getting lower fps in CarCry2 and Furmark than other people online.So I did some testing useing only single card and this is what i got:

If i take one card out form PCIE #1 (closest to CPU) and leave second one in PCIE # 2 everything runs nice. Im getting same FPS as other people who were testing one 5970 on Far Cry 2. If I move my card to PCIE #1 FPS drops 50%. I thought there is a problem with motherboard( PCIE #1 not working properly) so i installed another board, brand new, same model and I still have the same problem. I dont know what to do in this case..... please help
 

·
4kfan
Joined
·
4,224 Posts
try the beta drivers and make sure that you turn off msi afterburner and all that good stuff. and your i7 might be a bottleneck if is not overclocked. xfire was tricky for me to get right so i imagine quad fire is even worse. make sure that all the gpus are at the same clocks.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Right now im using one card in PCIE #2 it works the way it should: nice frames. Same thing if i switch the cards. It doesnt matter which card. As long as its sitting in PCIE # 2 works fine. PCIE # 1 gives me trouble.....
 

·
Premium Member
Joined
·
14,038 Posts
Don't you love how like nobody actually pays attention to what you wrote there, they just start blurting out random stuff that makes no sense in the context of what you're saying? I always find it amusing


Anyways ... does your board bios allow you to pick which slot is the primary PCI-Ex adapter? If so, which one is chosen?

That's kind of a long-shot though. I'm more inclined to think that there's some kind of driver issue. I would put both cards back in, fire up Windows, and then uninstall drivers completely. Then go into safe mode and do a Driver Sweep.

Drop back to 1 card in slot one, and restart the machine. Then install drivers, and restart again. Does the card in slot one now operate like the card used to in slot one (bad), or is it now working like it used to in slot two (good)?

If it's now working well, go ahead and shut down, install the card 2 in slot two, restart, re-install drivers (even if windows already did it for card 2), then restart again. This should enable crossfire. Now see if you're getting some xfire love/four card scaling.

If it's still working poorly, just because it's in slot one ... and both the gfx cards act the same way when placed in slot one ... then frankly I'm pretty baffled.

Keep in mind that unless you're running a very difficult test, gfx-wise (like vantage extreme, [email protected], the Heaven benchmark with DX11 ... all at at least 1920x1200), the scaling is not likely to be terribly impressive going from one to two 5970's. You are very likely to run into CPU-bottlenecks in a LOT of testing scenarios.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
I installed each card seperately and i enabled crossfire- works only if i connect my cable to the card in pcie 2. I colund find anything in bios regarding choosing pcie as primary... But now im happy i get 360 fps in furmark no aa And far cry 2 around 130 to 160 fps all settings maxed out and thats what i was looking for... Thnx for help
 
1 - 8 of 8 Posts
Top