Overclock.net banner
1 - 20 of 22 Posts

·
Premium Member
Joined
·
5,777 Posts
Discussion Starter · #1 ·
I have recently installed Crysis (Maximum Edition) on Windows 7 64-bit and I seem to be having an issue with the NO-DVD patch. I have updated to the Crysis 1.2 Patch and used the appropriate NO-DVD patch for that version. The issue seems to be that whenever I try to load the 64-bit version (default) of the game, it doesn't load and gets stuck on black screen. Then I have to Ctrl+Alt+Del and it gives me an error message regarding Crysis64.exe.

Has anyone been able to replicate this issue? It's only a problem with the NO-DVD patch and 64-bit version of the game and I have always had it working on Vista flawlessly.

I'd like to point out that this is a legally owned copy of the game and I'm trying to get rid of having to use the DVD all the time so I don't wear it out.
 

·
Premium Member
Joined
·
5,777 Posts
Discussion Starter · #3 ·
Quote:

Originally Posted by bringonblink View Post
have you tried a 32bit patch? just to see if its the actual patch thats the problem, or if it lies somewhere else
Did so and it said DLL files were missing (somewhat obvious I guess).

32-bit NO-DVD patch in 32-bit version of the game works as it should however.
 

·
Premium Member
Joined
·
5,777 Posts
Discussion Starter · #4 ·
Found the Solution

1. Go to: C:\\Program Files (x86)\\Electronic Arts\\Crytek\\Crysis\\Bin64\\
2. Right click: Crysis.exe
3. Click "Properties".
4. Click the "Compatibility" tab.
5. Click the "Show settings for all users" button.
6. Click the "Run this program in compatibility mode for: checkbox.
7. From the drop-down menu click "Windows Vista Service Pack 2".
8. Click the "Run this program as an administrator" checkbox.
9. Click the "OK" button.
10. Click the "OK" button.
11. Open Crysis like you would normally.


As a reminder, this is ONLY an issue if you're using the No-DVD crack, so follow the above steps if you run into the issue of Crysis 64-bit is freezing at a black screen when using the No-DVD exe for it.
 

·
Registered
Joined
·
1,198 Posts
The amount of ram it can use.
 

·
Registered
Joined
·
1 Posts
Quote:
Originally Posted by Open1Your1Eyes0;7929287
Found the Solution

1. Go to: C:\Program Files (x86)\Electronic Arts\Crytek\Crysis\Bin64\
2. Right click: Crysis.exe
3. Click "Properties".
4. Click the "Compatibility" tab.
5. Click the "Show settings for all users" button.
6. Click the "Run this program in compatibility mode for: checkbox.
7. From the drop-down menu click "Windows Vista Service Pack 2".
8. Click the "Run this program as an administrator" checkbox.
9. Click the "OK" button.
10. Click the "OK" button.
11. Open Crysis like you would normally.
smile.gif


As a reminder, this is ONLY an issue if you're using the No-DVD crack, so follow the above steps if you run into the issue of Crysis 64-bit is freezing at a black screen when using the No-DVD exe for it.
this doesn't work for me, but i just launch it from bin32 anyway. Thats works for me.
drum.gif
 

·
Registered
Joined
·
1 Posts
I got the game working by changing the Compatibility but now when the game loads up
the mouse is kind of out of sync with the screen, to click on settings I have to move
the mouse to the bottom right, far from the icon.
I changed settings here and there with no luck, also had the same problem with BFBC.

Is there anybody that can help with this please.

confused.gif
 

·
Registered
Joined
·
1 Posts
Running Crysis in Vista Service Pack 2 compatibility mode as the Administrator, but it plays terribly! The menu screens are fast enough, but the actual gameplay is SLOW. My system specs, I have been told countless times, are far more than what is necessary to play the game well. I own a legitimate copy of Crysis for 64 bit systems.
My SPECS:
Windows 7 Pro;
Phenom II x6;
MOBO - gigabyte M4A89GTD-PRO/USB3;
4gigs DDR3;
Video: one Radeon HD 5750

Portal 2 and Serious Sam H.D. run almost flawlessly and were what inspired me to buy Crysis... I thought I could handle it... wah!
 

·
Premium Member
Joined
·
5,257 Posts
Quote:
Originally Posted by Open1Your1Eyes0;7875689
I'd like to point out that this is a legally owned copy of the game and I'm trying to get rid of having to use the DVD all the time so I don't wear it out.
As this thread is already necro-central, just thought I'd add a hearty laugh in response to your justification

AFAIK a low-powered LASER such as the one in a DVD drive has never worn out the plastic / aluminium materials that a disc is made of
wth.gif
headscratch.gif
 

·
Registered
Joined
·
3,730 Posts
Quote:
Originally Posted by omega17;14308749
As this thread is already necro-central, just thought I'd add a hearty laugh in response to your justification

AFAIK a low-powered LASER such as the one in a DVD drive has never worn out the plastic / aluminium materials that a disc is made of
wth.gif
headscratch.gif
Probably not, but it sounds like a damn freight train spinning in a tornado and that's no fun!!
poke.gif


Thanks for this! So sick of DVD's...I don't care what kind of DRM the game uses...just NO SPINNING DISCS!!
 

·
Registered
Joined
·
13 Posts
This solution doesn't seem to work anymore, and I've been looking everywhere for weeks for a black-screen fix
 
1 - 20 of 22 Posts
Top