Overclock.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
642 Posts
Discussion Starter #1
I recently sold my MSI Gaming 6G 980 Ti. But the buyer told me he gets no video. I proceeded to troubleshoot with him but he still wasnt getting video. He told me the card lights up and fans spin as soon he powers the computer. After about 10 seconds, the fans stop but light stays on. But still no video. Long story short, I ended up refunding him once he shipped the card back to me. So I got back the card the other day. Needless to say, the same things were happening. I know there is nothing wrong with the computer because when I connect through igpu I get video. So I opened the card and cleaned the thermal paste, then reapplied with mx4. Put it back, still no video. I can see the monitor getting a signal, but nothing shows up on the screen. It obviously has nothing to do with the computer. I don't think I can return it to MSI for a replacement because some of the screws are missing. I had lost them a few months prior when I replaced the fan and backplate for custom cooling. Are there any other options to try to salvage something out of this card? I hate to just throw it in the garbage.

Sent from my SM-G920V using Tapatalk
 

·
Registered
Joined
·
1,169 Posts
If it still had warranty time left on it I would sure try to get it fixed that way. Find out if it meets MSI's requirements for warranty repair. Any missing screws can be purchased somewhere. You can always say you took it apart to try and see what the problem was. Call MSI and ask, or whoever you purchased it from originally. Still at least try.

https://us.msi.com/page/warranty/
 

·
Registered
Joined
·
642 Posts
Discussion Starter #3
Thanks for the reply. Do you know where I can purchase this cards type of screws? I would think a hardware store, but I'm not well versed in such stuff. Perhaps there is a website that sells various types of computer part screws.

Sent from my SM-G920V using Tapatalk
 

·
Registered
Joined
·
642 Posts
Discussion Starter #4
My card is still under warranty. I went to the site and they issued me a RMA. I think I'm just going to send it to MSI the way it is and take a chance they fix it. If not, no biggie as I have basically accepted the lose.

Sent from my SM-G920V using Tapatalk
 

·
Registered
Joined
·
1,169 Posts
You might want to ask first, if they will accept it that way. Any hardware store should be able to identify and order the correct screws. If you want to chance it all they can do is say no.
 

·
Registered
Joined
·
642 Posts
Discussion Starter #6
Thought about going to a hardware store. But by the time they order the screws, and that's even if they can get the right ones, then wait for the store to get them, I just decided it be better just to send the card as is now. It's still attached together. Just most of the other screws are missing. I'm sure they have seen cards in worse shape. Again, not expected anything, have already resigned to cut my losses. Even if I don't get another card, I learned a valuable lesson not to "screw" around. LOL.

Sent from my SM-G920V using Tapatalk
 

·
Computer Arsonist
Joined
·
2,620 Posts
If it was only getting a black screen, sounds like a dead vbios? Hopefully the RMA goes well.
 
1 - 7 of 7 Posts
Top