Overclock.net banner
1 - 13 of 13 Posts

·
Laptop Enthusiast
Joined
·
9,764 Posts
Discussion Starter · #1 ·
If you look at the sig you'll see that I had a 640gig WD SATA HDD on the way. Well I've just gotten it and it doesn't show up under My Computer. All connections are good and Bios sees it. This is my first HDD that I bought and it's just confusing ya know? If it helps, also, it's a bare drive. Do I need to put something on there before I can use it or should it just be like a plug-and-play deal?
 

·
Registered
Joined
·
886 Posts
it should be just a plug and play deal. are you sure you don't have RAID setup in the bios, that could prevent hard drives from being seen if they were not added to the array
 

·
Laptop Enthusiast
Joined
·
9,764 Posts
Discussion Starter · #4 ·
Sweet. ^^ Trying now. ^^

::EDIT::

Checked it under Device Manager and it says this:

 

·
Laptop Enthusiast
Joined
·
9,764 Posts
Discussion Starter · #6 ·
check the piccy from last post...
 

·
Premium Member
Joined
·
10,487 Posts
Not device manager, disk management, just click the start button and type disk management and then enter
 
  • Rep+
Reactions: Imglidinhere

·
Banned
Joined
·
1,453 Posts
Quote:


Originally Posted by meticadpa
View Post

Name the Drive and format it in "Disk Management".

You can get there by right clicking on My Computer and clicking "Manage" it should then be an option on the left.

Once you do that, click on Disk Management under Storage, right click on the new drive and press Format.

Once formatted (takes 15 seconds or so), your hard-drive will show up.
 

·
Laptop Enthusiast
Joined
·
9,764 Posts
Discussion Starter · #11 ·
What if I can't see it under device manager?

 

·
Laptop Enthusiast
Joined
·
9,764 Posts
Discussion Starter · #13 ·
NEVERMIND. o-o

I fixed it. ^^ being overly paranoid gets in the way sometimes... ^^
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top