Overclock.net banner

1 - 2 of 2 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Hello,

I didn't know where to put this. Just an hour ago I did something very stupid. I'm not sure what damage I might have caused.

I have a mechanical keyboard that is causing some problems. I have been trying to change the switch on a couple of keys and ever since removing some of the switches on the arrow keys, the keys won't register even though I seem to have installed everything okay.

So I thought "why don't I solder the connection a little to make sure contact is being registered". So I went to apply just a drop of solder to a contact point.

The problem is that I didn't realize that the keyboard was actually plugged into my computer when I tried to do that. So my computer basically turned off and tried to restart but the monitor won't turn on when it tries to boot.

To be clear I just touched a drop of solder to the key switch. I unplugged everything immediately after.

What could I have done by doing this? The soldering gun/solder must have sent some sort of voltage back to the usb port on my computer.

When I try to turn on my computer now everything lights up, the fans start, all the lights on the motherboard light up like their supposed to. But I hear no beep and the monitor never turns on.

My mouse lights up and it is plugged into the usb port on the motherboard.

What do you think happened? How do I troubleshoot this?
 

·
Overclock Failed...
Joined
·
13,565 Posts
Was this a solder iron that plugs into the mains or was it a battery operated soldering iron? If it was battery operated, well, that could be really, really bad.

No beeps:
Do you have a case with a motherboard speaker, and if so, is it plugged into the motherboard's speaker socket? If you have one and it's plugged in remove the keyboard and you should get beeps. You can also remove the memory, that will beep too.

If you're getting beeps, well even if you're not, try another keyboard. Don't try the soldered keyboard in another port.
 
1 - 2 of 2 Posts
Top