Overclock.net banner

dual monitor help

285 Views 9 Replies 6 Participants Last post by  lespaul5895
I'm running dual monitors on my system for the first time. I'm loving it but for some reason now every time I open firefox it opens on my second monitor. I've tried everything I can think of to make it stop doing this. I've even disabled the 2nd monitor and opened and closed firefox a few times, then enabled it again and the first time I open it, it pops up on my secondary monitor rather than my primary. I'm getting frustrated, any advice? Thanks in advance.
1 - 10 of 10 Posts
I have been having this problem too. You used to be able to change it in the nVidia control panel before they changed the interface. Not really sure now but I agree it is quite frustrating because my tertiary monitor is a TV that stays off but active and firefox recently started wanting to open on that instead of my primary
It should be as simple as moving the firefox from monitor one to monitor 2.
Open firefox.
Move window by dragging to mon.1
Then close firefox and when it ask you to save and quit. Go with that option.
Do any other programs do that, or just FF?

I thought FF would open in the last place you had it. So if you open it and then move it to your primary and then close it, it doesn't open back up on your primary?
I thought of that but closing it on primary it still opens on tertiary...vlc does this too when i want to go back and forth so I think its a driver thing and they just killed most of the code that was useful when you could control it
all u have to do is bring fire onto your primary monitor close it and there u have it. it opens on my main monitor after all the time
Try disabling the second monitor temporarily in your nvidia control panel, then open and close ff in main, re-enable the second monitor. See if it takes.
That worked before, but after reboot it had changed back
for me it's only ff that does it. I've tried everything suggested and it constantly opens on my secondary monitor. I'm clueless
well after doing some searching it was recommended that I close ff while it's not maximized on my primary monitor and that seems to have fixed the problem
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.