Overclock.net banner

61 - 71 of 71 Posts

Shooting down fallacies
Joined
8,721 Posts
So....product shows a much higher than expected failure rate, with reports popping up across PC forums from very experienced liquid cooling users. Normal thinking would be "hmmm.....that's a lot of unexpected failures, I should probably avoid the product". EK user thinking is "it didn't happen, everyone is lying, it's their fault, how dare they disrespect my love EK!". Yeah, it's a conspiracy started by Bill Cosby....he's convinced people to put gelatin in their res and post pictures so he can sell more Jell-O.
 

Registered
Joined
232 Posts
I've diluted my ek cryofuel blood red 2 1/2 times now with distilled. About 800ml two first times and 400ml last time. Whole loop is what 4.5-5 litres. It's STILL blood red. LOL. There's alot of stuff in their fluids, thats all I'm saying.
 

Registered
Joined
107 Posts
You guys got me worried now.I im starting my first build and I am planing to use demineralised water with mayhem bio extreme.Is that ok?
 

Shooting down fallacies
Joined
8,721 Posts
You guys got me worries now.I im starting my first build and I am planing to use demineralised water with mayhem bio extreme.Is that ok?
It's fine. That has nothing to do with CryoFuel.
 

Registered
Joined
971 Posts
Haters gonna hate, probably ur own fault for ending up like that, like in most cases, user error but product must be blamed.
I used EK water block exclusively for over 10 yrs until my last build. I even bought again after the wide spread nickel plating issue. Both of my 460gtx blocks pealed. EK stood up and replaced the blocks at no cost to me. I used EK fuel twice with the same results, I even gave it a second change. I love it when pups tell people with decades of experience how it is.

Those of you who had problems with EK Cryofuel gunk up, did you by any chance clean your loop with Mayhems Blitz Part 2 beforehand? I read on EK's site their coolant aren't compatible with that stuff for some reason. I'm just speculating this might be the outcome?
I only use a filtration loop with distilled water pumped through a 5 micro filter. Pump-res-rad-filter. I run the loop for 24hr for each rad.
 

Rig Advisor
Joined
3,492 Posts
Those of you who had problems with EK Cryofuel gunk up, did you by any chance clean your loop with Mayhems Blitz Part 2 beforehand? I read on EK's site their coolant aren't compatible with that stuff for some reason. I'm just speculating this might be the outcome?
Never used Cryofuel in any of my builds, however I would speculate that policy would be if someone failed to properly flush part 2 out after using. I find it hard to believe that if you flushed 3 times as suggested that any residual would be left to cause a reaction.
 

Registered
Joined
649 Posts
I always used EK Cryofuel, and always had crap blocking my CPU block fins. And temps were nothing to note.
Now I use plain distilled water. Temps are superb and no crap showing up.
 

Registered
Joined
1,587 Posts
I always used EK Cryofuel, and always had crap blocking my CPU block fins. And temps were nothing to note.
Now I use plain distilled water. Temps are superb and no crap showing up.
Take care with the pure distilled water, had my nickel start getting eaten when I ran that for too long. (cpu block & memory block)

As long as the Cryofuel prevents the Nickel corrosion it's gonna do it's job for my side on this.
 
  • Rep+
Reactions: Hale59
61 - 71 of 71 Posts
Top