Overclock.net banner
1 - 8 of 8 Posts

·
Registered
Joined
·
551 Posts
Discussion Starter · #1 ·
As im sure many of you know the 5850 has a problem with duel monitors where the 2D clocks drop too low and cause flicker if you have overclocked your card. The main fix for this is editing 2D clocks in your catalyst profile.

I have also discovered that flicker can also be cause by firefox causing clocks to jump to max and back down again. This can be fixed by going to options->options->advanced->general in firefox and unticking the "use hardware acceleration when available" box.

Hope this helps some1
smile.gif
 

·
Registered
Joined
·
545 Posts
Quote:
Originally Posted by Stevinchy;13111296
As im sure many of you know the 5850 has a problem with duel monitors where the 2D clocks drop too low and cause flicker if you have overclocked your card.

I have also discovered that flicker can also be cause by firefox causing clocks to jump to max and back down again. This can be fixed by going to options->options->advanced->general in firefox and unticking the "use hardware acceleration when available" box.

Hope this helps some1
smile.gif
interesting, ill have to try this, i was having flickering problems with my 5870 on 2 monitors. thanks
 

·
Registered
Joined
·
551 Posts
Discussion Starter · #3 ·
Quote:
Originally Posted by iamtwan;13111430
interesting, ill have to try this, i was having flickering problems with my 5870 on 2 monitors. thanks
Have you done the profile editing fix? That's what to do first, only try this if you still have flicker sometimes.
 

·
Registered
Joined
·
279 Posts
The flicker with multiple monitors using most ATI cards is caused by the memory speed changing when the card jumps from a powerplay state to the other.

I fixed that problem on my old HD4850 and my current HD5770 by flashing the BIOS with the same clock speed across all states.
 

·
Registered
Joined
·
551 Posts
Discussion Starter · #6 ·
Quote:
Originally Posted by xsever;13112177
The flicker with multiple monitors using most ATI cards is caused by the memory speed changing when the card jumps from a powerplay state to the other.

I fixed that problem on my old HD4850 and my current HD5770 by flashing the BIOS with the same clock speed across all states.
Correct, but with the 5850 when overdrive is disabled and you have 2 monitors the 2D clocks are 400/1000, when you enable overdrive the 2D clocks are 150/300 which is too low. You can fix this by editing your profile file for catalyst or by editing your BIOS.

What I was saying in this thread is that Firefox can cause jumps from 2D clocks to 3D clocks when hardware acceleration is enabled which is another source of flicker.

I am not saying this is a replacement fix just that is an additional fix to remove an extra source of flicker.

In your case you have your card running at full clocks all the time which would make this fix unnecessary. Some people may choose that they don't want to run their card at full speed the whole time (especially if it is highly overclocked) and this fix is for them.
 

·
Registered
Joined
·
279 Posts
My card still jumps between powerplay states but for the core only. 275 for idle, 400 for flash, and 970 for full load.

Only my memory stays at 1350 all the time.

Are trying to say that your problem is because the clocks are too low sometimes and not because the speeds are fluctuating? If so, what is the speed at which the flickering usually disappears?
 

·
Premium Member
Joined
·
15,008 Posts
Oh guys, I think I got the solution, if it's not too late.

I've been bothered by this aswell since I got the HD5870 and plugged in both screens.

Solution? Overclock via the CCC profile (X:/Users/(user)/AppData/Local/ATI/ACE/Profile.xml) with Overdrive disabled. No more memspeed jumps, and it rocks my socks. It also overclocks like a champ
biggrin.gif
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top