Overclock.net banner
1 - 4 of 4 Posts

·
Premium Member
Joined
·
8,451 Posts
Discussion Starter · #1 ·
Firefox all of a sudden started to display pages in german. The default Mozilla homepage as well as Google searches all come up in german; bookmarked pages are fine. Don't remember changing any language settings and the default browser language is english. Is there some other option I'm missing or did FF simply f'up?
 

·
Premium Member
Joined
·
18,611 Posts
Is it the URL changed to google.de or still google.com?
 

·
Premium Member
Joined
·
4,513 Posts
See if your connection has been put behind a proxy.
 
1 - 4 of 4 Posts
Top