Overclock.net banner
1 - 4 of 4 Posts

·
Registered
Joined
·
459 Posts
Discussion Starter · #1 ·
So i ordered an XSPC rasa kit from dazmode, its due to come in on friday. Upgraded it to have a dual 140mm radiator instead of the standard 120. Cant wait to get it and get it all up and running, so excited! Ive been lurking the forum for quite some time and have a general understanding of how to put it together and what to do but just in case could some of the gurus give me some pointers?

So far the plan is:
1) wash the radiator with hot distilled water by filling it and draining it 2-3 times while shaking it.
2) assemble the loop in my computer and with everything unplugged.
3) fill with distilled water and with tissues under all potential leak points run it for 2-3 hours to make sure its not leaking and bleed air bubbles.

I know i should tighten all the compression fittings a couple turns with a wrench after they're finger tight. making sure not to over tighten them. And i know i shouldn't run the pump dry and the loop should be filled little by little turning it on and off quickly to get the water flowing. Does that sound like a good build plan? I will post pictures of the build here when im doing it.

One question i have is i forgot to order the silver killcoil, would it be fine running with no treatment at all (kill coil or biocide) for about a week while i wait for that to ship?
 

·
Registered
Joined
·
50 Posts
Quote:
Originally Posted by Archer S View Post

So i ordered an XSPC rasa kit from dazmode, its due to come in on friday. Upgraded it to have a dual 140mm radiator instead of the standard 120. Cant wait to get it and get it all up and running, so excited! Ive been lurking the forum for quite some time and have a general understanding of how to put it together and what to do but just in case could some of the gurus give me some pointers?

So far the plan is:
1) wash the radiator with hot distilled water by filling it and draining it 2-3 times while shaking it.
2) assemble the loop in my computer and with everything unplugged.
3) fill with distilled water and with tissues under all potential leak points run it for 2-3 hours to make sure its not leaking and bleed air bubbles.

I know i should tighten all the compression fittings a couple turns with a wrench after they're finger tight. making sure not to over tighten them. And i know i shouldn't run the pump dry and the loop should be filled little by little turning it on and off quickly to get the water flowing. Does that sound like a good build plan? I will post pictures of the build here when im doing it.

One question i have is i forgot to order the silver killcoil, would it be fine running with no treatment at all (kill coil or biocide) for about a week while i wait for that to ship?
sounds like you have a good plan. Wash it for till you stop getting tiny black particles. I washed mine with cold ..i dont think it matters and i did it till i stopped getting those.. used whole 4L bottle for the RADs, lol...for the leak testing I would say atleast run it for 24 hours..n try to move the case a bit for bleeding..tube reservoirs are the best for bleeding air quickly..you'll notice the air moving in the loop when you move the case..also try to play with pump speed when bleeding it dislodges the stuck air. For compression fittings you don't need to overtighten them with wrench just finger tight is ok..it won't go all the way to the end and its not really suppose to..the o rings in them does the job. for the silver coil i aint really sure as I used coolant. cuz didnt wanted to mix up different metals for galvanization and EK had issues in the past with their nickel plated blocks getting messed up when there was silver coil used n they mentioned it on their site not to use silver coil with those..so I went the coolant way. I wouldn't risk it anyways if its gonna be still for a while. Good Luck my friend ..Keep us posted.
 

·
Registered
Joined
·
1,079 Posts
I been running my loop without a kill coil for 3 weeks now lol. Algae doesn't grow that fast. I have some mayhem in my closet but im upgrading my loop and dont want to toss it in yet lol.

I am emptying it out tomorrow because my 2nd sabertooth comes in
biggrin.gif


My usual steps with new WC parts are.

1 ~ boiling hot water into rad/block/pump

2 ~ shake it up.

3 ~ dump out

4 ~ (I use barbs) Put all tubing on to barbs

5 ~ Double zip tie it to the point of not going anywhere

6 ~ Real towel under my case

7 ~ Paper towel on top of gpu

8 ~ Jump PSU for 15 min without gpu/mobo on

9 ~ No leak, start rig up and watch for 3 hours. If nothing happens I clean up and done.
 
1 - 4 of 4 Posts
Top