Overclock.net banner

1 - 20 of 57 Posts

·
Registered
Joined
·
868 Posts
Discussion Starter #1
Ever since I set my BIOS to AHCI, I was plagued with my SATA connected drives showing up in the "Safely Remove Hardware" icon.

I understand that eSata, and USB devices should show up there. However, my internal devices, HDDs, CD/DVD/BluRay are showing up as well.

I didn't want to have to reinstall Windows 7, and set BIOS to SATA/RAID.
I wanted a better solution.
I found it!

This is a Registry fix.
You should ALWAYS back up your registry before you make changes - it only takes a second to do it, and if anything happens to it you'll need to reinstall...
Here we go...

Regedit your way to:
HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ services\ msahci
and create a new KEY called "Controller0"
inside Controller0, create a new KEY called "Channel0"
Now inside Channel0, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 0 (Drive C)to no longer show up in "Safely Remove Hardware")

Now, go back into the Controller0 folder again.
inside Controller0, create a new KEY called "Channel1"
Now inside Channel1, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 1 (Drive D)to no longer show up in "Safely Remove Hardware")

And so on, until all internal SATA ports are set to be treated as Internal.
My motherboard has 6 SATA ports, so I have set Channel0 to Channel5.

Here is an example of my registry change:

AHCIregedit.png


Your motherboard may have more or less SATA ports,
just remember to start with 0
6 Ports = 0-5 etc.

Now Reboot to allow changes.

Hooray! only external devices show up now!
 

·
Premium Member
Joined
·
5,330 Posts
Nice guide, and useful.

The only thing I would change is this bit:
Quote:
Originally Posted by t0adphr0g;12863711
If you are unfamiliar with changing your registry, back up your registry before proceeding.
You should ALWAYS back up your registry before you make changes - it only takes a second to do it, and if anything happens to it you'll need to reinstall...
 

·
Premium Member
Joined
·
5,330 Posts
smile.gif
 

·
Registered
Joined
·
645 Posts
Quote:
Originally Posted by t0adphr0g;12863711
Ever since I set my BIOS to AHCI, I was plagued with my SATA connected drives showing up in the "Safely Remove Hardware" icon.

I understand that eSata, and USB devices should show up there. However, my internal devices, HDDs, CD/DVD/BluRay are showing up as well.

I didn't want to have to reinstall Windows 7, and set BIOS to SATA/RAID.
I wanted a better solution.
I found it!

This is a Registry fix.
You should ALWAYS back up your registry before you make changes - it only takes a second to do it, and if anything happens to it you'll need to reinstall...
Here we go...

Regedit your way to:
HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ services\ msahci
and create a new KEY called "Controller0"
inside Controller0, create a new KEY called "Channel0"
Now inside Channel0, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 0 (Drive C)to no longer show up in "Safely Remove Hardware")

Now, go back into the Controller0 folder again.
inside Controller0, create a new KEY called "Channel1"
Now inside Channel1, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 1 (Drive D)to no longer show up in "Safely Remove Hardware")

And so on, until all internal SATA ports are set to be treated as Internal.
My motherboard has 6 SATA ports, so I have set Channel0 to Channel5.

Here is an example of my registry change:

AHCIregedit.png


Your motherboard may have more or less SATA ports,
just remember to start with 0
6 Ports = 0-5 etc.

Now Reboot to allow changes.

Hooray! only external devices show up now!
Does this work the opposite way as well? Can i create this setting in order to make external drives appear in safely remove by setting the option "1"? Cause i dont get the safely remove for the eSata drive i have connected...

Also can i use safely remove on internal drives as well if AHCI is not enabled? Can this be done, and is it safe?
 

·
Registered
Joined
·
645 Posts
I tried setting the value to 0 so that my esata drive gets the safe remove option and it didnt work. Any other way to do this? As i said i'm looking for the oppsoite effect so that i can safely remove esata drives on Windows.
 

·
Registered
Joined
·
868 Posts
Discussion Starter #9
Quote:
Originally Posted by vicrol123;13002759
work if I have a controller card for the raid?

Regards!
I created this fix with only the motherboard SATA stack in mind, Windows MSAHCI sees it as Controller 0. Does it see your RAID card as Controller 1? Then make a key accordingly.
Quote:
Originally Posted by therock003;13574068
Does this work the opposite way as well? Can i create this setting in order to make external drives appear in safely remove by setting the option "1"? Cause i dont get the safely remove for the eSata drive i have connected...

Also can i use safely remove on internal drives as well if AHCI is not enabled? Can this be done, and is it safe?
1. As far as your eSata drive, if it is plugged into SATA ports 0-6, and you want it to still be treated as external, then change the value to "0".

2. My "fix" is for systems that are running AHCI. If you are not running AHCI, this fix is not for you.
 

·
Registered
Joined
·
774 Posts

·
Registered
Joined
·
645 Posts
Quote:
Originally Posted by t0adphr0g;14836844
I created this fix with only the motherboard SATA stack in mind, Windows MSAHCI sees it as Controller 0. Does it see your RAID card as Controller 1? Then make a key accordingly.

1. As far as your eSata drive, if it is plugged into SATA ports 0-6, and you want it to still be treated as external, then change the value to "0".

2. My "fix" is for systems that are running AHCI. If you are not running AHCI, this fix is not for you.
Thanx man for getting back to me. As i said on my followup post i did set it up as 0 value but didnt quite work. It is plugged on ports 0-6 and i am working with AHCI enabled for these ports, so this seems odd.

BTW i havent created entries for each port. Just the one port i know the eSata drive is connected. And of course i did make a restart but still there was no sade remove option.

Could you think of any other reason this might not work for me? I'm on an AMD system, and have a gigabyte board. They seem to have issues. I also had an Intel Gigabyte and other strange things happened...
 

·
Registered
Joined
·
6 Posts
I know this is an old thread, BUT.. Do you or anyone else know a registry fix for a Marvell controller? My Marvell RAID 0 setup is showing up in the tray as a safely remove hardware icon as well. I only noticed it today for some reason. Not sure if it was there the whole time or not.
 

·
Registered
Joined
·
868 Posts
Discussion Starter #13
Quote:
Originally Posted by zoik View Post

I know this is an old thread, BUT.. Do you or anyone else know a registry fix for a Marvell controller? My Marvell RAID 0 setup is showing up in the tray as a safely remove hardware icon as well. I only noticed it today for some reason. Not sure if it was there the whole time or not.
I have a ASUS Sabertooth X58 motherboard, this also has a Marvell SATA 6 controller.

You just need to go into your Device Manager to turn off the "Safely Remove" function.

here I took a picture:

453

Open Device Manager, open Storage controllers, then just right click "Marvell 91xx...", choose properties, then go to the policies tab, and uncheck the box "Enable safely remove disk."

I would then reboot, to see the change.
 

·
Registered
Joined
·
221 Posts
the Intel Rapid Storage Technology only works on new motherboards not old ones like mine it wont install

but the regedit by t0adphr0g Worked PERFECT!!! i'm amazed.

i didn't want to mess with the regedit but i had no choice and it worked i'm so happy that it fixed my problem
smile.gif
I have been looking for DAYS now to fix that issue and with your help i was able to fix it.
i'm so glad there is people like t0adphr0g who share there knowledge on fixing these kind of things i really appreciate it for reals Thanks!

my problem started on this link http://www.overclock.net/t/1255982/intel-ssd-520-series-problem direct link http://www.overclock.net/t/1255982/intel-ssd-520-series-problem

i have 3 SSD and they all showed up in the remove hardware icon spot like this 274

and every time i shutdown my PC unexpected power loss and unsafe shutdown count would increase on all 3 Intel 520 Series SSD in the SMART part of the Intel Tool Box by 1 like this 458 direct link http://i45.tinypic.com/15i983k.jpg

i looked everywhere and on the Intel forums everybody is saying ignore it the smart values mean nothing its not important and that's normal i couldn't believe that its normal for the numbers to go up because in my laptop the numbers do not go up look 700 direct link http://i50.tinypic.com/2wck1ua.jpg
as you can see on my laptop the unexpected power loss and unsafe shutdown count do not go up just the power cycle count go's up every time i turn on my laptop now that's normal.

and the laptop does not show the usb remove icon so i figured that's my problem i used google and found this forum
smile.gif
and now its fixed the numbers no longer go up in the smart area just the power cycle count but i hope i fixed it on time that Intel wont tell me that my warranty is no longer good because of those numbers
frown.gif


Thank you So much!!! t0adphr0g you are Awesome!
 

·
Registered
Joined
·
41 Posts
This is in NO WAY resolve the Intel 520 problem.

Tested on GA-P67A-UD7-B3, no change at all.

Also, this issue have absolutely nothing to do with so called "warranty".
 

·
Registered
Joined
·
221 Posts
Quote:
Originally Posted by Gradius View Post

This is in NO WAY resolve the Intel 520 problem.
Tested on GA-P67A-UD7-B3, no change at all.
Also, this issue have absolutely nothing to do with so called "warranty".
i can try to help you
smile.gif

first check that you didn't use the Marvell Sata connectors i think its the white ones on your board and the esata not sure ?
second check that you installed windows 7 in ACHI mode under bios since that's the method i used not IDE or RAID
did you install a chipset driver (Intel Management Engine Interface) if so uninstall it and see if the stock windows drivers work for you (i'm using the stock ones there is no chipset driver for my board)
maybe try the Intel raid storage technology like others have stated here
do you have sata hot plug in your bios try disabling them all
if you have a old video card try using that one a faulty video card may cause windows to hang on shutdown
does your ssd show in safely remove hardware area ?

you can explain your problem in more detail to see what is going on

also i do not know about the warranty and Intel is aware of the unsafe shutdown count and other problems
but if it does not bother you then you can do what everybody on the Intel forums is doing and not worry about it
but it was killing me since my Notebook does not have that issue so i had to find a fix for me
biggrin.gif
 

·
Registered
Joined
·
6 Posts
Quote:
Originally Posted by t0adphr0g View Post

Ever since I set my BIOS to AHCI, I was plagued with my SATA connected drives showing up in the "Safely Remove Hardware" icon.
I understand that eSata, and USB devices should show up there. However, my internal devices, HDDs, CD/DVD/BluRay are showing up as well.
I didn't want to have to reinstall Windows 7, and set BIOS to SATA/RAID.
I wanted a better solution.
I found it!
This is a Registry fix.
You should ALWAYS back up your registry before you make changes - it only takes a second to do it, and if anything happens to it you'll need to reinstall...
Here we go...
Regedit your way to:
HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ services\ msahci
and create a new KEY called "Controller0"
inside Controller0, create a new KEY called "Channel0"
Now inside Channel0, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 0 (Drive C)to no longer show up in "Safely Remove Hardware")
Now, go back into the Controller0 folder again.
inside Controller0, create a new KEY called "Channel1"
Now inside Channel1, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 1 (Drive D)to no longer show up in "Safely Remove Hardware")
And so on, until all internal SATA ports are set to be treated as Internal.
My motherboard has 6 SATA ports, so I have set Channel0 to Channel5.
Here is an example of my registry change:
AHCIregedit.png

Your motherboard may have more or less SATA ports,
just remember to start with 0
6 Ports = 0-5 etc.
Now Reboot to allow changes.
Hooray! only external devices show up now!
if i am using WINDOW 7 64bit,under QWORD should 64 BIT VALUE?
 
1 - 20 of 57 Posts
Top