Overclock.net banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,223 Posts
Discussion Starter #1
is it me, or is everyone getting this flickering issue when crossfire is enabled? when i disable Crossfire, it goes away. i have two Gigabyte HD6950 1GB in CFX.
i never got this problem until a few days ago. i think they released an update to the game which broke Crossfire support?

i reinstalled the drivers the recommended way FEW TIMES (with or without 12.4 CAP1), even downgraded to 12.3, but still getting this. i wonder if something other than a game update or a ATI driver is causing this. Also, the amount of flickering differs from driver to driver. in 12.3, as was this video taken with, i can at least see what is going on. in 12.4, it is so hard to see what is going on.

i was able to fix it by reinstalling Windows but it came back. i cannot remember what i did. perhaps a different driver or software is causing this.
frown.gif


if i cannot find a fix, I'm thinking of swapping these cards for a single GXT670 or HD7970. i pretty much only play BF3 these days, and if i have to disable CF to get it to work, then there is no point of having CF after all.
 

·
Registered
Joined
·
420 Posts
My BF3 runs good but my BC2 flickers like that, I will have to keep an eye on this thread for a solution.
thumb.gif
 

·
Registered
Joined
·
1,223 Posts
Discussion Starter #4
Quote:
Originally Posted by grunion View Post

No flicker here, 12.1cat+12.4cap..
You using 1 bridge or 2?
Tested each card individually?
i'm using one bridge. the lower ones.

each card runs fine on its own.

i'll go back to 12.1 and see how they perform. seems like most people are sticking to 12.1. but i wonder why mine didn't have any issue until last week. this is the first time i have run across this flickering issue.

if all fails, i'm gonna ditch Crossfire and ATI altogether. raw FPS wise it will be a downgrade, but i need peace of mind.
 

·
Registered
Joined
·
1,223 Posts
Discussion Starter #5
I went home and installed 12.1 drivers. It did not work. I was lost at this point.

I went and reinstalled Windows once again. Then I tried to play safe.

First I installed the LAN driver, then VGA driver (stuck to 12.1 this time), Origin and downloaded BF3. I disabled Windows Updates for the time being. With this setup, there was flickering.

Then I installed the reset of the drivers. Still no problem.

Then I installed Windows Updates. Still no problem.

Then I installed all the general software. Still no problem.

Finally I installed MSI AfterBurner to see if it was causing the issue. (Although, when I had the issue before this, removing AfterBurner didn't fix the problem)
Again, no problem.

Also installed latest DX9 update. Still no problem.

Now everything is working as they should. I don't know what cause the problem. It is possible that 12.4 driver broke the OS and even when I removed it, it didn't go away.

BTW, when this problem was there, other games behaved differently.
3DMark11 would run without an issue. Crysis would not.
When I reinstalled OS back then, BF3 went bad, but Crysis did not.

From now onwards, I would not update ATI drivers unless,
1. it fixes an issue with a game that I have trouble with - there definitely will be in the future. (right now, I don't have an issue with BF3, which is the only game that I am playing)
2. it brings tangible performance gains for the games that I play
 

·
Registered
Joined
·
870 Posts
12.4 sucks. i did a fresh install removed it in registry and fully manually. Lets see how it is. my FPS is lower with 12.4 :|. We need new drivers! The entire 12.xx has been crap!
 
1 - 6 of 6 Posts
Top