Overclock.net banner

1 - 15 of 15 Posts

·
Registered
Joined
·
953 Posts
Discussion Starter #1
My folding setup is all messed up right now. I followed the guide to setup folding for multi GPU but when I click the second folding icon, labeled "[email protected] 2", it comes up with an error messaging saying:
[email protected] version 6.20r2

usage: fah6 [-option1][-option2]

Options: -config Configure information
-configonly Configure user information, then exit
-help Display this usage screen
-queneinfo Get information on queued work units
-delete x Delete item#x from work queue
-send x Send result #x to server then exit. Use x-all to send all resutls
-verbosity x Sets the output level, from 1 to 9 (max). Default: 3
-pause Pause after finshing and trying to send current unit
-oneunit Exit after completing one unit
-forceasm Force core assembly optimizations to be used if available
-advmethods Use new advanced scientific cores and/or wirk units if available
-gpu x Run GPU code on the specified display number

Please note the abolce recognized flags for when you start [email protected] again.

I'm very new to [email protected] and have no clue what I did wrong. I want to get folding set up for both my GPU's and CPU. Not sure how to do this, I also want to setup FahMon to monitor but I think I messed that up too. Any help would be greatly appreciated.
 

·
Premium Member
Joined
·
8,679 Posts
You should have "-gpu 0" for the 1st shortcut and "-gpu 1" for the 2nd. And use HFM, it calculates bonuses
 

·
Registered
Joined
·
953 Posts
Discussion Starter #4
Quote:


Originally Posted by lordikon
View Post

Sounds like your shortcut is messed up. Can you paste the exact shortcut you're using?

I'm guessing you want the shortcut target? If so here it is:

"C:\\Program Files (x86)\\[email protected]\\[email protected]\\[email protected]" -local -gpu1 -forcegpu nvidia_g80

Quote:


Originally Posted by mmx+
View Post

You should have "-gpu 0" for the 1st shortcut and "-gpu 1" for the 2nd. And use HFM, it calculates bonuses


I did that. It worked for a while and then I got all these weird errors and wouldn't open. I'll give HFM a try
 

·
Banned
Joined
·
12,758 Posts
Quote:


Originally Posted by kschat
View Post

I'm guessing you want the shortcut target? If so here it is:

"C:\\Program Files (x86)\\[email protected]\\[email protected]\\[email protected]" -local -gpu1 -forcegpu nvidia_g80

I did that. It worked for a while and then I got all these weird errors and wouldn't open. I'll give HFM a try

You need a space between "gpu" and "1", so -gpu 1, not -gpu1
 

·
Registered
Joined
·
953 Posts
Discussion Starter #6
Quote:


Originally Posted by lordikon
View Post

You need a space between "gpu" and "1", so -gpu 1, not -gpu1

oh good catch. Now it says "Process 2244 is currently running and may also be a client with Mach. ID 2. The program will now exit. Upon restat, this check will not be dont -- You may wish to check that no client is currently running in C:\\Users\\Kyle\\AppData\\Rpaming\\[email protected] before restarting." No clue how to fix this
 

·
Premium Member
Joined
·
2,659 Posts
Run the -config flag on the second card. Put in the info as you did before but when asked if you want to change the advanced options (think that's what it's called) tell it yes. Go through the steps until you come to machine ID and change it to 3. Then you can remove the flag and fold away.
 

·
Registered
Joined
·
953 Posts
Discussion Starter #8
Quote:


Originally Posted by AvgWhiteGuy
View Post

Run the -config flag on the second card. Put in the info as you did before but when asked if you want to change the advanced options (think that's what it's called) tell it yes. Go through the steps until you come to machine ID and change it to 3. Then you can remove the flag and fold away.

Sorry, how do I run the config flag? I'm guessing its using the console, but how do I get into the folding program to use the flag. Also I just closed the first folding GPU and restarted it because for some reason every time I restart it my name and team number reset. Now its giving me an error saying "The program can't start because cudart32_30_14.dll is missing from your computer. Try reinstalling the program and fix this problem." The error box is titled FahCore_15.exe - System error.

Edit: After I click ok two more error messages come up. The first says the same thing and then the second is a [email protected] error message saying " [email protected] has run into a serious error running the core. and will shutdown.
 

·
Premium Member
Joined
·
8,679 Posts
Or just edit the client.cfg file
 

·
Registered
Joined
·
953 Posts
Discussion Starter #10
Quote:


Originally Posted by mmx+
View Post

Or just edit the client.cfg file


where is this file located?
 

·
Registered
Joined
·
953 Posts
Discussion Starter #12
Ok, I got it all running. I reinstalled everything again. The problem is I had to copy the .dll files from appdata to the files that the folding clients were installed to. I'm having trouble getting HFM to monitor my graphics cards though. I downloaded SMP and its monitoring my CPU fine but nothing on my 460's.
 

·
Premium Member
Joined
·
46,114 Posts
Open the FAHlog for the 460s (rightclick the icon in the systray> My Status> Log File), and somewhere around the 16th line, it lists the active folder. Point HFM to that location.
 

·
Registered
Joined
·
953 Posts
Discussion Starter #14
Quote:


Originally Posted by zodac
View Post

Open the FAHlog for the 460s (rightclick the icon in the systray> My Status> Log File), and somewhere around the 16th line, it lists the active folder. Point HFM to that location.


It worked! Thank you! One more question and I'll get out of your hair. On my first GPU it says in the systray "GPU - [email protected]: Sleeping...". The icon is also different, what does this mean? Is it still folding?

Edit: Nvm I fixed it. Thank you everyone for all your help. +Rep
 

·
Banned
Joined
·
12,758 Posts
Quote:


Originally Posted by kschat
View Post

It worked! Thank you! One more question and I'll get out of your hair. On my first GPU it says in the systray "GPU - [email protected]: Sleeping...". The icon is also different, what does this mean? Is it still folding?

Edit: Nvm I fixed it. Thank you everyone for all your help. +Rep

Welcome to the team. That rig should net you at least 60-70k PPD if you're folding 24/7 with -bigadv WUs. That'd put you in the top 20 if you were folding 24/7.
 
1 - 15 of 15 Posts
Top