Overclock.net banner
1 - 12 of 12 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
So... I am building a computer for my friend. He has about a $400 budget, so we ordered the stuff from Newegg. The power supply that came with the case was fried. So we drove down to Fry's Electronics (best store ever) and bought an EchoStar power supply. Fried. Today we ventured down to Circuit City (last resort) and bought an Antec Truepower. GUESS WHAT?? It is fried. I am not a neanderthal, I know its not something I have done that messed the psu's up. My friend broke two mirrors in one day a few years ago, so I guess hes cursed. LOL
 

·
Old Timer
Joined
·
4,895 Posts
I cant beleave that they were all bad. Try this:

Plug the PSU's into a diferant wall outlet and jump the green wire on the 20/24-pin connector with any black wire on the same connector. Flip the PSU switch to 'on' if it has one and see if the fans spin up. If they do, its the motherboard or you forgot to plug something in. If not, its the PSU.
 

·
Premium Member
Joined
·
5,811 Posts
Quote:


Originally Posted by Blue_Fire

Mobo, or wall outlet. Or satan is after your friend, either way not your fault lol.

agreed... no way three fry in a row, something is prolly wrong with the MOBO...
 

·
Banned
Joined
·
4,795 Posts
yep yep, and i was the first to diagnose the problem
. if you got an antec, it wouldve worked off the bat and im speaking from experience
.
 

·
Registered
Joined
·
5 Posts
or havoc531 didnt plug the power button cable into the right spot. but his friend was smart enough to figure that out, right havoc531?
 

·
Premium Member
Joined
·
2,825 Posts
I can believe the generic PSU, and maybe the off brand one, but an ANTEC?!?!?!

but 3 is wayyy too many. make sure its hooked up right (power switch) and try a different outlet, when he gets another psu...

oh yeah, Kool-aid, you have a sweet monitor. 13 inches of goodness!
 
1 - 12 of 12 Posts
Top