Overclock.net banner
1 - 9 of 9 Posts

·
Premium Member
Joined
·
5,703 Posts
Discussion Starter · #1 ·
WHY IS CREATIVE SUCH A STUPID COMPANY! GRR! For the longest time my EAX console/drivers were really messed up and among other things they would default to 2/2.1 no matter how many times I set them to 5.1 (I have 5.1 speakers....) so I uninstalled EAX console and downloaded the newest installers for EAX console and Surround Mixer, but when I try to install either of them I get an error "Setup did not detect the required components, Setup will exit" ***H? Does anyone know what is causing this or how I can determine what is causing this stupid error?
 

·
Premium Member
Joined
·
5,703 Posts
Discussion Starter · #4 ·
Ok, it appears as if Creative being the geniuses that they are, do not provide the drivers on their site, only updates to them.....so I am SOL as it stands, maybe I can borrow pandapimp's Audigy 2ZS driver disc because I cannot find mine for the life of me
wish me luck I guess.
I seriously want to kill Creative right now, why can't they host the full drivers on their site?
 

·
Premium Member
Joined
·
4,730 Posts
this is the way creative has always operated... you have to have the original install cd, you can only get updates at their site

I posted some news about a new update they just released and it is basically the first download that doesnt require the install cd... http://www.overclock.net/sound-cards...udigy-2-a.html

but there was a patch for the very problem youre talking about... I know for a fact its in creatives download section

anyway, if you cant find what you need, you can always aim me and Ill try to grab the necessary files off of my install cd... I have an audigy 2 zs platinum but it should be compatible with your audigy 2 value
 

·
Premium Member
Joined
·
5,703 Posts
Discussion Starter · #8 ·
Trying out those drivers, as I said in your other thread, if they work mad reps for you!
 

·
Premium Member
Joined
·
5,703 Posts
Discussion Starter · #9 ·
Anyone having this problem follow THENUT's link, it fixed my problem! W00t you have no idea how happy I am, I was about to buy an XFI Fatal1ty because I thought my card was dead, and I was going to have to scrounge up $300 myself!
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top