Overclock.net banner
1 - 13 of 13 Posts

·
Banned
Joined
·
9 Posts
Discussion Starter · #1 ·
Hey guys, last night I turned off my pc and this morning 4 of my USB 3 ports on the back are not working. I have only 2 working for my mouse and keyboard, and the front ports connected to the case. I've updated to the latest BIOS, installed the newest drivers but all of my devices are still not recognizable. One of the two usb drivers didn't install though , it's the VIA USB driver. I got an error message which was I don't have the proper hardware or something like hardware not detected. Any help?
thumb.gif
 

·
Registered
Joined
·
24 Posts
Quote:
Originally Posted by The Salesman View Post

Oh no I forgot. Of course yes, numerous times unistalled them and installed them all over again. No luck.
Seems like its the same situation for me. Even on W7, the USB 3.0 ports would not recognise my peripherals once in a while. Rebooting would solve the problem...or changing the ports. Is that a driver issue?
 

·
Registered
Joined
·
986 Posts
This driver option did not work for me. I was going crazy because all of a sudden the 4 USB 3 ports on my gigabyte Z77X-UD3H just stopped working and I tried all of the solutions I could find here. I took a chance and opened up device manager and let it search for a new driver for the VIA host controller and it updated to a microsoft driver and behold I now have my USB 3 ports working again
 

·
Registered
Joined
·
2 Posts
From the gigabyte site:
VIA VL800 chip:
Up to 4 USB 3.0/2.0 ports on the back panel
* Due to a Windows 7 limitation, please connect your USB device(s) to the Intel controlled USB port(s) (located below the RJ-45 LAN port) before the VIA USB 3.0 controller driver is installed.
 
1 - 13 of 13 Posts
Top