Overclock.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,253 Posts
Discussion Starter #1
I got an error in grub when I installed fedora and I re-installed to try to fix it. Now Xp loads every time with no grub. How do I install a fresh grub?
 

·
Registered
Joined
·
2,292 Posts
the problem is that you have set windows as the default boot loader and not fedora core 6. Had the same problem. And grub is a boot loader, just incase he doesn't know.
 

·
Registered
Joined
·
1,253 Posts
Discussion Starter #4
I know whater it is, just not how to boot fedora. It isn't the same as Ubuntu loader? None appears.
 

·
Registered
Joined
·
2,292 Posts
Well now i am having the same problem. I have put int eh windows cd, because part opf my HD, that is unused is reading in windows now, and now it just boots straight to windows.
 

·
Premium Member
Joined
·
3,590 Posts
<div style="margin:20px; margin-top:5px; ">
<div class="smallfont" style="margin-bottom:2px">Quote:</div>
<table cellpadding="6" cellspacing="0" border="0" width="99%">
<tr>
<td class="alt2" style="border:1px inset">

<div>
Originally Posted by <strong>ravicus</strong>

</div>
<div style="font-style:italic">do you even know what grub is?</div>

</td>
</tr>
</table>
</div>Don't know if you meant that to be silly or what but it came off a bit rude...<br />
<br />
<div style="margin:20px; margin-top:5px; ">
<div class="smallfont" style="margin-bottom:2px">Quote:</div>
<table cellpadding="6" cellspacing="0" border="0" width="99%">
<tr>
<td class="alt2" style="border:1px inset">

<div>
Originally Posted by <strong>K092084</strong>

</div>
<div style="font-style:italic"> Well now i am having the same problem. I have put int eh windows cd, because part opf my HD, that is unused is reading in windows now, and now it just boots straight to windows.</div>

</td>
</tr>
</table>
</div>Windows probably erased grub, I don't quite understand want you did though.<br />
<br />
<div style="margin:20px; margin-top:5px; ">
<div class="smallfont" style="margin-bottom:2px">Quote:</div>
<table cellpadding="6" cellspacing="0" border="0" width="99%">
<tr>
<td class="alt2" style="border:1px inset">

<div>
Originally Posted by <strong>Firefly</strong>

</div>
<div style="font-style:italic">I got an error in grub when I installed fedora and I re-installed to try to fix it. Now Xp loads every time with no grub. How do I install a fresh grub?</div>

</td>
</tr>
</table>
</div>I know it maybe a bit of a hassle, but you could just reinstall Fedora and make sure that GRUB gets set up. It kind of odd though that you re-installed and then there is no GRUB.<br />
<br />
Use cd 1. When you get to the boot: prompt, type "rescue" or "linux rescue"<br />
Then type "grub-install /dev/hda" (or grub-install /dev/sda if SATA drive)<br />
<br />
One of these two site might help you.<br />
<a href="http://www.linuxforums.org/forum/linux-newbie/35065-there-way-installing-grub-bootloader-mbr-windows-knoppix.html" target="_blank">Link 1</a><br />
<a href="http://forums.fedoraforum.org/showpost.php?p=5538&postcount=1" target="_blank">Link 2</a>
 

·
Registered
Joined
·
1,708 Posts
I had that problem, too. I was dual-booting XP and Ubuntu (also uses GRUB), but then I installed Vista on a third partition (4th if you count swap) and it seems to have erased GRUB (MBR, anyone?) and can only load Vista or "Earlier version of Windows". I will be getting the alternate CD this afternoon and reinstalling GRUB with "rescue".
 
1 - 7 of 7 Posts
Top