Overclock.net banner

1 - 20 of 40 Posts

·
Registered
Joined
·
573 Posts
Discussion Starter #1
Download Nvidia Inspector 1.9.6.6.

Why use a fixed clock speed
World of Tanks without vsync. Default GTX670 on left. Forced clock speed on right.
6_compare-1.png


Performance modes
P8 = idle clock speeds and lowest power consumption
P2 = the default mode used when your PC boots or no drivers are installed.
P0 = Gaming/Load. This mode only accepts boost/offset values

Forcing specific modes
The command line is required to do this. Either run "cmd" and locate the directory containing nvidia inspector, or create a .bat file in its directory.

Force P8 (idle) nvidiaInspector.exe -forcepstate:0,8
Force P2 (custom) nvidiaInspector.exe -forcepstate:0,2
Return to Default nvidiaInspector.exe -forcepstate:0,16

Be sure to set all clock speeds back to default before running the last command above.

Setting a fixed overclock
First, find your maximum boost/memory offsets using the normal overclocking methods.

I'm going to apply a +135/+500 overclock which equals 1311mhz/3500mhz. Use your own values in place for the instructions below.

1. Force P2 mode using "nvidiaInspector.exe -forcepstate:0,2".

2. Open Nvidia Inspector and go to the P2 dropdown entry. It should look like this:
119o6sw.png


3. Click unlock Max and move the GPU clock to 1311mhz. You can try and move the Memory Clock but it simply bounces back. Hit Apply Clocks. Notice how the Current Clock on left is not the value you just set. If you do the math, it is exactly 135 below our target.
2_set_clock.png


4. The P2 mode still relies on your P0 boost setting to determine max clock speed. So, open that drop down and set your values. Once you click Apply it will now look like this:
3_set_boost.png


Using batch files for simple switching between power modes
Create the following batch files in your Nvidia Inspector directory.

overclock.bat
nvidiaInspector.exe -setBaseClockOffset:0,0,135 -setMemoryClockOffset:0,0,500 -setpowertarget:0,111 -setVoltageOffset:0,0,187500 -setGpuClock:0,2,1311 -setMemoryClock:0,2,3500 -forcepstate:0,2

force_idle.bat
nvidiaInspector.exe -forcepstate:0,8

default
nvidiaInspector.exe -setVoltageOffset:0,0,0 -setGpuClock:0,2,705 -setMemoryClock:0,2,3000 -forcepstate:0,16

The commands above are self explanatory. Simply adjust the offsets/values to suit. I use shortcuts to execute these batch files, making idle<->overclock an easy toggle. Even with forced idle clocks, blurays only use 20% gpu.

Overvolting
When your card exceeds 70c it starts to downclock AND downvolt. If you apply a maximum voltage offset of +187.5mhz, your card will no longer downvolt. It will still downclock, but a fixed voltage may solve stability issues if you are right on the edge.

Known issues

Using -resetAllPStates command does not work correctly.

Reverting to default P mode can sometimes, depending on what you did, lock your card at a specific clock speed. Simply reinstall drivers to fix (clean install not required).

There is a 1-2% performance loss using this method. I have no idea why. Stick to normal overclock methods if you want high benchmark figures.
 

·
Registered
Joined
·
573 Posts
Discussion Starter #2
Undervolting
To undervolt requires a bit of trickery. The voltage is calculated by your current clock speeds distance from your boost clock speed. Increasing your boost value or decreasing the P2 clock speed will adjust your voltage.

Normal overclock with stock voltage
5_undervolt_1.png


Decrease P2 clock speed and voltage is automatically lowered - this is Heaven stable for me
5_undervolt_2.png


Increasing boost decreases voltage at selected clock speed
5_undervolt_3.png
 

·
Registered
Joined
·
3,254 Posts
Hmm well thats actually pretty intresting. I noticed in Bf3 my 670 is all over the place as well sometimes, ESPECIALLY in Starcraft
 

·
Registered
Joined
·
12 Posts
Quote:
Originally Posted by whybother View Post

*reserved*
Hi,
first of all thanks for a nice guide.
Do you know how to make your batchcommands apply for two gfx-cards in an SLI setup? Currently only GPU1 responds when executing them.

Thanks
 

·
Registered
Joined
·
527 Posts
Great guide, thanks! I'm using this in a batch file to force +118 and +444 offsets (1178 and 3445) for my GTX 690 with 135% power target

Code:

Code:
"C:\Program Files (x86)\nvidia inspector\nvidiaInspector.exe" -setBaseClockOffset:0,0,118 -setMemoryClockOffset:0,0,444 -setpowertarget:0,135 -setVoltageOffset:0,0,187500 -setGPUClock:0,2,1178 -setMemoryClock:0,2,3445 -forcepstate:0,2

"C:\Program Files (x86)\nvidia inspector\nvidiaInspector.exe" -setBaseClockOffset:1,0,118 -setMemoryClockOffset:1,0,444 -setpowertarget:1,135 -setVoltageOffset:1,0,187500 -setGPUClock:1,2,1178 -setMemoryClock:1,2,3445 -forcepstate:1,2
now if only there were a way to stop it from downclocking at each temperature increase!

Edit: also, does anyone know if it's safe to run EVGA Precision or MSI Afterburner just to get the FPS/clocks overlay in games via RT statistics server? or will it mess up the NVInspector settings?
 

·
Registered
Joined
·
573 Posts
Discussion Starter #7
Quote:
Originally Posted by kribol01 View Post

Hi,
first of all thanks for a nice guide.
Do you know how to make your batchcommands apply for two gfx-cards in an SLI setup? Currently only GPU1 responds when executing them.
Thanks
Sorry for late reply. You simply need to add the settings for each card. The first number in each command is the card. So, to force idle for both would require:

nvidiaInspector.exe -forcepstate:0,8 -forcepstate:1,8
 

·
Registered
Joined
·
573 Posts
Discussion Starter #8
Quote:
Originally Posted by s74r1 View Post

Great guide, thanks!
Glad you found it useful.

I tried running without this method for a bit, but the latest drivers suck. My card kept sticking at random clock speeds when idle, giving rather high temps and a noiser than desired fan. I'll be using this method until Nvidia get their act together.
 

·
Registered
Joined
·
527 Posts
Actually, my readings were off. the clocks DON'T downclock with temperature like boost clock does!!! holding steady at 1163MHz on both GPU's now.

much better keeping a consistent clock, especially with a 690 since two fluctuating clock rates can't be good for micro-stutter. but I wish I could increase the power target more than 135%
frown.gif
my GPU0 still fluctuates down sometimes...

as for power management, I just use Nvidia Inspector's Multi Display Power Saver to force idle clocks.
 

·
Registered
Joined
·
65 Posts
Are you sure that temp doesn't cause throttling? I reached 80 when overclocking mine using this method, and when I looked at my core clock on GPU-Z it showed that my clockspeed was around 30 Hz less than it should have been during most of the Heaven benchmark.

On that note, is it possible to create a fan profile without a programs such as Precision X? It seems that when I start Precision X my overclock is disabled, though I remain in the same power state instead of going to idle. Without a good fan profile, however, I'm doomed to have throttling due to high temps.

Further, I have a 670FTW with a power target of 145%. When I attempted to overclock using this guide I was only able to achieve a boost of +55 on the core with many oscillations, even though my temps were below 70, my voltage was maxed out, and my power target remained under 110%. That is why I had hope in this method, to be able to force my card to stay at a higher and consistent clock speed. Does anyone have any clue why my card won't overclock well? Is there anything I can do?
 

·
Registered
Joined
·
1 Posts
Hello Whybother, i need advice. i tried to play Guild Wars 2 with my Asus gtx670 DC2 Top model GPU. But i got so many driver crash error while playing. Yesterday i noticed that my card did auto turbo boots while im playing GW2 and reached 1250 Mhz clock speed. Thats why i keep getting driver crash errors. So i need to disable my turbo boots and want to play with stock clock speed.

Can you help me with that?

i just wrote on cmd " ...nvidiainspector - forcepstate:0,2" and set P2 clock to 1058 Mhz should i do something else?

Also when i restart computer all changes reseted? my Gpu will have turbo boots again... ?
 

·
Registered
Joined
·
3 Posts
My video card (GT 650m) only shows 3 available power states, P8 (idle) P5 (performance level 1) and P0 (performance level 2). P0 is completely greyed out so I can't OC while maintaining my ability to idle. If I want to OC I have to force it to P5 and then OC P5.... this works, but isn't ideal. Ideally I would be able to access the P0 clock frequencies, so if anyone know how to get access to them (remember they are greyed out) that would be awesome. Another solution would be to make P5 the max power state not the all time power state, in other words it would still idle at P8 then under load go to P5 but not continue on the P0 (P8 > P5 instead of P8 > P5 > P0 like stock), is there anyway to set a power state "ceiling" vs forcing it into a single power state all the time?
 

·
Registered
Joined
·
301 Posts
Good job, awesome guide. It helps for games like WoW where my core clock just stays at 980Mhz. No more of that with an OC and a default profile .bat file
smile.gif
 

·
Registered
Joined
·
628 Posts
I just wanted to thank you. Had some problems with the card not clocking up properly when playing bfbc2 using msi ab. Low gpu usage I guess that was the reason.

I started using this because I had some fluctuations in fps, which imho I shouldnt have.

Anyways I have created 2 .bats, only way to get it to work 100% of the time is running them after eachother, I have no idea why:

nvidiaInspector.exe -setBaseClockOffset:0,0,100 -setMemoryClockOffset:0,0,200 -setpowertarget:0,111 -setGpuClock:0,2,1275 -setMemoryClock:0,2,3000 -forcepstate:0,2

and

nvidiaInspector.exe -setBaseClockOffset:0,0,100 -setMemoryClockOffset:0,0,400 -setpowertarget:0,111 -setGpuClock:0,2,1267 -setMemoryClock:0,2,3405 -forcepstate:0,2

Mind you ab is still running and this works fine.
 

·
Registered
Joined
·
1 Posts
Thanks for the tip! I have a GTX 690, watercooled, running at below 35 degrees even overclocked... but no matter what I do, the 2nd core will not clock past 324MHz according to nvidiaInspector. I ran the command line posted here and that worked fine to overclock the first core, but the second core doesn't budge. And yes, I did set the GPU index to 1 instead of 0. :) Any ideas?
 

·
Registered
Joined
·
573 Posts
Discussion Starter #17
Sorry, I forgot about this thread.

I've never tried using SLI so am not sure why it doesn't work.

Conditioned - I think you need to increase the baseclockoffset from 100. That should allow a single instance to work.

I've been running these for the past 6 months without issue. I have idle.bat executed on boot and a shortcut to each placed in start menu.

idle:
nvidiaInspector.exe -forcepstate:0,8

overclock:
nvidiaInspector.exe -setBaseClockOffset:0,0,125 -setMemoryClockOffset:0,0,600 -setpowertarget:0,112 -setVoltageOffset:0,0,187500 -setGpuClock:0,2,1295 -setMemoryClock:0,2,3600 -forcepstate:0,2

One more reason to use a fixed clock speed - video playback.

The default Nvidia clock speeds for video produces excessive amounts of tearing for me, which also exists in idle mode. By forcing a fixed clock speed all tearing is gone in VLC, MPlayer, Flash etc.
 

·
Registered
Joined
·
1 Posts
Hi there. I've read this guide and absolutely love it. Is there a command with nVidia inspector that I could use to stop it forcing the power state? Would I have to reinstall the driver or delete nVidia inspector?

Any tips would be nice.

Update: I decided to a full driver sweep, since I needed to update my GPU driver anyway.
tongue.gif
 

·
Pink Freud
Joined
·
2,698 Posts
Nice guide. Are you still maintaining it?

Is there other methods, like a BIOS flash?

By the way, I'm talking about undervolting
biggrin.gif
 
1 - 20 of 40 Posts
Top