Overclock.net banner

21 - 40 of 4332 Posts

·
Meddling user
Joined
·
7,423 Posts
Discussion Starter #22
Quote:
Originally Posted by OneB1t View Post

not all but few are now editable (pls check result rom by reloading into app but it should be allright
smile.gif
)
Thanks for new updated Hawaii app!
smile.gif


Quote:
Originally Posted by Shodin10k View Post

OMG, thank you for the newest version of the app. Editable tables!
I will be adding to post 1 information concerning conventions I'm seeing in varying manufacturer 290 / 290X roms to set the DPM 0 -7 Freq.



On the left is table for Stock AMD R9 290X bios, middle is Vapor-X R9 290X STD Edition and right is the Vapor-X 290X OC Edition.

When manufacturers create a OC bios GPU Freq for DPM 0 & 1 will always be 300 MHz & 516 MHz . DPM 2 -7 will be the percentage shown of DPM7.

For example if I was setting GPU clock as 1100 Mhz then DPM7 would be this then DPM 6 would be 1100 x 97.7% = 1074.7 (rounded up to 1075) .

RAM Freq DPM 0 is always 150MHz and DPM1-7 are full RAM speed.
 

·
Meddling user
Joined
·
7,423 Posts
Discussion Starter #24
It looks like I've got the GPU core voltage offset mod I was after!
biggrin.gif


My stock bios offset of +31mV was not enough to get me 1100MHz / 1525MHz , but now with the bios set to +44mv!
Will be adding info to post 1 after some more testing!
smile.gif
.
 

·
Registered
Joined
·
2 Posts
Thanks for this guide, i've tried to modify the temp and rpm values of the bios of my r9 290 vapor-x OC, to stop the fans in idle, but it didn't work. There are some other value to modify to have full controll on the rpm and stop the fans?
 

·
Meddling user
Joined
·
7,423 Posts
Discussion Starter #27
Quote:
Originally Posted by JrtOC View Post

Thanks for this guide, i've tried to modify the temp and rpm values of the bios of my r9 290 vapor-x OC, to stop the fans in idle, but it didn't work. There are some other value to modify to have full controll on the rpm and stop the fans?
No idea, sorry.

On my Vapor-X 290X it has a switch to enable outer fans to stop spinning at low gpu usage.



Your Vapor-X 290 also has this feature / switch.
 

·
Registered
Joined
·
2 Posts
Thanks for reply, i know i can stop the external fans, but even with only one fan spinning, the gpu is more noisy of all my system. I've set the first rpm to 0 in the bios and in the catalyst i can see fan speed 0% but the fan still spinning at 20%, i've tryed to modify the fan speed with MSI Afterburner, speedfan and sapphire trixx, but didn't work. I suppose there are some other values to set min rpm to 0, or to control the fans separately but i can't find them anywhere.
 

·
Meddling user
Joined
·
7,423 Posts
Discussion Starter #29
Tried a test in VBE7 to see what values change on a 7970 rom when fan profile edited to have minimum of 10% and it changes %rpm1 hex values that are in the fan profile editing in post1. As some things in post one where sussed by doing this and checking for comparable in 290 / 290x rom.

Those values you've edited anyhow, so like you would think there is a setting in bios which forces a minimum of 20%.

Difficulty in searching the rom is it could be a D0 07 you're looking for or a 14.

I too have tried setting MSI AB , Sapphire TriXX to lower % but it doesn't work.

*** edit ***

To all other viewers in further testing phase for voltage editing to bios and will soon be adding information to post 1.
 

·
Registered
Joined
·
30 Posts
Got a 290 trix a few days ago and planed to under-volt it.
After reading a bit it seemed that all AMD bioses are locked via signature. Later I found out that was not the case anymore for the Hawaii chips. Just to then find out that there is no bios editor out for it... oh well

Seems you could become my savior just in time.
biggrin.gif


All the tools like Sapphires Trixx kind of work to test voltages and gpu/ram clock. But they have to many quirks for me and I also use the GPU under Linux.
The idle status seems to be my current unvervolt limit for the ram when working with offset voltage. I guess that has to do with the ram speed being at max for anything except the lowest power mode.

With trixx I'm currently running 1000/1200 with -75mv (native this card runs 1000/1300 + 12mv)

I am curious how far I can undervolt with full access to the dpm tables!
 

·
Meddling user
Joined
·
7,423 Posts
Discussion Starter #31
Sapphire roms usually have a GPU core voltage preset in rom (VoltageObjectInfo hex values 8d 00 xx 00 , xx convert to dec x 6.25mv gives you offset).

If it does not have an offset in bios the voltage controller can be preprogrammed from factory, you can adjust voltages down / up taking that into consideration.

Post 1 has currently lack of content for Voltage editing heading but will soon be sorted this week
biggrin.gif
.

OneB1t has done some tests to how low you can go, he should get notification of your post and be along with info
wink.gif
.
 

·
Registered
Joined
·
30 Posts
In my bios Rom I only have one value of 8d 00 xx 00 where xx is not 0. And that value is 2. Which would fit the +12mv that I get shown when I open Trixx because it only shows full mv values.

What really bugs me right now is the UVD voltage:

Furmark
standard (+12mv) 1.070 - 1.102 V
Undervolted (-75mv) 1.016 - 1.023 V

UVD (Youtube video via html5 player)
standard (+12mv) 1.211 - 1.219 V
Undervolted (-75mv) 1.133 - 1.141 V

That looks so much wrong...
 

·
Registered
Joined
·
3,398 Posts
Would flashing my card's bios to Sapphire's 390 change the behavior of my fans? I mean, would they turn off @idle like they do on the 390 Tri-X?
 

·
Meddling user
Joined
·
7,423 Posts
Discussion Starter #34
Quote:
Originally Posted by Osbios View Post

In my bios Rom I only have one value of 8d 00 xx 00 where xx is not 0. And that value is 2. Which would fit the +12mv that I get shown when I open Trixx because it only shows full mv values.
xx is just to denote unknown , for example it could be 04 , 06 , etc

As yours is 02 yes it equates +12.5mv, MSI AB / Sapphire TriXX don't show the after the values after decimal point , MSI AB will show 12.5mv as 13mv, I think you get the idea
wink.gif
.
Quote:
Originally Posted by Osbios View Post

What really bugs me right now is the UVD voltage:

Furmark
standard (+12mv) 1.070 - 1.102 V
Undervolted (-75mv) 1.016 - 1.023 V

UVD (Youtube video via html5 player)
standard (+12mv) 1.211 - 1.219 V
Undervolted (-75mv) 1.133 - 1.141 V

That looks so much wrong...
Looks right to me, -75mv equals -0.075v , Link:- http://www.rapidtables.com/convert/voltage/mv-to-volt.htm .

Whats The Stilt states:-
Quote:
Forgot to mention that you will never achieve a FULL control over the power management on these cards. The driver will perform certain adjustments without the user knowing about it.
From post Link:- http://forums.guru3d.com/showpost.php?p=5120403&postcount=614
Quote:
Originally Posted by Ha-Nocri View Post

Would flashing my card's bios to Sapphire's 390 change the behavior of my fans? I mean, would they turn off @idle like they do on the 390 Tri-X?
It could be possible , but what we are struggling with is AtomDis we're using is really old.

It excludes some updates for hawaii, we can see the updates on git repositories but can't get them.

You can dump certain tables into atomdis for parsing but it spews out incorrect info (or we don't understand it yet) due to it being a 2009 edition (if that makes sense).
 

·
Meddling user
Joined
·
7,423 Posts
Discussion Starter #36
Ahhh , sorry got wrong end of stick.

I think Furmark and some other tests like that get limited by the driver, IIRC I have read info on web relating to this, have a google and you will find it.
 

·
Registered
Joined
·
26 Posts
Just wanted to say thanks gupsterg for keeping this thread up to date. I know the guru3d thread has a better following, but I like how you compiled all the information here.
 

·
Meddling user
Joined
·
7,423 Posts
Discussion Starter #38
No worries
smile.gif
, that threads what kicked it off as you know.

For some one new to that thread it's alot of posts/pages and some info they'd have to stitch together as it came in / got discovered in thread.

Here I can edit post 1 to have everything and OCN forum support attaching pic/files on their server it's just easier.

Will be replicating it there soon
wink.gif
.
 

·
Registered
Joined
·
168 Posts
Following the syntax ./atomdis hawaii.rom |>output.txt is not outputting anything to the text file

help?
 

·
Meddling user
Joined
·
7,423 Posts
Discussion Starter #40
You don't use | you use l , the character is lower case L not vertical bar.

./atomdis hawaii.rom l >output.txt

there also must be space between l and > .
 
21 - 40 of 4332 Posts
Top