Overclock.net banner

1 - 13 of 13 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
I upgraded from Windows 7 to Windows 10 yesterday just to see if I liked it and that everything would work. The upgrade was flawless and after disabling all the privacy options I could and updating the Nvidia driver to 353.62, I tried to load Final Fantasy XI.<br><br>
Playonline launches and I can go through the process of logging in but the game won't launch after selecting (closes Playonline to launch FFXI). Instead, a pop-up partially loads, mentioning installation of DirectPlay, but is immediately 'Not Responding'. Opening the Task Manager to end the task doesn't help as this hangs also, along with almost everything else. So I reset the pc, and use google to find out that DirectPlay is a legacy component required to play the game similar to Windows 8.<br><br>
Attempting to install DirectPlay gives the following response:<br><div class="quote-container"><span>Quote:</span>
<div class="quote-block">Windows couldn't complete the requested changes<br>
The function attempted to use a name that is reserved for use by another transaction<br>
Error code: 0x80071A90<br>
'tell me how to solve this problem' (this is a link)</div>
</div>
<br>
clicking on the link opens a web page referring to completely different error codes regarding .NET Framework 3.5.<br><br>
Does anyone know how to get DirectPlay working in Windows 10?<br><br>
Any help would be most welcome.
 

·
Registered
Joined
·
1 Posts
Hello Mitch311,<br>
I faced the same problem. I following steps resolved the issue for me:<br><br>
1) Install DirectX run time library from Microsoft's site :<br><a class="bbcode_url" href="http://www.microsoft.com/en-us/download/details.aspx?id=35" target="_blank">http://www.microsoft.com/en-us/download/details.aspx?id=35</a><br><br>
2) Restart the machine<br><br>
3) Run your game, when asked to install DirectPlay confirm and you will be ready to play
 

·
Registered
Joined
·
60 Posts
Discussion Starter #3
<div class="quote-container" data-huddler-embed="/t/1568181/help-installing-directplay-on-windows-10#post_24265863" data-huddler-embed-placeholder="false"><span>Quote:</span>
<div class="quote-block">Originally Posted by <strong>istofix</strong> <a href="/t/1568181/help-installing-directplay-on-windows-10#post_24265863"><img alt="View Post" class="inlineimg" src="/img/forum/go_quote.gif"></a><br><br>
Hello Mitch311,<br>
I faced the same problem. I following steps resolved the issue for me:<br><br>
1) Install DirectX run time library from Microsoft's site :<br><a class="bbcode_url" href="http://www.microsoft.com/en-us/download/details.aspx?id=35" target="_blank">http://www.microsoft.com/en-us/download/details.aspx?id=35</a><br><br>
2) Restart the machine<br><br>
3) Run your game, when asked to install DirectPlay confirm and you will be ready to play</div>
</div>
<br>
Thanks for this. I reverted back to Windows 7 but I'll update to 10 again and give it shot tonight when I get home from work. <img alt="thumb.gif" class="bbcode_smiley" src="http://files.overclock.net/images/smilies/thumb.gif">
 

·
Registered
Joined
·
154 Posts
I was having issues with DirectPlay as well. It would hang Windows every time i launched FFXI and said it needed to install it.<br><br>
I followed this <a class="bbcode_url" href="https://youtu.be/6XYyGB-Tn3g" target="_blank">youtube</a> and it works now.<br><br>
Basically<br><br>
1. Right click Start<br>
2. Click Programs and Features<br>
3. Click Turn Windows features on or off<br>
4. Make sure there is a check in Legacy Components<br>
5. Click the + to expand<br>
6. Check the box for DirectPlay
 

·
Registered
Joined
·
1 Posts
Sorry for lobbing in on your thread, but I was trying to decide if I need to install DirectPlay on my Windows 10 box.<br><br>
What games need direct play? Doesn't it come with the DirectX 9.0 runtime? Or is DirectPlay for even older apps and games?
 

·
Registered
Joined
·
3 Posts
I am also having this issue when I go to play AOE. But I have done everything above, and mine still wont work.<br><br>
My directplay in the legacy components when I check it just comes up with an error and wont install.
 

·
Registered
Joined
·
1 Posts
<div class="quote-container" data-huddler-embed="/t/1568181/help-installing-directplay-on-windows-10#post_24288509" data-huddler-embed-placeholder="false"><span>Quote:</span>
<div class="quote-block">Originally Posted by <strong>JimmyWild</strong> <a href="/t/1568181/help-installing-directplay-on-windows-10#post_24288509"><img alt="View Post" class="inlineimg" src="/img/forum/go_quote.gif"></a><br><br>
1. Right click Start<br>
2. Click Programs and Features<br>
3. Click Turn Windows features on or off<br>
4. Make sure there is a check in Legacy Components<br>
5. Click the + to expand<br>
6. Check the box for DirectPlay</div>
</div>
<br>
I had trouble installing DirectPlay for Windows 10 and this forum was the first hit. You follow this method but make sure you disable your antivirus temporarily to install it. I have Avast, and apparently something with Windows 10 and Avast prevents DirectPlay from installing unless you disable your antivirus. Before I disabled it it would always turn up an error and link me to a .NET 3.5 install on Microsoft's website.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #8
<div class="quote-container" data-huddler-embed="/t/1568181/help-installing-directplay-on-windows-10#post_24405298" data-huddler-embed-placeholder="false"><span>Quote:</span>
<div class="quote-block">Originally Posted by <strong>zaonhort</strong> <a href="/t/1568181/help-installing-directplay-on-windows-10#post_24405298"><img alt="View Post" class="inlineimg" src="/img/forum/go_quote.gif"></a><br><br>
I had trouble installing DirectPlay for Windows 10 and this forum was the first hit. You follow this method but make sure you disable your antivirus temporarily to install it. I have Avast, and apparently something with Windows 10 and Avast prevents DirectPlay from installing unless you disable your antivirus. Before I disabled it it would always turn up an error and link me to a .NET 3.5 install on Microsoft's website.</div>
</div>
<br>
I've not reinstalled Win 10 since the original attempt. Wasn't so keen on some of the other 'features' so have stayed with Win 7 for just now. FFXI is the only reason keeping me on a Windows OS so once support for it ends next year I may just move to Linux full time.<br><br>
I too have Avast installed and disabling AV (or is it Avast specific?) to get a Legacy Windows component to install just seems bizarre to me but if it works then at least people who want to upgrade can do so. Thanks for sharing<br><br>
Cheers <img alt="thumb.gif" class="bbcode_smiley" src="http://files.overclock.net/images/smilies/thumb.gif">
 

·
Registered
Joined
·
180 Posts
I didn't have an issue with installing DirectPlay when requested upon starting Rollercoaster Tycoon. If the add remove features isn't working for you, though, you could try the command line method:<br><br>
dism /Online /enable-feature /FeatureName:"DirectPlay" /NoRestart<br><br>
Or if that doesn't work you could try and perform it via a Windows 10 install USB and instead of /Online you use /image: i.e. <b>dism /image:C:\ /enable-feature /FeatureName:"DirectPlay"</b> and reboot back into the OS. I've not installed DirectPlay to an offline image but have done .NET 3.5 "netFX" via dism without an issue so see why DP should work.
 

·
Registered
Joined
·
1 Posts
<div class="quote-container" data-huddler-embed="/t/1568181/help-installing-directplay-on-windows-10#post_24394543" data-huddler-embed-placeholder="false"><span>Quote:</span>
<div class="quote-block">Originally Posted by <strong>Needhelp101</strong> <a href="/t/1568181/help-installing-directplay-on-windows-10#post_24394543"><img alt="View Post" class="inlineimg" src="/img/forum/go_quote.gif"></a><br><br>
I am also having this issue when I go to play AOE. But I have done everything above, and mine still wont work.<br><br>
My directplay in the legacy components when I check it just comes up with an error and wont install.</div>
</div>
<br><br>
First disable your antivirus software. I was just able to resolve this issue that way.
 

·
Registered
Joined
·
1 Posts
I too received the error message about the feature name being reserved. Temporarily disabling Avast, and then attempting to enable Direct Play again worked for me.
 

·
Registered
Joined
·
2 Posts
Hello everyone, I am jumping onto this party train a bit late, but I'm here nonetheless.
I recently tried to install Icewind Dale 2. Once installed Windows 10 is asking me to install DirectPlay. I have tried all of the suggestions here; Disable the antivirus and install via the Programs and Features and then check the Legacy Components, I have gone to Microsoft and downloaded the Microsoft DirectX.
The DirectX would not install saying a newer version was installed and this version will not installed.
The disabling of the antivirus and then checking the Legacy Components and then ticking the Direct Play option. This just opens a window and gives me; Windows Features- Searching for Required Files..and that been looking now 20 mins and then tells me that the required files were not found.

This is a very odd thing to show me, as I can play the older games Baldur's Gate 1 & 2, even Icewind Dale 1 all of which are years older than IWD2. They do not require DirectPlay. Has anyone a solid fix for this?

Regards,
Mereinid
 
1 - 13 of 13 Posts
Top