Overclock.net banner

HELP , is it dead?? p6t

545 Views 11 Replies 9 Participants Last post by  ghost55
hi guys i am about to panick, i have this build that i have been getting together to give as a present to a family member.
its made of a p6t deluxe v2, 920 d0, 6Gb g.skill 2000mhz, now the problem the system is not starting up, there is lights on the onboard power and reset buttons but when you press them nothing happens, eventually when it does seems its going to power up, all it does is spin the fans but no image , no lights on the undeneath the memory to say that its started up like it usually does.

it was workign fine about an hour ago

also this is all outside the case and its sitting on my desk on top of a anty static bag

any help??

i was giong to give it to them on wednesday

also i have tried the components on my evga classified and it worked so its def the motherboard
1 - 12 of 12 Posts
Put the RAM in slots 2/4/6 instead of 1/3/5.
EDIT, oh it was once working? Nevermind then.
Try resetting the CMOS, and updating the BIOS if you get it working again.
tried resetting the cmos, all it does is spin the fans once i power up the system and them nothing
anyone else

EDIT: to make matters worse, i juts spilled freeser one liquid coolant on the motherboard
this is so not my day. i supose the liquid wont damage anything as its non conductive? it did spil over 30% of the board but didint go inside any slots or anything
See less See more
this may sound silly, but is the power button connector you are using connected properly? You said its outside on an anti static bag, so perhaps something as small as that could cause nothing happening.
nope not that,

the lights on the motherboard power and reset button are on, but when you press the pwer button the it dosent power up
See less See more
Did you try only 1 stick of RAM? Try that. If 1 doesn't work, try another. I had brand new RAM go bad once. Just like you said. Worked on initial boot up, never worked after.
antistatic bags are ONLY anti-static IN the bag, not out.

I would suggest throwing the system into a case, maybe there is a grounding problem with something on the bottom of the motherboard?

what initially caused it to stop working? did you adjust something? maybe bump the system?
Did you pull the battery? I know my GENE has the cmos switch and that didnt work for me, my board did the same til I reset via battery.
Get it off the anti-static bag and test it.

Reset CMOS by pulling battery out

Check RAM sticks one by one(insert only 1 RAM stick)

Possible power supply issue?

edit: remove/unplug anything unnecessary, that means optical drive, hard drives, sound card, etc. Just have only mobo, RAM, CPU, graphics card, and PSU and see if it boots.
are you standing on a rug while you ork? if so, you may have fried your mobo
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.