Overclock.net banner

1 - 15 of 15 Posts

·
No desktop currently :(
Joined
·
2,134 Posts
Discussion Starter · #1 ·
Today I decided to begin my grand Linux adventure
I use Ubuntu 9.10 regularly at school, so I decided I would use Kubuntu 9.10 as my home distribution so I can get both the KDE and GNOME experience. The computer I installed it on uses a 90nm 3.0GHz P4 w/ 1.5GB DDR333 and has a 8600GT.

I installed it as a dual-boot with WinXP, and everything worked just fine. I installed the newest packaged Nvidia driver from the repo (version 180?) and that went without a hitch. The problem came up when I went into the display settings to try to set the resolution to my CRT monitor's native resolution of 1280x1024 @ 75 Hz. In the settings, the maximum resolution I could set it to was only 1024x768 @ 60 Hz


I looked in both the Nvidia control panel and Kubuntu's own display settings to no avail. I googled around and tried some things in the terminal that were supposed to fix the problem, but I ended up borking the Kubuntu install, so I formatted the partition and reinstalled.

This time, I thought I'd try the newest, non-packaged driver straight from Nvidia (195.36.15). I successfully installed it, (which taught me quite a bit) but now I have the same problem, only worse. The max resolution I can get is now 640x480 @ 50Hz


I've tried a couple more supposed "fixes" and none of them do anything. Can some local Linux guru help me out here?
 

·
No desktop currently :(
Joined
·
2,134 Posts
Discussion Starter · #2 ·
As a development, I used xrandr in the terminal without the proprietary drivers installed (just on a fresh install of Kubuntu) and was able to force it into 1280x1024 @ 75 Hz. I tried the same process with the Nvidia drivers installed, however, and got an error saying "xrandr: Configure crtc 0 failed."
 

·
Registered
Joined
·
1,104 Posts
Could you post your /var/log/xorg.0.log and /var/log/xorg.0.log.old?

That'll help point out any errors.
 

·
No desktop currently :(
Joined
·
2,134 Posts
Discussion Starter · #4 ·
Quote:

Originally Posted by Error 404 View Post
Could you post your /var/log/xorg.0.log and /var/log/xorg.0.log.old?

That'll help point out any errors.
I attached them, just remove the .txt extensions (or not, since they are just text anyway lol). My forcing of 1280x1024 without the Nvidia drivers magically stopped working. Now every time I try doing the EXACT same thing I did before to make it work, xrandr gives me an error saying

Code:

Code:
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  149 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  27
  Current serial number in output stream:  27
I haven't even tried reinstalling the Nvidia drivers yet. This is a nightmare
Any and all help is greatly appreciated
 

·
Registered
Joined
·
1,104 Posts
Oh. Only one would have done, I'm silly. You're still having the problem. Anyway - I should've asked you to attach /etc/X11/xorg.conf too
 

·
No desktop currently :(
Joined
·
2,134 Posts
Discussion Starter · #6 ·
Quote:

Originally Posted by Error 404 View Post
Oh. Only one would have done, I'm silly. You're still having the problem. Anyway - I should've asked you to attach /etc/X11/xorg.conf too

I just installed the latest Nvidia driver from the repository, and I'm stuck at 1024x768 again
I tried using xrandr to force 1280x1024, but it gave me the error:

Code:

Code:
xrandr: Configure crtc 0 failed
again :/

I attached my xorg for ya. This is really grinding my gears.
 

·
Registered
Joined
·
1,104 Posts
Try backing up xorg.conf and making a new one - do this without X running.

To kill X

Code:

Code:
sudo pkill X
then

Code:

Code:
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
Xorg -configure
(reboot)
shutdown -r now
(or restart X)
startx
Try this


Edit: With the automatically installed drivers installed. Just easier to manage, and since Xorg is autoconfiguring itself. Also, try editing your xorg.conf to this guide.....And I know there's an nvidia driver command to configure Xorg...But I don't remember it right now, so someone else should fill that in if they do
 

·
No desktop currently :(
Joined
·
2,134 Posts
Discussion Starter · #8 ·
Quote:

Originally Posted by Error 404 View Post
Try backing up xorg.conf and making a new one - do this without X running.

To kill X

Code:

Code:
sudo pkill X
then

Code:

Code:
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
Xorg -configure
(reboot)
shutdown -r now
(or restart X)
startx
Try this


Edit: With the automatically installed drivers installed. Just easier to manage, and since Xorg is autoconfiguring itself. Also, try editing your xorg.conf to this guide.....And I know there's an nvidia driver command to configure Xorg...But I don't remember it right now, so someone else should fill that in if they do

Well I took your advice and reconfigured Xorg, which dropped the max resolution back down to 640x480
I then manually edited Xorg with sudo kate /etc/X11/Xorg.conf so that the horizontal and vertical refresh rate values for my monitor within it were correct. I saved Xorg.conf and rebooted, which gave me a 1024x768 resolution. I then checked the NVIDIA X Server Settings and discovered that doing that had unlocked a bunch of different resolutions, including 1280x1024!
After some finagling to get the resolution setting to stick and keep 3d acceleration enabled, it finally took!

Mission accomplished!
Thanks for the help! +REP

PS - The Nvidia autoconfigure xorg.conf command you were thinking of is sudo nvidia-xconfig
 

·
Registered
Joined
·
1,698 Posts
not sure why you would want to go thru all that.... when u first boot up into ubuntu, just do the nvidia restricted drivers. then reboot, done.... i have a 8600gts on my rig, no issues except setting up dual monitors, but i just had to run sudo nvidia-settings from the command line, set it up and saved and exited....
 

·
No desktop currently :(
Joined
·
2,134 Posts
Discussion Starter · #10 ·
Quote:

Originally Posted by MrAMD_Fan View Post
not sure why you would want to go thru all that.... when u first boot up into ubuntu, just do the nvidia restricted drivers. then reboot, done.... i have a 8600gts on my rig, no issues except setting up dual monitors, but i just had to run sudo nvidia-settings from the command line, set it up and saved and exited....
Did you even read my OP?

Quote:
The problem came up when I went into the display settings to try to set the resolution to my CRT monitor's native resolution of 1280x1024 @ 75 Hz. In the settings, the maximum resolution I could set it to was only 1024x768 @ 60 Hz

I looked in both the Nvidia control panel and Kubuntu's own display settings to no avail.
The whole point of this thread is that simply installing the drivers and rebooting DID NOT give me the resolution options I needed.

The problem ended up being that when the Nvidia drivers installed and auto-configured Xorg.conf, they detected my monitors refresh rate ranges incorrectly. I had to manually edit Xorg.conf and put in the correct values, which miraculously gave me the needed resolution options in the Nvidia X Server Settings. I don't really understand why this worked, I just know that it does, which is all that matters to me haha.
 

·
cd C:\TEMP\
Joined
·
2,309 Posts
Hmmm... glad to see that you persevered and got it working
 

·
Registered
Joined
·
1,104 Posts
Quote:

Originally Posted by The_0ctogon View Post
Did you even read my OP?

The whole point of this thread is that simply installing the drivers and rebooting DID NOT give me the resolution options I needed.

The problem ended up being that when the Nvidia drivers installed and auto-configured Xorg.conf, they detected my monitors refresh rate ranges incorrectly. I had to manually edit Xorg.conf and put in the correct values, which miraculously gave me the needed resolution options in the Nvidia X Server Settings. I don't really understand why this worked, I just know that it does, which is all that matters to me haha.
Glad to hear you got it working


Grats


Quote:

Originally Posted by enorbet2 View Post
"nvidia-settings" is your friend (twinview too!) and

http://www.nvnews.net/vbulletin/foru...?s=&forumid=14

is extremely thorough if that's not enough
That's the command...


Quote:

Originally Posted by MrAMD_Fan View Post
not sure why you would want to go thru all that.... when u first boot up into ubuntu, just do the nvidia restricted drivers. then reboot, done.... i have a 8600gts on my rig, no issues except setting up dual monitors, but i just had to run sudo nvidia-settings from the command line, set it up and saved and exited....
Doesn't always work out perfectly - OP is a great example
 

·
Registered
Joined
·
1,698 Posts
Quote:

Originally Posted by The_0ctogon View Post
Today I decided to begin my grand Linux adventure
I use Ubuntu 9.10 regularly at school, so I decided I would use Kubuntu 9.10 as my home distribution so I can get both the KDE and GNOME experience. The computer I installed it on uses a 90nm 3.0GHz P4 w/ 1.5GB DDR333 and has a 8600GT.

I installed it as a dual-boot with WinXP, and everything worked just fine. I installed the newest packaged Nvidia driver from the repo (version 180?) and that went without a hitch. The problem came up when I went into the display settings to try to set the resolution to my CRT monitor's native resolution of 1280x1024 @ 75 Hz. In the settings, the maximum resolution I could set it to was only 1024x768 @ 60 Hz


I looked in both the Nvidia control panel and Kubuntu's own display settings to no avail. I googled around and tried some things in the terminal that were supposed to fix the problem, but I ended up borking the Kubuntu install, so I formatted the partition and reinstalled.

This time, I thought I'd try the newest, non-packaged driver straight from Nvidia (195.36.15). I successfully installed it, (which taught me quite a bit) but now I have the same problem, only worse. The max resolution I can get is now 640x480 @ 50Hz


I've tried a couple more supposed "fixes" and none of them do anything. Can some local Linux guru help me out here?
I did read your post.... you said you installed it from the repo....
i was saying just turn on restricted drivers and reboot.... but whatever
 
1 - 15 of 15 Posts
Top