Overclock.net banner
1 - 13 of 13 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
After stopping and starting gdm in Ubuntu 10.10 in order to install the latest driver for my gpu. My system no longer boots automatically into the GDM /Ubuntu desktop. Any help with this please?
 

·
Premium Member
Joined
·
6,820 Posts
It's probably trying but crashing to cli? Well I actually need more specifics though, like after it boots will it run gdm?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #3 ·
Quote:


Originally Posted by mushroomboy
View Post

It's probably trying but crashing to cli? Well I actually need more specifics though, like after it boots will it run gdm?

Ok so let me expand a little more sorry about that. I installed 10.10 today on my new machine. I went to install the newest driver for my gt240 so this is what I did:
1. downloaded the driver from nvidia.
2. ctrl-alt-f1
3. entered my login/pw
4. "sudo services gdm stop
5. navigated to the directory where the driver was downloaded it and ran it. (everything went fine, it did throw an error about some script, but it let me install anyways)
6. "sudo services gdm start"

Then it went to the gdm/desktop. The screen resolution to my TV via HDMI was messed up (almost like it is oversized, tried to fix resolution but no luck), but thats another issue. Then when I restarted, it didn't automatically load into the gdm/desktop, instead it sat on the login for the terminal (like when u hit ctrl-alt-f1).
Sorry if my explanation is confusing, sort of new to Linux/Ubuntu.
 

·
10 year OCN Vet
Joined
·
3,447 Posts
Greetz
You might possibly solve it by running "nvidia-xconfig" after you login but the pre-install script that nVidia complained about is some st00pid device that Ubuntu employs to make it easier to use Synaptic and stick with their nvidia-current. I love Open Source too but there is no way I am going to use a driver like nouveau that is still considerably behind the nVidia driver and I don't know why the Ubuntu boys don't just accept that instead of making the installation of such an important driver so painful.

In any case use your favorite command line text editor to read "/var/log/Xorg.0.log" to see what's going on and what errors [E] or warnings [WW] there are. Don't sweat font warnings those are common. Just see why nVidia is not loading right.
 

·
Premium Member
Joined
·
6,820 Posts
Here's what I would do... I'd login and run nvidia-xconfig then run:

sudo /etc/init.d/gdm stop
Do that again with start instead.

Now if you don't get video I'd replace the nvidia driver with the opensource one so you can at least do the rest of this with a gui...


sudo view /etc/X11/xorg.conf

find where it says driver "nvidia" or something, press i and change that to "nv" then press Esc, wq!, enter.

You should now be able to do the /ect/init.d/gdm start/stop again and you'll at least get 2d video. After you get there I'd go into synaptic and search "nvidia dkms" and install the nvidia-kernel-dkms package or whatever the name is (if you want the latest driver use a maverick repository such as "deb http://us.archive.ubuntu.com/ubuntu/ maverick main"). After that installs you should check the status of the dkms by running:

sudo dkms status

That should give you this (replace versions with yours):

nvidia, 256.53, 2.6.32-5-amd64, x86_64: installed

You should now be able re-edit that file back to nvidia, to do this in X I just run gksu and type:

gedit /etc/X11/xorg.conf

Replace gedit with whatever you use (kwrite, gedit, mousepad, ect...). Once the file is open edit "nv" in driver back to "nvidia" save and quit. To get it running restart X:

sudo killall -9 Xorg

Log back in and enjoy!

If "nvidia, 256.53, 2.6.32-5-amd64, x86_64: installed" doesn't appear it didn't compile, though you'll probably get an error thrown at you before that so let us know. I choose the dkms way because it's pretty easy and auto-installs when you update kernels. =)
 
  • Rep+
Reactions: NFishbone

·
Premium Member
Joined
·
6,820 Posts
Quote:

Originally Posted by Jimi View Post
vi = view??

mind = blown
[edit2] And yes I know they have the same layout as there probably the same program like xterm and wterm ect... just different name

[edit3] There all softlinks to /usr/bin/vim.basic, BLAH so vi isn't even the proper program.

[err] I cut all the crap out, I decided since I'm traveling over a bridge I should lighten the load. I'm surprised to see one on a forum, usually there more wild.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #8 ·
Quote:

Originally Posted by mushroomboy View Post
Here's what I would do... I'd login and run nvidia-xconfig then run:

sudo /etc/init.d/gdm stop
Do that again with start instead.

Now if you don't get video I'd replace the nvidia driver with the opensource one so you can at least do the rest of this with a gui...


sudo view /etc/X11/xorg.conf

find where it says driver "nvidia" or something, press i and change that to "nv" then press Esc, wq!, enter.

You should now be able to do the /ect/init.d/gdm start/stop again and you'll at least get 2d video. After you get there I'd go into synaptic and search "nvidia dkms" and install the nvidia-kernel-dkms package or whatever the name is (if you want the latest driver use a maverick repository such as "deb http://us.archive.ubuntu.com/ubuntu/ maverick main"). After that installs you should check the status of the dkms by running:

sudo dkms status

That should give you this (replace versions with yours):

nvidia, 256.53, 2.6.32-5-amd64, x86_64: installed

You should now be able re-edit that file back to nvidia, to do this in X I just run gksu and type:

gedit /etc/X11/xorg.conf

Replace gedit with whatever you use (kwrite, gedit, mousepad, ect...). Once the file is open edit "nv" in driver back to "nvidia" save and quit. To get it running restart X:

sudo killall -9 Xorg

Log back in and enjoy!

If "nvidia, 256.53, 2.6.32-5-amd64, x86_64: installed" doesn't appear it didn't compile, though you'll probably get an error thrown at you before that so let us know. I choose the dkms way because it's pretty easy and auto-installs when you update kernels. =)
Ok well I think I got it. When I do the "sudo dkms status" it says: "nvidia-current, 260.19.06, 2.6.35-22-generic, x86_64: installed" I assume this is the latest driver for my gt240? Hopefully
So thanks for guiding me through my issue!

Any chance you or anyone knows how to get the sound to properly work through my hdmi? I have sound output through hdmi selected in sound preferences and High Definition Audio Controller selected in the Hardware tab.
 

·
Premium Member
Joined
·
6,820 Posts
Quote:

Originally Posted by NFishbone View Post
Ok well I think I got it. When I do the "sudo dkms status" it says: "nvidia-current, 260.19.06, 2.6.35-22-generic, x86_64: installed" I assume this is the latest driver for my gt240? Hopefully
So thanks for guiding me through my issue!

Any chance you or anyone knows how to get the sound to properly work through my hdmi? I have sound output through hdmi selected in sound preferences and High Definition Audio Controller selected in the Hardware tab.
HDMI and nvidia? I don't think nvidia hdmi supports sound, only ATi (AMD) support it that I'm aware of.

And your welcome.

Oh, and thank you jimi for pointing out vi=view, was very nice of you to aid me across that bridge.
 

·
Banned
Joined
·
4,996 Posts
Quote:

Originally Posted by mushroomboy View Post
HDMI and nvidia? I don't think nvidia hdmi supports sound, only ATi (AMD) support it that I'm aware of.

I have use HDMI in Ubuntu before and it works along with the sound
and that was out of the box

OP
to install nvidia do this
make two text files
one named

nvidia-graphics-drivers.conf

with these lines

blacklist vga16fb
blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
blacklist nvidia-current
blacklist nvidiafb

and the other text file will be named
xorg.conf

with these lines

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

put "nvidia-graphics-drivers.conf" in
/etc/modprobe.d/

and "xorg.conf" in
/etc/X11/

then stop the xserver
and install the drivers
and finally reboot

this has worked for ever PC with a nvidia card I have had running in Ubuntu
 

·
Premium Member
Joined
·
6,820 Posts
Quote:


Originally Posted by 3dfxvoodoo
View Post


I have use HDMI in Ubuntu before and it works along with the sound
and that was out of the box

=( Hmmmm ALSA might detect the HDMI out and re-direct audio. Idk

http://forums.nvidia.com/lofiversion...hp?t52765.html

They talk about not installing the nvidia audio driver, so maybe they do have sound! lol I don't use hdmi as I still got an 8800GT =P
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #12 ·
Quote:


Originally Posted by mushroomboy
View Post

=( Hmmmm ALSA might detect the HDMI out and re-direct audio. Idk

http://forums.nvidia.com/lofiversion...hp?t52765.html

They talk about not installing the nvidia audio driver, so maybe they do have sound! lol I don't use hdmi as I still got an 8800GT =P

Yup finally got sound through HDMI !!!
After seeing it had something to do with ALSA, I did some investigating. I had to disable onboard sound in bios. Then I added: "options snd-hda-intel enable_msi=0 probe_mask=0xfff2" to /etc/modprobe.d/alsa-base.conf . Then voila it works!
 

·
Premium Member
Joined
·
6,820 Posts
Quote:


Originally Posted by NFishbone
View Post

Yup finally got sound through HDMI !!!
After seeing it had something to do with ALSA, I did some investigating. I had to disable onboard sound in bios. Then I added: "options snd-hda-intel enable_msi=0 probe_mask=0xfff2" to /etc/modprobe.d/alsa-base.conf . Then voila it works!

LOL Now the real test is getting OSS to work! I actually can't stand ALSA now that I've started using OSS, the sound quality is extremely good.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top