Overclock.net banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,964 Posts
Discussion Starter · #1 ·
This is a tutorial on how to modify your BIOS using Radeon BIOS Editor and how to flash it using ATI Winflash.
First you need to download the following:
Radeon Bios Editor
ATI Winflash

They are both executables, so no installation is require. Unzip Winflash and we're ready to go.

Start by launching Radeon BIOS editor. Once you get into the main screen click on Acquire/Flash.



Now enter the path to Winflash. Click Analyze.



Click Acquire BIOS. You now have your current BIOS loaded into RBE, ready for editing.



*VERY IMPORTANT!*
Before you edit anything make a backup of your BIOS by clicking Save BIOS, just in case of a bad flash.



Go ahead and edit any of the values you wish. When you're done save a copy of you modified bios if you want, otherwise you're ready to flash.

*VERY IMPORTANT!*
Before you flash, make sure you close any non-essential applications, programs, etc. just to be safe.

Click Acquire/Flash. Click Flash BIOS. You will probably be prompted about the BIOS part number not matching, this is normal even with an unmodified BIOS. Click Yes. You will be prompted to restart, click Ok.



Congratulations!! You have officially flashed your BIOS. If you have any questions feel free to post them here. I plan on adding a section on how to recover from a bad flash, and how to flash in DOS in the future, as well as adding pictures.
 

·
Registered
Joined
·
16 Posts
Cool hermitmaster, but flashing a GPU without understanding/setting correct values (RBE) will have a negative effect + no real use. So the big question, how does an almost perfect BIOS looking ?

I'm still searching/reading/comparing info, to see how GPU modders using & setting values for a new BIOS.

Concerning my actual default BIOS, I just have the first 3 clock info with values, all the same expect the first one.

http://xs.to/image-0EAE_4BA4C676.jpg

Still searching help with my XFX 4870 heating + OC problems =>

Thread : "XFX 4870 Issues [HELP PLZ]"
 

·
Registered
Joined
·
1,964 Posts
Discussion Starter · #3 ·
It's different for every card unfortunately. I will tell you this though. The three states in your particular BIOS are boot, 2D, and 3D. You should always leave boot alone and always have all the other memory clocks exactly the same to prevent screen tearing on multi monitor setups. The 2D clock can go as low as 150-200 without adversely affecting anything. Start there and see if you have any improvement. You could also adjust fan settings if they are available in your BIOS. Flashing isn't for everybody, if you're having a lot of trouble with it you could always try using something like ATITool.

*edit*
I just looked at your screenshots and your fan settings are terrible. You have no fan until 58C and it doesn't reach 100% until 96C. Change the duty cycle% to 30, Tmax to 90 and Tmin to 45. You may need to edit Tslope too, but try this first.
 

·
Registered
Joined
·
16 Posts
Thanks !

Here's what I'm projecting to use :

Clock/Voltage settings :

Clock info 00 :

GPU : ?
RAM : ?
V : 1.263

Clock info 01 :

GPU : ?
RAM : ?
V : 1.263

Clock info 02 :

GPU : ?
RAM : ?
V : 1.263

Fan Throttle control settings :


Tmin : 45
Tmax : 90
Duty cycle : 30

Hysteresis : ?
Spin up cycle : ?
Tmin Hysteresis : ?
Spin up time : ?
PWM ramp on : ?
PWM ramp % : ?

Additional features :

Method 1 or 2 ?
Fix spin up bug ?
 

·
Registered
Joined
·
1,964 Posts
Discussion Starter · #5 ·
Clock/Voltage settings :

Clock info 00 :

GPU : 750
RAM : 900
V : 1.263

Clock info 01 :

GPU : 200
RAM : 900
V : 1.000

Clock info 02 :

GPU : 750
RAM : 900
V : 1.263

Fan Throttle control settings :


Tmin : 45
Tmax : 90
Duty cycle : 30

Hysteresis : Leave Stock
Spin up cycle : Leave Stock
Tmin Hysteresis : Leave Stock
Spin up time : Leave Stock
PWM ramp on : Leave Stock
PWM ramp % : Leave Stock

Additional features :

Method 1 or 2: Leave Stock
Fix spin up bug: Leave Stock
 

·
Registered
Joined
·
16 Posts
Aieee BLACK SCREEN !!! 1st GPU Flash (Windows)...

Didn't real thought, it would end up like this, anyways I restored my original BIOS & will DOS BIOS re-flash it, looks a lot safer...(no drivers destroying)

If you planning to flash your GPU via Windows, be aware drivers will be screwed, so you have to re-install them after that. It's safer via DOS, just create a bootable HDD USB (HP USB Disk Storage Format Tool ), format your USB HDD with this tool, copy files (HP USB Disk Storage Format Tool ) into your USB HDD with your BIOS (bin & rom files, just tried the original bin file) + copy also atiflash.exe, restart pc, enter BIOS, set your primary bootable device (HDD USB), save & restart, insert HDD USB, enter command :

>atiflash -f -p 0 your_New_BIOS.bin

-f => force flash
-p 0 => adapter 1 => primary card/GPU
-p 1 => adapter 2 => secondary card/GPU
your_New_BIOS.bin => be aware to choose an short BIOS name with no special characters.

Reboot pc, you're done ! Enjoy !

WARNING :

Always, save your original BIOS, before flashing. The more secure way to acquire it, is => GPU-Z 0.3.7. Click the green icon next to BIOS Version & save your original BIOS.

==========================
@hermitmaster

I'm suspecting the voltage + the too low GPU clock which did have a bad impact ! For sure, didn't use your exact settings since 1000V doesn't exist at all...grrrr !
 

·
Registered
Joined
·
207 Posts
hey i just flashed my 5870 with modded bios, but when i run gpuz @ the buttom it says its 1000/1300 ( the clocks i set it to) but when i goto sensor it shows up as 850/1200 which is the normal stock one... so how do i make it change permanently??
 

·
Registered
Joined
·
1,311 Posts
can you give a pic for us?
if it's what i think you mite have just reinstall drivers or if you
have msi afterburner just due a complete re install make sure when it ask you to
save settings for msi tell not to save then reboot and intall msi after burner
 

·
Registered
Joined
·
1,964 Posts
Discussion Starter · #10 ·
Quote:

Originally Posted by yummybar View Post
hey i just flashed my 5870 with modded bios, but when i run gpuz @ the buttom it says its 1000/1300 ( the clocks i set it to) but when i goto sensor it shows up as 850/1200 which is the normal stock one... so how do i make it change permanently??
It's most likely a safety feature. Try setting it to 900/1200 and see if it appears right.
 
1 - 11 of 11 Posts
Top