Overclock.net banner
1 - 11 of 11 Posts

·
Registered
Joined
·
315 Posts
Discussion Starter · #1 ·
For those who experience screen flickering in dual monitor mode with AMD/ATI video cards, here is a very simple step by step fix. This if for those who do not wish to flash 2D and 3D bios settings.

Symptoms:
Screen flickers when using dual monitor setup. Usually occurs when using YouTube or other flash video websites.

Cause:

While using YouTube or flash video websites, you will notice on MSI Afterburner that your GPU Core Clock will increase, and your GPU Memory Clock will decrease. The change in Memory Clock is what's causing the screen to flicker.

Solution:

1) Go to YouTube and open up any video.

2) Right-click on the video and choose the 'Settings...' option.
step2-1.jpg


3)
A small menu will pop up. On the 'Display' tab, disable hardware acceleration by un-checking 'Enable hardware acceleration.'
step3.jpg


4) Close the small menu, and you're done!

You should notice next time you start YouTube, your GPU Core Clock and Memory Clock should remain constant. I'm not sure why AMD/ATI is having this problem with dual monitor setups. But, this is a quick and easy fix for those experiencing monitor screen flickering whenever using YouTube or flash videos.

Hope this helps!
smile.gif
 

·
Registered
Joined
·
54 Posts
Hey there just wondering...the flickering I get is on my 2nd monitor..
I believe it's happening because my clock speeds are 157/300.
I notice it disappears when I watch a movie or watch video content on the web and my clocks change to 400/900.

I tried following this method from this link: http://www.tomshardware.com/forum/283348-33-5870-dual-monitor-screen-tear-flickering

with no luck
frown.gif
it keeps downclocking to 157/300...

I'm still looking for fixes...hopefully someone here can lead me to the right direction
tongue.gif
 

·
Premium Member
Joined
·
7,127 Posts
Quote:
Originally Posted by onslaught_ View Post

Hey there just wondering...the flickering I get is on my 2nd monitor..
I believe it's happening because my clock speeds are 157/300.
I notice it disappears when I watch a movie or watch video content on the web and my clocks change to 400/900.

I tried following this method from this link: http://www.tomshardware.com/forum/283348-33-5870-dual-monitor-screen-tear-flickering

with no luck
frown.gif
it keeps downclocking to 157/300...

I'm still looking for fixes...hopefully someone here can lead me to the right direction
tongue.gif
Try to flash it with this BIOS http://www.techpowerup.com/vgabios/75219/Sapphire.HD5870.1024.100301_3.html
 

·
Registered
Joined
·
794 Posts
Thanks for this! It has been driving me nuts and I was running at stock clocks because of it. This worked
smile.gif
 

·
Registered
Joined
·
7 Posts
That is not a fix, but just a workaround. I don't want to disable hardware acceleration, you know ;)

I heard it has something to do with downclocking to idle speeds or something. Personally I got it frequently on my second screen (even if i'm not using Flash). It's a driver issue, AMD has to fix their Catalyst drivers.

When I use a GPU overclocking program like MSI Afterburner, ATi Tray Tools or Sapphire TRIXX, it becomes A LOT worse and then it happens at my first screen too. It disappears when I reboot or change my desktop resolution.

And oh, my card is aan Sapphire HD6950 2GB OC (Dual fan cooler)

EDIT:

I did some research and I found something:

1000

It is possible to correct this in a CCC config file located at C:\Users\*\AppData\Local\ATI\ACE\Profiles.xml.

Look for the following block:

Quote:
<Feature name="MemoryClockTarget_PCI_VEN_1002&DEV_6719&SUBSYS_186B174B&REV_00_4&80E7924&0&0008A">
<Property name="Want_0" value="15000" />
<Property name="Want_1" value="62500" />
<Property name="Want_2" value="125000" />
</Feature>
And change the value of Want_1 to that of Want_2:

Quote:
<Feature name="MemoryClockTarget_PCI_VEN_1002&DEV_6719&SUBSYS_186B174B&REV_00_4&80E7924&0&0008A">
<Property name="Want_0" value="15000" />
<Property name="Want_1" value="125000" />
<Property name="Want_2" value="125000" />
</Feature>
Now, it will no longer jump from 625 MHz to 1250 MHz. Note that this needs AMD Overdrive to be enabled to work.

Also, these clocks are for my Sapphire HD 6950 2GB OC. It's factory overclocked. Your card's clock settings may be different.
 

·
Registered
Joined
·
37 Posts
Hmm that's interesting reading Compizfox, I just disabled hardware acceleration on flash and it seems to cure my overclock issue for now.

See I only get the flicker on main screen when I close down a youtube video. This only happens when I oc my 7970. Its fine on stock clocks. Also I am watching the memory clock and its sticking at 1400mhz and not down clocking at all. Only the core clock moves. I am thinking that the card just needs some more volts as its still in 1.175v stock (1000/1400).

On 12.11 beta.
 

·
Registered
Joined
·
45 Posts
Quote:
Originally Posted by Compizfox View Post

That is not a fix, but just a workaround. I don't want to disable hardware acceleration, you know
wink.gif


I heard it has something to do with downclocking to idle speeds or something. Personally I got it frequently on my second screen (even if i'm not using Flash). It's a driver issue, AMD has to fix their Catalyst drivers.

When I use a GPU overclocking program like MSI Afterburner, ATi Tray Tools or Sapphire TRIXX, it becomes A LOT worse and then it happens at my first screen too. It disappears when I reboot or change my desktop resolution.

And oh, my card is aan Sapphire HD6950 2GB OC (Dual fan cooler)

EDIT:

I did some research and I found something:

1000


It is possible to correct this in a CCC config file located at C:\Users\*\AppData\Local\ATI\ACE\Profiles.xml.

Look for the following block:

And change the value of Want_1 to that of Want_2:

Now, it will no longer jump from 625 MHz to 1250 MHz. Note that this needs AMD Overdrive to be enabled to work.

Also, these clocks are for my Sapphire HD 6950 2GB OC. It's factory overclocked. Your card's clock settings may be different.
Sorry to dig up and old thread but there is no "want 2" in my profiles file only want 0 and want 1 is there another method for this?
 

·
Registered
Joined
·
1 Posts
Sorry for bumping this old thread but this is one of the first google results for "AMD dual monitor taskbar flicker" and hopefully this will help people.

So I've been having this annoying problem as well as many of you and I finally found something that worked for me.

I have a 24 inch Dell monitor (60hz) and a 40 inch TCL LCD (60hz).
Windows 7
AMD 7870 Myst Edition

What I finally did was change the refresh rate on my 2nd 'monitor' (the TCL) to 59hz.
-Right Click Desktop --Select Screen Resolution
-Select the 2nd monitor --Click 'Advanced Settings
-Click monitor tab --*Check 'Hide Modes Monitor Cannot Display ---Select 59hz or something else other than the default

Dunno why but it cleared it up when nothing else would.

Hope this helps someone!
 

·
Registered
Joined
·
1 Posts
If you couldn't fix the problem, try this. (I have two DELL 2412m(DVI + DisplayPort, Dual))

Download the AMD GPU Clock tool (http://www.techpowerup.com/downloads/1641/amd-gpu-clock-tool-v0-9-26-0-for-hd-5870/ )

,and fix the memory clock to default value in the AMD Catalyst. This was caused from the GPU Memory clock changing when the display hardware accellerated.




I couldn't fix with above solutions, but i could confirm this was caused from gpu memory clock changing only when watching WebBrowser's Video(Hardware accellerated, Adobe Flash or HTML5 Video).

(For my case, with CompizFox's XML editing way the gpu memory clock didn't fixed,
and AMD Catalyst(latest ver) didn't fixed changeable mem clocks too.
But with that tool it has fixed tightly.
And i couldn't change to 59hz, whenever i changed to 59hz, the resolution changed forced to 1920x1080( Default is 1920x'1200'). So those didn't help for my case.)

If you couldn't fix the problem like me, try this and hope this will help someone.

Thank you all for the solutions.
 
1 - 11 of 11 Posts
Top