Overclock.net banner
1 - 20 of 26 Posts

·
Registered
Joined
·
1,132 Posts
Discussion Starter · #1 ·
Skyrim suffers from an oversight (or laziness) with the mouse control. It feels "laggy" or "slow" or wrong.

To fix this, go to Documents>My Games>Skyrim

-Make a backup copy of SkyrimPrefs.ini

-Open SkyrimPrefs.ini

-Look for a value called bMouseHeadingSensitivity (something along those lines)

-Delete it and replace it with these two values fMouseHeadingYScale=0.0100
fMouseHeadingXScale=0.0100

That fixed the laggy mouse problem for me. I should also add if the sensitivity is too low/high for you all you need to do is change the numbers higher or lower to fit your needs. If you want, you can also disable VSync by adding iPresentInterval=0 to the display section in SkyrimPrefs.ini. You can disable mouse smoothing by changing bMouseAcceleration=1 to 0 in SkyrimPrefs.ini.

Hopes this helps anyone with the same problem, it was driving me insane.
 

·
Premium Member
Joined
·
10,813 Posts
Skyrim is one of the biggest ports in recent memory. I am a big TES fan, at least from Morrowind on, but I was a little disappointed by this game. I don't usually buy games full price at launch, this one I did. So far I regret it. I've done the tweaks out now and its made things a little better but so far I am sad face.
 

·
A title was here
Joined
·
4,144 Posts
Seriously ?

sigh.

This really did just kill my enthusiasm because I can't enjoy games that have issues with the mouse feeling "off". I don't mind editing ini's or anything such as that as long as it can be corrected. I still can't enjoy Deus Ex HR and many other games because of it. Some of them simply can't be completely fixed.

I'm getting sick of issues like this, now I know why I once proudly pirated every game I could find, I stopped many years ago though.
 

·
Registered
Joined
·
1,132 Posts
Discussion Starter · #4 ·
Quote:
Originally Posted by Mygaffer View Post

Skyrim is one of the biggest ports in recent memory. I am a big TES fan, at least from Morrowind on, but I was a little disappointed by this game. I don't usually buy games full price at launch, this one I did. So far I regret it. I've done the tweaks out now and its made things a little better but so far I am sad face.
I'm content so far. The menus are awful and are no different from the XBox menus, but once you get past that and look at the gameplay the game is fantastic.
Quote:
Originally Posted by Ascii Aficionado View Post

Seriously ?
sigh.
This really did just kill my enthusiasm because I can't enjoy games that have issues with the mouse feeling "off". I don't mind editing ini's or anything such as that as long as it can be corrected. I still can't enjoy Deus Ex HR and many other games because of it. Some of them simply can't be completely fixed.
I'm getting sick of issues like this, now I know why I once proudly pirated every game I could find, I stopped many years ago though.
Even with this fix, the mouse still isn't perfect. There is only so much an .ini tweak can do. The laggy feeling you get from the mouse is just a result of rushed and bad porting. The tweak makes it bearable, at least.
 

·
Registered
Joined
·
4,873 Posts
This is pretty much par for the course for a Bethesda release. Wish they'd stop screwing with PC users for once.

On the bright side, they usually fix it quick.

Sent from my Droid using Tapatalk
 

·
OCN Veteran
Joined
·
594 Posts

·
A title was here
Joined
·
4,144 Posts
Quote:
Originally Posted by Prox View Post

I'm content so far. The menus are awful and are no different from the XBox menus, but once you get past that and look at the gameplay the game is fantastic.
Even with this fix, the mouse still isn't perfect. There is only so much an .ini tweak can do. The laggy feeling you get from the mouse is just a result of rushed and bad porting. The tweak makes it bearable, at least.
That's my point, it's unacceptable garbage.
 

·
Registered
Joined
·
375 Posts
Quote:
Originally Posted by Prox View Post

Skyrim suffers from an oversight (or laziness) with the mouse control. It feels "laggy" or "slow" or wrong.
To fix this, go to Documents>My Games>Skyrim
-Make a backup copy of SkyrimPrefs.ini
-Open SkyrimPrefs.ini
-Look for a value called bMouseHeadingSensitivity (something along those lines)
-Delete it and replace it with these two values fMouseHeadingYScale=0.0100
fMouseHeadingXScale=0.0100
That fixed the laggy mouse problem for me. I should also add if the sensitivity is too low/high for you all you need to do is change the numbers higher or lower to fit your needs. If you want, you can also disable VSync by adding iPresentInterval=0 to the display section in SkyrimPrefs.ini. You can disable mouse smoothing by changing bMouseAcceleration=1 to 0 in SkyrimPrefs.ini.
Hopes this helps anyone with the same problem, it was driving me insane.
thanks for this, they also have a article on how to fix it at PC gamer.com
 

·
Registered
Joined
·
183 Posts
Laggy mouse has more to do with the Vsync being on by default. You can either limit the Frame rate by using Dxtory, or disable VSync in Skyrim, by adding iPresentInterval=0 to the bottom of the [Display] section of the Skyrim.ini file in the \Users\[Username]\My Documents\My Games\Skyrim directory.
 

·
A title was here
Joined
·
4,144 Posts
Quote:
Originally Posted by bckai View Post

Laggy mouse has more to do with the Vsync being on by default. You can either limit the Frame rate by using Dxtory, or disable VSync in Skyrim, by adding iPresentInterval=0 to the bottom of the [Display] section of the Skyrim.ini file in the \Users\[Username]\My Documents\My Games\Skyrim directory.
I just tried this, it felt less "off" in 1st person to the extent it now only felt as if it was using the wrong FoV instead of having other issues, once I switched to 3rd person *which has a higher FoV * it almost felt perfect.

This implies the FoV the game uses for 16:9/16:10 aspect ratios and resolutions in first person is still too zoomed in and the true FoV isn't realized unless you're in 3rd person.

I think we're on to something here........
 

·
Registered
Joined
·
1,132 Posts
Discussion Starter · #13 ·
Quote:
Originally Posted by bckai View Post

Laggy mouse has more to do with the Vsync being on by default. You can either limit the Frame rate by using Dxtory, or disable VSync in Skyrim, by adding iPresentInterval=0 to the bottom of the [Display] section of the Skyrim.ini file in the \Users\[Username]\My Documents\My Games\Skyrim directory.
Even with Vsync off it still felt wrong. It's because the mouse axis are set to different sensitivities by default.
 

·
Read Only
Joined
·
3 Posts
Prox, your edits improved the feel of the mouse, but for whatever reason, altering the value for fMouseHeadingXScale and YScale has no effect on the actual mouse sensitivity in game for me. The smoothing is gone and it feels like it should, but the mouse sensitivity is still far too low.

I tried editing the SkyrimPrefs.ini in the user folder and also in the steam folder under Program Files, but am getting no results. Thoughts? There is no difference between 0.0100 and 3.0000 when I change it. Both settings involve having to row the mouse repeatedly to turn around.
 

·
Registered
Joined
·
1,132 Posts
Discussion Starter · #16 ·
Quote:
Originally Posted by dioxideUniversa View Post

Prox, your edits improved the feel of the mouse, but for whatever reason, altering the value for fMouseHeadingXScale and YScale has no effect on the actual mouse sensitivity in game for me. The smoothing is gone and it feels like it should, but the mouse sensitivity is still far too low.
I tried editing the SkyrimPrefs.ini in the user folder and also in the steam folder under Program Files, but am getting no results. Thoughts? There is no difference between 0.0100 and 3.0000 when I change it. Both settings involve having to row the mouse repeatedly to turn around.
This may be a stupid question, but have you tried turning up the sensitivity in game? Was the sensitivity too low before this edit as well or was it caused by the edit?
 

·
Read Only
Joined
·
3 Posts
I had the sensitivity turned up before the fact, but it went back down low when I messed with it. I didn't want to change it in-game just due to past experience with other games causing it to undo all the custom settings. This apparently wasn't the case.

Still getting weird mouse lag though; probably need an FPS limiter. Feels like Dead Space all over again. Very frustrating issue when the game runs just fine on my brother's build which has all the same parts except the video card...

Thanks for posting the info on it, by the way.
 

·
Registered
Joined
·
1 Posts
Skyrim drives me crazy! I have tried everything with those .inf files and nothing really worked. Now what's funny about the whole thing is, that in 3rd person everything runs just fine & precise. But as soon as I switch into first person mode my mouse is sooo damn slow & "sluggish"... a higher mouse sensitivity doesn't help because the movement gets faster but than it gets kinda laggy again. It is so annoying! Do we really have to wait for an official update?
 

·
Read Only
Joined
·
3 Posts
Back with no success.

Mouse seems to be handling fine, except that nothing I've found fixes the input delay. Disabling VSync did not work (which DID work when Dead Space had the same issue,) and an FPS limiter also had no effect. I can tell when I move the mouse that the movement comes maybe a quarter of a second late at the most. It is very much noticeable and very nauseating.

Worse yet, clicking behaves even worse. If I have my character's weapons out, if I left click fast enough, she will not swing because I didn't hold the button for long enough. This isn't input delay, it's just... What? I don't even. None of my other games or programs do this.

I've tested on my brother's computer and not only does it not do it on his, but his game displays absolutely none of the issues mine is having. Sigh.

I can't even cry about it and post my specs on Bethesda's forums because their validation emails don't actually send. Coooooool.
 

·
Registered
Joined
·
537 Posts
Fixes DONT work correctly and the X axis is still way slower than the Y axis........... Allegedly the only workaround is to FIX your FPS to 75, if your videocard can handle that.

Bethesda Needs to Fix this ASAP !!!! Even if it's just a small patch for now just to address this issue !!!!

I can't play the game like this honestly and i'm not willing to put Windows 7 Acceleration fixes back on by uninstalling MarkC windows acceleration fix.
That or bump up my sensitivity with acceleration back on just to play, i'll definitely still notice it.

I wonder if people with acceleration removed in windows 7 notice it more, and i'm not just talkin about "mouse smoothing" but registry fixes.

Quote:
STEAM FORUM

http://forums.steampowered.com/forums/showthread.php?p=26317143

Originally Posted by entropylc View Post
These commands do not work. Yes they do allow you to change the x and y scale, but I've discovered, through many hours of frustrated testing, that the Y sensitivity is a function of your current FPS. It appears to be normalized (x=y) around 60 fps. If you change the x and y scale, it changes the point at which the game normalizes your x and y scale.
For example: If you have a good computer, you will have 150+ fps indoors, which causes Y sensitivity to be about 5-10 times faster than x normally. You can manually adjust the x and y scale to be normal at that point, but any point below/above that FPS will be off. The threshhold of discomfort for Y sensitivity occurs around 100 FPS. So what I am currently doing is forcing vsync to be on, and changing my monitor refresh rate to 100 so I never get more than 100FPS ingame. I don't understand how this got passed testing, I noticed this after playing for 15 seconds and have been unable to play without intense irritation for sustained amounts of time.
People that have "fixed" this problem by changing their X and Y scale to be the same, check and see if its still same same indoors when you have over 120fps. If for some reason I'm the only one that this is happening to, I will just reinstall the game and hope for the best.
Bethesda really fudged this up, it's crazy that this wasn't noticed in testing or fixed, if there was any testing that is.
rolleyes.gif
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top