Overclock.net banner

*HowTo*: ATI + NVIDIA PhysX Guide

167511 331
I am using ATI HD4870 1GB as primary and NVIDIA 8800GTS 512Mb for physx.

EDIT: Sorry to bring this old topic back up but it seems people are interested in doing this so I will update anything new to this and also here is my version of Damien's guide, (same thing only a few things here and there)

************************************************** ******

1. Download the following:

- Latest ATI Drivers:

64-Bit: https://a248.e.akamai.net/f/674/9206...cc_wdm_enu.exe

32-Bit: https://a248.e.akamai.net/f/674/9206...cc_wdm_enu.exe

- Nvidia Display Driver 181.71:

32-Bit: http://www.nvidia.com/object/win7_x86_181.71_beta.html
64-Bit: http://www.nvidia.co.uk/object/win7_...1_beta_uk.html

- Latest Nvidia PhysX Pack:

http://www.nvidia.com/object/physx_9.09.0408_whql.html

- Driver Sweeper 2.0

http://downloads.guru3d.com/Driver-S...load-2186.html

EXTRA APPLICATIONS:

Fluidmark (to test if PhysX is enabled):

http://www.ozone3d.net/benchmarks/physx-fluidmark/

************************************************** ******

Make sure that the NVIDIA card is connected to a SEPARATE monitor with the DVI-to-VGA dongle and a SVGA cable

************************************************** ******

Now here is how you actually do it:

1. Go to Control Panel > Programs and Features, and remove the ATI, NVIDIA, and PhysX drivers

2. Unplug your Ethernet cord or disable your internet adapter, (this is so that Windows cannot install drivers automatically)

3. Restart and boot into Safe Mode

4. Run Driver Sweeper 2.0 and tick Nvidia Display + ATI Display + Physx Drivers, and click Analyze, once it shows all the remaining files tick all of them and click on Clean

5. Repeat this process while restarting when necessary until no files remain in the Analyze section

6. Boot Windows normally and install the ATI Drivers downloaded earlier, Restart upon completion

7. Install NVIDIA Display Drivers downloaded earlier, Restart upon completion

8. Install PhysX Driver Pack downloaded earlier, Restart upon completion

9. Once Windows is up and running you should have 2 Desktops, one ATI on the left and one NVIDIA on the right monitor, now right-click on desktop and go to Screen Resolution

10. Click on the second display and tick "Make this my main display"

11. Click on the ATI monitor and from the drop down menu select "Disconnect Display"

12. Now you should have one monitor with Nvidia as the adapter, now go to start panel and find and open the folder called "NVIDIA Corporation ..." and click on the "PhysX Properties" icon

13. Now it asks if you want the advanced or basic panel, select advanced and click ok

14. Now the NVIDIA Control Panel is open with the options of enabling or disabling PhysX, keep this panel open

15. Right click on the desktop and go to Screen Resolutions, click on the ATI monitor and from the same drop down menu as before, select "Extend my desktop .." and click apply. Now it should automatically set the ATI monitor as the main monitor but if it doesn't just tick the "Make this my main display .." and click apply.

16. Your set! Now to test if it works you can run Vantage and see if the CPU Score triples or you can run Fluidmark and see if it says Hardware Physx at the top.

Another great thing to try is Unreal Tournament 3, I find that the map Heat Ray PhysX, under Team Deathmatch, really shows that the PhysX is working wonderfully

************************************************** ******

I DON'T take credit for all this, its Damien's work from Guru and I just changed it a bit.

I hope this helps, post here if you have any problems so that everyone can learn from it.
1 - 20 of 332 Posts

·
Registered
Joined
·
5,807 Posts
As long as you are trying to do this on XP or 7, this will work.
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #4 ·
Quote:

Originally Posted by videoman5 View Post
As long as you are trying to do this on XP or 7, this will work.
Funny thing is its the other way around, I know exactly how to do it in Vista but I don't wanna install it till I do it in XP first. Once I figure this out I will write a guide on how to do it in every OS.

Quote:

Originally Posted by joemaniaci View Post
Make sure you are only install the nvidia phyx drivers and not the whole package. If you already are, you could try installing the display drivers first, and then the physx drivers.
Dough!!! I already installed everything lol. I thought that only mattered in Vista but I'll try that one for sure.
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #5 ·
Ok so I did what you said and installed only the physx drivers now the problem is gone but the Physx options are greyed out and I can't select Aegie Physx.

Any ideas?
 

·
Registered
Joined
·
3,898 Posts
I've had trouble with various versions of the Nvidia drivers. (This is on Windows 7) I've had the best success with 182.5 drivers, but your 'mileage may vary'.

I've also found that it really doesn't work to have the Nvidia card in your second PCIe slot, you must have it as your primary physical video card. You can set the card to be secondary with the display control panel, however.

Along with this, you need to have a second display, or the Nvidia card hooked to a second input on your display, so the card is recognized at boot.

I hope this helps.
 

·
Banned
Joined
·
5,551 Posts
Quote:

Originally Posted by ModoeXtreme View Post
Funny thing is its the other way around, I know exactly how to do it in Vista
No, it doesn't work in Vista. Period. You can have more than one active video driver in Vista, but you can in XP and 7.

As you have discovered, it is still finicky to pull off.
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #8 ·
Quote:

Originally Posted by 003 View Post
No, it doesn't work in Vista. Period. You can have more than one active video driver in Vista, but you can in XP and 7.

As you have discovered, it is still finicky to pull off.
It actually does work in Vista I'll post shortly how to do it.

I heard if I hook up the DVI-to-Vga converter it would be the same as hooking up the monitor? Is this true?
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #9 ·
Quote:

Originally Posted by CDMAN View Post
This is a easy way to use a Nvidia card for PhysX with a ATI card for video:

http://www.pcgameshardware.com/aid,6...eviews/?page=2

http://www.pcgameshardware.de/aid,67...fikkarte/Test/

1: Install the driver for your graphics card (Catalyst 8.12 WHQL or higher)
2: Install the v8.09.04 WHQL Physx pack: http://www.nvidia.com/object/physx_8.09.04_whql.html
3: Go to the Windows Start Menu -> Programs -> Nvidia Corporation -> Nvidia Physx Properties
4: In the control panel you select "Settings"
5: Here you should be able to activate "No Acceleration" or "Geforce Physx" or "Ageia Physx". You select the "Ageia Physx". If you use a Physx pack newer than v8.09.04 the "Ageia Physx" is not available even if you have a Ageia card in your system.

There are other methods, but I think most of them require you to be in windows XP.
Thanks to CDMAN for that guide.
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #10 ·
I just tried plugging the 8800GTS to the VGA input of my monitor and my 4870 to the DVI and still nothing the options are greyed out.
 

·
Registered
Joined
·
3,898 Posts
Quote:

Originally Posted by ModoeXtreme View Post
I just tried plugging the 8800GTS to the VGA input of my monitor and my 4870 to the DVI and still nothing the options are greyed out.
Do you have your 8800GTS in the top-most PCIe slot? Seriously, it has to be there.
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #12 ·
Quote:

Originally Posted by timw4mail View Post
Do you have your 8800GTS in the top-most PCIe slot? Seriously, it has to be there.
Really? There is no other way? Cause that would make my ATI 8x and 8800GTS 16x
 

·
Registered
Joined
·
3,898 Posts
Quote:

Originally Posted by ModoeXtreme View Post
Really? There is no other way? Cause that would make my ATI 8x and 8800GTS 16x

Trust me, I've never gotten it to work otherwise.
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #14 ·
Quote:

Originally Posted by timw4mail View Post
Trust me, I've never gotten it to work otherwise.
I'll try that but I don't know if its worth it to run it like that, I mean doesn't it make a huge difference?
 

·
Registered
Joined
·
3,898 Posts
Quote:

Originally Posted by ModoeXtreme View Post
I'll try that but I don't know if its worth it to run it like that, I mean doesn't it make a huge difference?
It shouldn't make any difference in performance, the 4870 does not utilize all of the x8 bandwidth.
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #16 ·
I WAS SO CLOSE!!! I clicked enable Physx and BAM BSOD! "Driver is mismanaging PTEs" 0x000000DA
.

I think this is a XP 64 issue so I'll format and install 32bit and see if it works. But you were right the only way is to set is as first PCIE and I realized it runs at 8x and 8x so it makes no difference lol.

I'll report when I'm done!
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #17 ·
Ok so I installed 32 bit and wow its alot more stable and I got both card enable now the problem is that the physx option is completly gone from the control panel and the aegia shortcut just runs the nvidia control panel heres a pic:
LL
LL
 

·
Registered
Joined
·
144 Posts
Quote:

Originally Posted by timw4mail View Post
Do you have your 8800GTS in the top-most PCIe slot? Seriously, it has to be there.
No, it doesn't, I have gotten 4850x2 (1st slot) 4850 (2nd slot) and a 8600GTS (3rd slot) for physx operation to work just fine. (this is in windows 7)

Delete all vid card drivers, install nvidia package first (not physx only, the whole package) Then you install ATI drivers. You need to hook a monitor to both cards and enable landscaping, with the ATI card as primary display.

The only way i got this to work was by using 2 monitors with the same native res, i could not get it to work with only 1 monitor.
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #19 ·
Ok so I did what you said and I installed the NVIDIA driver package after Driver Sweeping but still no Physx option I just can't find it. Is there a way to manually enable it?

EDIT: I also have enabled landscaping, which I think is when you extend the desktop correct? They are both at 1680x1050
 

·
Registered
Joined
·
441 Posts
Discussion Starter · #20 ·
No matter what I do right after I install the ATI drivers the Physx options disappear from the control panel. Can one of you just tell me step by step how you got yours to work. I have installed Windows 7 and still the same goddang thing
.

Thanks
 
1 - 20 of 332 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top