Overclock.net banner
301 - 304 of 304 Posts

·
Registered
Joined
·
1 Posts
Hello- quick question. Following the above instructions with a 3x4TB RAID 5 configuration I was able to recover partition - unfortunately after running the automatic file recovery I can see portions of my directory structure in tact and many of my file names, but none of the data accessible.

There's TBs of files in d:\found.000 after running the Windows file recovery tool. Has anyone come across anything similar?
 

·
Registered
Joined
·
1 Posts
Solved it a few hours ago. Was able to repair the array after carefully reading the whole guide thread over several times and making some wild-guess modifications to the procedure based on the issues people were having.

What I did, new/modified steps in green:
1) Booted into windows and uninstalled Intel Matrix / Intel Rapid Storage software!
2) Rebooted, Reset to non-raid (did not delete)
3) Build new raid identical to previous one.
4) Booted into windows and used TestDisk to analyze.
5) Quick Search with Testdisk returned no readable files/
6) Deeper search revealed the original RAID 10 partition after about 10 seconds (it continued for what would have been several hours afterwards, discovering error after error after error until I stopped it).
7) RAID 10 partition showed correct files, marked it as primary partition, wrote partition data to disk using testdisk
8) Rebooted
9) Re-established links within windows (and re-installed chrome... for whatever reason that and only that got corrupted in the process... and it wasn't even on the raid to begin with! I was on C! As soon as I reinstalled it, all the bookmarks, extensions, and settings were in place automatically. Whatever)

Note that my raid was my "d" drive and not my "c". I believe this is the key! The majority of users following this guide have had their RAID as their C drive and as such when they followed this guide, the intel software was not readable until the process was finished. For several users the method did not work due to intel software attempting to re-initialize the new raid therefore overwriting old data - these users logically had a separate C drive where the intel software was free to work while attempting this fix.

In other words, if your raid is NOT your C drive, you must first uninstall intel software to prevent erroneous re-initialization.

Anyway, thanks for your input mmiszkiel. +rep for responding helpfully even if it was a wee bit late
wink.gif
Hi all from little sunny island of Singapore!

I HAVE TO MAKE MYSELF JOIN THIS FORUM JUST TO THANK THE USER BEHIND ZERO4549 AND MANY OF YOU WHO HAVE PROVIDED SOLUTIONS THAT HELPED ME TO RECOVER MY LOST RAID 5 DRIVE!!! PARDON ME AND THE ALL-CAPS FONT BUT I'M OVERFLOWED WITH JOY!!!!

It all happened when I couldnt install 3 updates on my windows 7 64-bit professional workstation. I actually gave up on those updates until recently my adobe photoshop and premiere pro gave me an endless-loop of signing in and getting signed out involuntarily problem. The technician advise to have the updates downloaded and installed manual for windows and although it indeed solved the problem of signing into my adobe apps, I was shocked my RAID 5 drive was gone!

STEP 1 IS HIGHLY RECOMMENDED!!! PLS!!
So I followed exactly the steps in zero4549's post and voila!!! my drive is back with all my previous data intact!!!!!!!!!!! ELATED!!!! 3 x 6Tb's of work-related data all back!!! Thank you!! Thank you!!! Thank you!!!!

The takeaway from days and nights of reading up and researching online for me was to never use intel raid ever again!!! never again!!! so I've since purchased a synology ds1621+ NAS to backup all my data into it and also off-site onto another NAS for extra security!! please, guys! get a NAS and dont use intel software raid, internal raid, motherboard raid or whatever it is called! GET A NAS and have it configured for RAID 6 or synology's SHR2 so you can survive up to 2 disk failures!!

Enough ranting for me and I'm gonna go backup my data to the new NAS now!! have an awesome day, everyone!! peace out!! ;);)
 

·
Registered
Joined
·
1 Posts
Hello guys,
i want to tell you my story auf sucessfully recovery. (in advance: sorry for my bad english)

I had two 500GB SSD's configured as RAID0, this was my operating-system (C:) Volume.
The issue started with updating the BIOS of my Asus H97M Plus motherboard.
After the update, one of the SSD's was declared as "Non-RAID Disk".
I suspect a SATA-Port failing or something like this, so i switch the SATA-Ports of the SSD's many times, but it maked no difference, ever the same disk was declared as non-member.

So i searched arround in the web for a solution and found this thread.
First of all, i wanted too make a sector-for-sector backup of the disks, in the case that the solution here not work for me.
But in Windows (on a other PC, plugged the disks in a USB-SATA adapter) it does not work. Windows want to initialize the disks, and on recommendation of some users in this thread i dont intialize the disk.

Because im have little time, i decided to skip the sector-for-sector backup. I even have a Backup, it was taken months before but it contains the most important data.

But i will prefere you to take a sector-for-sector backup and only work with a copy if the data is important. Maybe the sector-for-sector backup works with linux (-live cd), i dont know, i dont try it.
Even i dont know, if the RAID-Controller will accept a 1:1 copy of the disks, but i think so.

So then i tryed the solution in this thread.
1. First i went in RAID-Bios/Configuration and take a picture of the RAID-Configuration.
2. I selected "Reset Disks to Non-RAID" and confirmed it.
3 .I rebooted and create a Array with same parameters then before.
4. I started the PC from a WindowsPE boot usb-stick which contains the software "R-Studio" (google for "windows pe strelec")
Note: This Windows-PE does not contain Intel-RST, so i skip the first step with uninstall Intel RST
5. I started the R-Studio Recovery Process and it found immediately my old volume.

Now it is in progress to recovery the volume but i saw the data in preview and it seems that everything is there:)
Thank you all for your help!!!
 

·
Registered
Joined
·
1 Posts
Thanks for everyone who contributed. Too many to give credit for these steps but here is my take with other steps I took:


My setup is a raid 10 with 4 disks. The problem started when my computer suddenly stopped working (after years of service). Lot of troubleshooting followed and the problem was the motherboard, it was death. The raid card was on board and that's the main problem - if the motherboard fails the raid card is gone. No need to say that with on-board raid cards there's a greater risk of failure due to the fact that if the mb fails for whatever reason your raid card is gone too.

After lot of research I found out that if I replace my death mb with the same exact model, or at least one with the same raid card I should be able to just replace the motherboard, hook the raid disks exactly as in the old mb, and the raid will work by itself.

The first problem was that the mb was pretty old and no longer being sold new, so I had to pay a good penny to find a refurbished one. (It was more than double the price when I bought it new)

After the mb arrived, I replace the old with the new, crossed my fingers and it booted. Forgot to mention that the OS was installed on a separate ssd disk (not the raid array) which made things simpler.

The system booted and suddenly I saw the "2 non Member Disks", apparently in the bios the disks were not set to raid the first time it booted which caused 2 disk to fall out of the raid or something.

When windows started I could see 2 disks are in the raid and the 2 others were not. At this point you should not initialize the disks, format or do anything to the raid array or disks!

Its important also to stop the service of the Intel Raid/Intel Rapid storage or delete it altogether from windows because it could interfere with the process or try to initialize the wrong raid automatically etc.


Anyhow, more days spent doing research and before trying anything further suggested here, one should ideally first do the below:


Physically clone the disks to other disks
And attempt the recovery procedure on the "CLONED DISKS" (its important to hook the cloned disks in the same order as the ones being cloned - labels are a must) - I didn't had the option to buy 4 new disks but if you have the means, and most importantly If you don't have a backup, buying 4 disks to reduce the risk of loosing your data is a fair price.


Make an image of all the disks.
I used "Reclaim Me Free Raid Recovery" (FREE software) and after a few days I had 4 .img disks.

Obviously the .img disks need a lot of space so you could buy an external drive with lot of capacity for this.

I read that you could recover/reconstruct the said RAID Array using the .img disks but didn't managed to do so personally.

BUT the nice twist to recover the raid suddenly came to my mind when I used "Reclaim Me File Recovery" which is demo software by the same company as "Reclaim Me Free Raid Recovery"

I run the demo software and it could locate my data (but to recover data you need the full version which is not free). I tried the demo on the 4 disks and the software was returning the same data on 2 disks, and the same data on the other 2 disks. Yes! thats the nature of RAID 10, meaning the same data is on 2 of the disks!

So technically one could recover the data using 2 disks only (depending which disks, basically those with the different data).

The next step was to load the .img of the 2 disks with different data using "Reclaim Me Free Raid Recovery" (FREE software) and then use the "Start Raid 5" Recovery option.

And just like that, after a while it found the data.

The option i used next was the "Write Array to Disk"

It took 4 days and then it recovered the Disk Array (All the data) for free using the 2 .img disks as a raid 5.

Notes:

Be sure to have enough space to store the recovered Raid Array (and all the files)

I tried the above procedure to recover the Raid10 array using the 4 .img disk but that one failed, hence why i tried the Raid 5 option (which apparently is much more simpler for the software to recover)


---------------------------------------------------------------------------------------------------------------------------


Now, after the data was recovered from the .img disks, had a copy of the .img disk still and/or have physical clones of the disks I could try the technique mentioned in this thread without worrying too much if it failed (because I already had my data recovered), as per below:


  • Booted into windows and uninstalled Intel Matrix / Intel Rapid Storage software or stop the service. (If not done already)
  • Rebooted, Entered raid setup and took note of the name of the Raid Array (take a photo just in case)
  • While still in the raid setup, set the 2 disks which were still in the raid array to non-raid (no delete).. so the non-raid disk are now 4.
  • Created a new raid array using the 4 disks and with the same name of the array as before.(basically an identical raid like the old one with the same settings, mine were the default)
  • Booted into windows and used TestDisk to analyze.
  • Quick Search with Testdisk returned no readable files.
  • Deeper search revealed the original RAID 10 partition.
  • RAID 10 partition showed correct files and wrote partition data to disk using Testdisk.
  • Rebooted
  • Raid Array RECOVERED!


Note again that my OS was on a separate hard disk and not on the raid. Its very important not to do anything to the raid disks or you risk loosing the data, no need to say that you shouldn't do anything such as initializing, formatting, etc.

As always the steps come without any guarantee and try them at your own risk!
 
301 - 304 of 304 Posts
Top