Overclock.net banner

1 - 13 of 13 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I know this is going to sound repetitive but im begining to think my "lower" fps in WoW is system based, I have all the settings on the lowest possible settings and im only getting 30 fps max i use to get 100+ easily not only the 30+ fps thing is bothering me its more then screen tearing the lag spikes mid run i just want some advice i did virus scans i deleted all possible adware spyware. I know i probably sound like a little ***** because some people dont even get 30 fps. TNX

Comp.

Intel Core 2 Duo CPU E6550 2.33GHz

1.00 Gb of ram

32 bit windows Vista Home Premium

GFX - Nvdia GeForce 8600 GTS

Again any advice is wanted and if i left any information out inform me.
 

·
Registered
Joined
·
3,231 Posts
You need more ram its as simple as that. You vid card is a little old but plenty powerful for that game. Also WOTLK is ALOT more stressful than the BC or the original game. Thats why you are noticing slow downs alot more than you used to. Get rid of that 1gb of ram and get a good 4gb kit.

yeah i know he is using a 32bit OS, but the extra will still help some.

EDIT: Try this kit out.

http://www.newegg.com/Product/Produc...82E16820231166
 

·
Registered
Joined
·
1,458 Posts
First of all, you're running vista on 1GB of RAM. There really isn't any room for WoW to run. Try upgrading to some more RAM, DDR2 is very very cheap now.

Second of all, think about upgrading to an 8800 or 9800 gt, they are both great cards that will outperform what you're using now. If you want an ATI solution, look at the 3850, 3870, or 4830/4850.

GL
 

·
Premium Member
Joined
·
5,437 Posts
Ram is so cheap!

Also, use Perfectdisk10 or Auslogics disk defrag. WoW spends ALOT of time reading from your HDD in order to pull up each and every weapon and armor texture, which is why your FPS in cities especially is always poor.

Quote:

Originally Posted by prosser13 View Post
With my addons, my WoW install alone uses nearly 1.6GB of RAM...

I feel ya there, I havent even bothered to reinstall Bartender yet and I run 2gb

But I just cant get rid of Xperl, its too perdy!
 

·
Premium Member
Joined
·
12,297 Posts
Quote:

Originally Posted by d3v0 View Post
I feel ya there, I havent even bothered to reinstall Bartender yet and I run 2gb

But I just cant get rid of Xperl, its too perdy!


I use Xperl too, and Dominoes for action bars. Add in the rest and then head into a 25 man raid and things get crazy fast
 

·
Registered
Joined
·
1,334 Posts
There's another thread about someone having a similar problem.

Here:http://www.overclock.net/pc-games/47...re-driven.html

Turn off advanced shadows! They are a FPS killer and FPS is worth more then beauty in WoW. Also, I'd like to say that WoW doesn't contain a huge quantity of variables or anything very RAM consuming. But if you wanna stick with vista, more RAM is a must..
 

·
Registered
Joined
·
841 Posts
You'll need more RAM and BAM your problems gone! I used to have the same problem on my 8600 and that fixed it.

Quote:

Originally Posted by prosser13 View Post


I use Xperl too, and Dominoes for action bars. Add in the rest and then head into a 25 man raid and things get crazy fast

I run naked :3
 

·
Premium Member
Joined
·
11,272 Posts
1GB used to be fine in vanilla. I remember going from 512MB to 1GB... it was like night and day.

1GB gave me smooth loads.
 
1 - 13 of 13 Posts
Top