Overclock.net banner

1 - 20 of 50 Posts

·
QA Engineer
Joined
·
3,016 Posts
Discussion Starter #1
How would I go about installing nVidia drivers on Ubuntu 10.04? I can download a Linux file from nVidia, but I have no idea how to install it.
 

·
Premium Member
Joined
·
4,521 Posts
the video is alright, but the guy seems a bit confused, i personally prefer the nvidia drivers from nvidia.com vs the ones in the repo's, if you are looking to install them instead here are the steps.

1. download the nvidia drivers from nvidia that firts your architect and card.
2. open up dolphin/nautilus, rename them to something simple, like nvidia.run
3. open up a terminal, type sudo su, it will ask for your password, enter it.
4. cd to where the nvidia.run is located and issue this command, chmod +x nvidia.run.
5. run this command, gedit /etc/modprobe.d/blacklist.conf, add these lines to it at the bottom:
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
save, and then close out gedit
6. in the terminal you will need to kill gdm/xorg, type this command:
service gdm stop
this will kill your desktop and leave you with this totally unusable screen, you will need to do this:
ctrl+alt+f1, this will take you to another runlevel, it will ask for your login and user name, once there issue this command:
sudo su, you will need super user privilages again.

8. issue this command, apt-get install build-essential , this will install eveyrthing you need, wait till it is done.
9. issue this command, sh nvidia.run, follow the onscreen prompts, basically say yes to everything.

it will install and configure the xorg.conf automatically, you will need to restart after it is done, all you will need to do is type in reboot now, and it will restart the computer.

if you ever need to change nvidia settings, DO NOT USE THE Nvidia-settings in sytem-preferences, you will need to go to the terminal, type:
sudo nvidia-settings, cause you need root access to alter the xorg.conf.

on a side note about the plymouth and the ubuntu boot, it is moronic that they do not support the propeitary drivers, cause the default drivers just totally suck, they are useless in 99% of all situations except for the initial boot imho, i exp a lot of tearing and artifacting in the first few minutes after i've installed ubuntu or any other linux distro, i've never had a problem like this guy has described install the prop drivers from nvidia.com, but i am also not a total noob, who just lets the update run without checking what it is updating or adding to my system, so if you want to err on the side of caution, use the method described in the video
 

·
Banned
Joined
·
2,407 Posts
Oh my god. That post above is just terrible. I'm sure it works but it's overly complicated.

Download the file to the desktop. Make sure it's the only NVidia driver on there so you don't get confused.

1. Drop to shell with Ctrl-Alt-F2
2. Login with your name and password.
3. Stop GDM with "sudo /etc/init.d/gdm stop"
4. Run the shell script with "sudo sh N". Hit tab and let it auto complete the name. Hit enter.
5. Go through the setup wizard. Hit yes to just about everything. Let it install.
6. Start GDM with "sudo /etc/init.d/gdm start"
7. Go back into the correct shell with Ctrl-Alt-F7

Done.
 

·
Premium Member
Joined
·
8,405 Posts

·
QA Engineer
Joined
·
3,016 Posts
Discussion Starter #6
Quote:


Originally Posted by transhour
View Post

if you ever need to change nvidia settings, DO NOT USE THE Nvidia-settings in sytem-preferences, you will need to go to the terminal, type:
sudo nvidia-settings, cause you need root access to alter the xorg.conf.

How come?
 

·
Premium Member
Joined
·
4,521 Posts
Quote:


Originally Posted by TFB
View Post

Oh my god. That post above is just terrible. I'm sure it works but it's overly complicated.

Download the file to the desktop. Make sure it's the only NVidia driver on there so you don't get confused.

1. Drop to shell with Ctrl-Alt-F2
2. Login with your name and password.
3. Stop GDM with "sudo /etc/init.d/gdm stop"
4. Run the shell script with "sudo sh N". Hit tab and let it auto complete the name. Hit enter.
5. Go through the setup wizard. Hit yes to just about everything. Let it install.
6. Start GDM with "sudo /etc/init.d/gdm start"
7. Go back into the correct shell with Ctrl-Alt-F7

Done.

he will still need to blacklist the opensource drivers, and make sure build-essentials are installed or the drivers will not install, cause the package will not build or install without it.

i wouldn't say my post was horrible, just not well laid out, as i was trying to include ALL steps needed, and it was very late when i was writing it, before you criticize, make sure you include ALL steps first.

and for a side note, 10.04 uses upstart, it will complain about sudo /etc/init.d/gdm start as being an incorrect command, and will not start or stop gdm, you will need to use service gdm stop/start in 10.04.
 

·
Premium Member
Joined
·
4,521 Posts
Quote:


Originally Posted by Playapplepie
View Post

How come?

if you do not open nvidia-settings as a root or privilaged user, then if you go to save the changes to the xorg, it will not let you, that is why i said run it from terminal as root.
 

·
QA Engineer
Joined
·
3,016 Posts
Discussion Starter #9
Quote:


Originally Posted by transhour
View Post

if you do not open nvidia-settings as a root or privilaged user, then if you go to save the changes to the xorg, it will not let you, that is why i said run it from terminal as root.

I see. For some reason Bioshock and Borderlands no longer work after installing this driver.
 

·
Premium Member
Joined
·
4,521 Posts
Quote:


Originally Posted by Playapplepie
View Post

I see. For some reason Bioshock and Borderlands no longer work after installing this driver.

i honestly do not know, as i do not run wine, or any windows apps inside linux, as wine is flakey imho.
 

·
10 year OCN Vet
Joined
·
3,421 Posts
Quote:


Originally Posted by Playapplepie
View Post

I see. For some reason Bioshock and Borderlands no longer work after installing this driver.

You ought to run "winecfg" to see what graphics settings are there. Do you have DX9 installed under Wine? Also some programs run better w/ different Windows style settings ie: Windows XP vs./ Win 7. Try a few.
 

·
QA Engineer
Joined
·
3,016 Posts
Discussion Starter #12
Quote:


Originally Posted by enorbet2
View Post

You ought to run "winecfg" to see what graphics settings are there. Do you have DX9 installed under Wine? Also some programs run better w/ different Windows style settings ie: Windows XP vs./ Win 7. Try a few.

I'm sure I have DX9 installed under Wine. Do I have to again after installing a new driver? But I actually can't play Bioshock or Borderlands anything higher than XP, because they error out saying the Game Explorer file could not be found or something.
 

·
QA Engineer
Joined
·
3,016 Posts
Discussion Starter #14
Does Ubuntu usually yield awful graphics performance?
 

·
QA Engineer
Joined
·
3,016 Posts
Discussion Starter #16
Quote:


Originally Posted by TFB
View Post

Not at all. Take a screen shot.

The games I have are putting out extremely low FPS. L4D2 had a fps of 11-13 on all low settings at 1024x768. Borderlands has really bad graphics performance at 1024x768 with all low settings.
 

·
Premium Member
Joined
·
4,521 Posts
Quote:


Originally Posted by TFB
View Post

I never had to blacklist the nouveau drivers.

the beauty of things are, just cause you have never, doesn't mean it is not a vital step.

the black list is there for a few reasons, the main reason i've always used it, this just doesn't apply to installing nvidia prop drivers, it is for those times when more than one driver exist for the same device, i can tell the system not to use one driver or the other, incase that driver i do not want to be using gets onto the system, thru a update or a dependency check, with the blacklist, it will not interfere with the driver i have chosen to use.
 

·
QA Engineer
Joined
·
3,016 Posts
Discussion Starter #19
Quote:


Originally Posted by TFB
View Post

Linux is not a gaming platform but I got incredible frame rates in HL2.

HL2=Source

L4D2=Source

Maybe it's the 8500GT I'm using in this Linux experiment. But this 8500GT was able to play L4D2 and other games pretty well.
 

·
Premium Member
Joined
·
8,405 Posts
WINE just sucks. Go play some native games instead
.
 
1 - 20 of 50 Posts
Top