Overclock.net banner

1 - 5 of 5 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
I just purchased a new oem 250Gig Seagate barracuda 7200 rpm HDD. I plugged it in via sata cable and sata power cable to my mobo. <br />
<br />
Now when I boot up XP it says that I have new hardware, but when I check it under device manager and my computer: it says its a removable disc drive and I cannot seem to get access to it.<br />
<br />
I have updated my bios to the latest version and checked the seagate site, it says that no drivers are needed beyond the xp ones already existing...<br />
<br />
I don't know what I'm doing wrong. Any help would be much appreciated.
 

·
Retired
Joined
·
2,424 Posts
Have you formatted it yet? You need to go to My Computer, you will find it there as probably something like E: or F:. Right click on it and format it. That will allow you to use it.
 

·
Registered
Joined
·
988 Posts
Yeah you have to format it..Go to My computer... right click on the drive and hit format.. and eventually I would later reinstall your OS on the Sata drive since it performs much faster....
 

·
Goodbye
Joined
·
10,269 Posts
Go under Administrator tools, computer management and then the storage tab.<br />
<br />
Right click the hard drive, slap on an NTFS partition and then format it, do a deep format if you dont mind waiting.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #5
Thanks for the help guys, really appreciate it.<br />
<br />
The administrative tools method worked, right clicking in my computer did not allow me to format my drive, for future reference.<br />
<br />
Thanks again
 
1 - 5 of 5 Posts
Top