Overclock.net banner

Installing windows AHCI woes

540 Views 17 Replies 3 Participants Last post by  Bluemustang
Hey guys, So I'm in the process of reinstalling windows on my ssd. It was my understanding that you should have ahci enabled in bios prior to installation and it was already enabled before I began installing.

Now after windows installed and rebooted to complete installation it passes the IDE screen and finds no drives (since of course AHCI is enabled) then onto the next screen which is the AHCI bios loading it pauses and fails to find any drives and won't progress.

I figured I might try to reenable IDE but after rebooting and hitting del to go into bios it has to pass the AHCI screen first which is where I got stuck.

I'm at a loss and all I can think to do now is clear CMOS to force reset to IDE, this doesn't make sense.

Any help would be greatly appreciated.
1 - 18 of 18 Posts
You didn't do anything wrong but I think you have to load motherboad and chipset drivers after formating the SSD from the Windows installation menu. Have you mobo chipset drivers ready.

Also, update the motherboard BIOS if it is too old which might not support the SSD.
There's no way for me to install motherboard/chipset drivers (chipset drivers should be up to date, only 1 on gigabyte.com which is dated before i bought the board) since I can't even get into the bios. And the bios is up to date, I updated it after I bought and installed windows on the ssd the first time over half a year ago.

It's as if the ahci drivers were on the ssd I was trying to install windows on, since wiping the drive I can't get passed that ahci screen. It gets to the screen and says ahci, tells the number of ports and the number of drives connected but doesn't list any of them as it used to and won't move on.
Do you mean you can't even try to reinstall Windows and during the process there's an option to load drivers? It looks like you have to load AHCI driver during the installation process. If you don't want to do this, I don't see how you will be able to get pass the AHCI screen.


If you can't get into BIOS, just reset CMOS.
That's what I was thinking I had to do because in order to get into the bios (I hit del and it said loading) it must pass the AHCI screen first.

But I've been tinkering around and trying different things. I had the SSD in sata port 0 and HDD in port 1, disconnecting HDD did nothing. Then I moved HDD to port 0 and disconnected the SSD and it loaded the AHCI bios, listed drives and I got into the bios.

What does this mean? I must be missing something simple, I haven't installed any new chipset drivers or firmware updates since I installed windows on the SSD the first time. Everything should still be compatible driver wise.
Set AHCI in BIOS > Install Windows > format SSD > Load drivers > complete Windows Installation > Install Motherboard and Chipset Drivers. Done.
Ok sorry but what drivers are you referring to? The only SSD drivers I installed last time were the Intel RST drivers but that was inside windows. Same for motherboard drivers (audio drivers, lan drivers etc). Never did that outside of windows.
Usually you don't need to install motherboard and chipset drivers (AHCI) during the Windows installation. But in your case where AHCI is not working, this is the only way I could think of for you to try. If you want to do otherwise, let's hope for others with better solutions for you.
It's not that I want to do otherwise I just didn't realize motherboard drivers and ssd drivers (aside from intel RST I don't know what drivers those would be) could be installed outside of the operating system. Really appreciate the help.

So I tried plugging the SSD back in, this time in port 1 (second port) and got to the ahci screen, showed the HDD in port0 and for port 1 (the ssd) it said not detected and wouldnt continue. I then disconnected the SSD, went into the bios and enabled IDE and plugged the ssd back into port1 and it booted.

Whatever I need to do to the ssd so I can boot it in AHCI I'm going to need to do it in while in IDE.
This is the easiest way.

Set AHCI in BIOS > Install Windows > format SSD > Load drivers > complete Windows Installation > Install Motherboard and Chipset Drivers. Done.

There is a registry edit for AHCI but the above is the easiest.
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To resolve this issue yourself, enable the AHCI driver in the registry before you change the SATA mode of the boot drive.

To do this, follow these steps:

1.Exit all Windows-based programs.
2.Click Start, type regedit in the Start Search box, and then press ENTER.
3.If you receive the User Account Control dialog box, click Continue.
4.Locate and then click one of the following registry subkeys:


5.In the right pane, right-click Start in the Name column, and then click Modify.
6.In the Value data box, type 0, and then click OK.
7.On the File menu, click Exit to close Registry Editor.
That's the problem though, I can't boot at all with the ssd connected while in AHCI mode.
1. Update Motherboard BIOS.

2. Set AHCI in BIOS > Install Windows > format SSD > Load drivers (AHCI)> complete Windows Installation > Install Motherboard and Chipset Drivers.


PS. Downlaod all available drivers update from Gigabyte's site dan save it in a pen drive, you will need this during Windows installation.
Been looking around trying to figure this out but I can't find a guide on the part where you say "Load Drivers (AHCI)". Plus I thought the AHCI drivers were the chipset drivers? And also how to do that without being inside of windows.
Download all the drivers update from Gigabyte for your board. Then extracted the downladed drivers to a pendrive/USD drive. During Windows installation you have the options to format, select which drive you want it to install to, also there's option to load driver. You can't miss it, it's just only one screen menu.

When you select load drivers, browse the location where the drivers are at the USB drive. It's easy peasy.
Reset cmos and if it loads into windows do the registry edit that was posted earlier, restart computer go into bios and set as ahci. If that doesnt work, probably need to flash your bios....
Ok thanks going to flash the bios first.

But I'm not finding any AHCI drivers on gigabyte, just audio/lan and chipset. What are you referring to?

And if the bios flash doesn't work what else could it be? I was looking into updating the SSD firmware but OCZ says it won't work with intel RST drivers. (Are these the AHCI drivers you were talking about?)
There are no ahci drivers on your motherboard cd. Just in bios and in windows. Nothing to install in order to use ahci mode.
Ok I decided to go ahead and finish installing windows on the SSD in IDE mode in hopes of enabling AHCI later with the registry hack. Then I messed something up and had to reinstall and boy was I surprised.

The first time I tried to install windows I had AHCI enabled from the beginning, before I began installing. On the second try I started off in IDE mode. After windows installed and rebooted to continue installation I went into the bios before it continued and enabled AHCI. Much to my surprise it worked this time.

So it appears to have fixed itself lol, well that took a lot longer then I'd expected.

Thank you all for the help, much appreciated.
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.