Overclock.net banner
1 - 3 of 3 Posts

·
Registered
Joined
·
362 Posts
Discussion Starter · #1 ·
If I enable memory compression (via the mmagent cmdlet in powershell) I get this "error" in process explorer about a process called "memory compression" and the path reads "[a device attached to the system is not functioning.]":


When I try to access any kind of information on it via properties settings, which there is none, it says "Access Is Denied" the only info I can see is threads tab that shows "ntoskrnlGetCompressionWorkspace" error.

Anyways, if I disable memory compression via the mmagent cmdlet in powershell, I no longer get the "error" in process explorer! The image below shows that memory compression is disabled with its "False" value:


But the other features having "True" values show that superfetch/prefetch is currently enabled. Normally superfetch enables memory compression by default when superfetch is on, until I manually disabled memory compression.

Suppose Superfetch (and memory compression) was enabled before then I disabled the Superfetch service in Service Manager, well this is what the mmagent cmdlet in Powershell looks like.

With Superfetch disabled, it also disables memory compression.

Currently, I have enabled Superfetch but since I manually disabled memory compression it stayed disabled. Otherwise, memory compression would have been automatically enabled alongside the Superfetch features.
 

·
New001
Joined
·
2,668 Posts
Have you edited the size of your pagefile?

I think its fine to disable memory compression - its just compression - you can do it how you've done there or you can disable the related services through memory diagnostics in task scheduler.
 

·
Registered
Joined
·
362 Posts
Discussion Starter · #3 ·
I let Windows manage the pagefile size. If I disable the related services through memory diagnostics in task scheduler, is it RunFullMemoryDiagnostic or ProcessMemoryDiagnosticEvents?
 
1 - 3 of 3 Posts
Top