Overclock.net banner

1 - 6 of 6 Posts

Ultra wide wide wide.....
5,283 Posts
Discussion Starter #1
The game looks fantastic, however, it suffers from performance issues even on the beastliest of rigs. I went through the advanced graphics options and messed around for a while to see which option(s) caused the most severe impact on performance, and here are my findings.

Test Rig Specs:
4770K @ 4.6GHz
16GB DDR3 @ 2600 MHz
GTX 1080 @ 2050/11000 MHz
Resolution: 2560 x 1440

I set all of the advanced graphics options to Ultra High and maxed out all of the LOD sliders but turned Motion Blur off. My PoV was set to 70. I found a spot in a tavern that caused my FPS to drop to 32, in front of a fire place with lots of effects and shadows. I then started dropping the settings one by one and recorded the results:

Lighting, Shader quality, and Shadows account for the highest percentage of performance loss, so by tweaking those, you can probably get your game running at an optimal level. By simply dropping Lighting and Shadows to Very high (Instead of Ultra High), I managed to get my FPS from 32, to 50 -An increase of 56%-. A small price to pay in graphics quality for such a huge gain in performance.

I hope you guys find this helpful.

Here longer than mods lol
3,800 Posts
Thank you, now I can run it on very high with a 1050ti :)

14 Posts
Really good findings with this Cyclops thanks, gonna run it the game with these settings in mind. Gives a much better understanding on which specific settings are the culprits too.

172 Posts
Yeah I hover around 19-24 fps in some difficult areas with everything on ultra on a 4k pc system. I'll try it out to see if I get better results too.

1,698 Posts
This post got me thinking so I decided to do a bit of digging online. + Rep to OP.

Just to add to this:


"I would like to thankyou for this.I have i7-7700K CPU, 16 gb ram, GTX 1080 Ti 11gb, at 2560 x 1440 rez
Whenever I would up shadow res to 2048 I would get shadow flickering indoors really bad on vannila settings ultra high or even using the optimized presets mod.
I use your settings all on Ultra high. plus these

My user.cfg:

r_TexturesStreamingMaxRequestedMB =720
sys_budget_sysmem = 16384
sys_budget_videomem = 11264
r_TexturesStreamPoolSize = 11264
r_TexturesStreamingResidencyTime = 120
r_texturesstreamingDeferred = 1
r_TexturesStreamingResidencyEnabled = 1
r_TexturesStreamingMipBias = -1
r_TexturesStreamingResidencyThrottle = 0.8
e_PreloadMaterials = 1
sys_PakStreamCache = 1
sys_preload = 1
sys_maxfps = 60

r_ssdo = 1
r_ssdoAmountAmbient = 1.42
r_ssdoAmountDirect = 2
r_ssdoAmountReflection = 2
r_ssdoHalfRes = 0
r_ssdoRadius = 0.3
r_ssdoRadiusMin = 2
r_ssdoRadiusMax = 0.1
e_svoTI_SSAOAmount = 1.4

e_ShadowsMaxTexRes = 2048
r_AntialiasingMode = 3
r_Sharpening = 0.8

wh_horse_CameraCentering = 0
wh_pl_showfirecursor = 1

I also have made a few changes directly in the pak files themselves

Only thing is I went from 60 fps down to 40-45 fps,But it runs smooth as silk I have no pop in,no stutters at all.
and no more Flickering.I use a very lite reshade just for some more color.

Thanks again.Keep up the good work"

I have also had good results with the above and that rework mod. No texture pop-ins... lighting seems to be fixed and the performance has improved a lot.

I'm on an i7 6700k + MSI ARMOR OC GTX 1080 + 48gb 2400mhz + ROG SWIFT PG348Q and getting around 45-60fps consistently now. Where-as before the mod, and the tweaks, I'd be dropping to 25-30fps in towns and it would feel awful, even with G-Sync.

EDIT: Went to REP the OP but there's no option. Sorry buddy! I'll set a reminder to do it as soon as rep is sorted.
1 - 6 of 6 Posts