Overclock.net banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hiya,
I have a samsung RF510

Intel® Core™ i5 Processor 460M (2.53GHz, 3MB)
nVIDIA GeForce GT 330M (External Graphic card) 1GB gDDR3 (External Graphic)
4GB (DDR3 / 2GB x 2) System Memory

But every time I run a game on it (dragon age, mass effect 2 etc) it just turns off randomly - anywhere between instantly and 30 mins in.The game runs smoothly till then. I have checked the temp (75 highest), updated all the drivers and the BIOS, reinstalled win 7 (I also have ubuntu on a partition), turned the graphics to low and tried DirectX9. I played wow for ages when I first got the laptop with no problems (I have no game time to test now).

I spoke to Samsung, but they said as I had deleted the recovery partition it was out of warranty.... only got it at xmas. This is very frustrating, please help!
 

·
Registered
Joined
·
2,531 Posts
Stupid that the warranty is voided because you deleted their bloatware partition.

Anyways, how's the battery health? I think you might be able to check that in the Bios
 

·
Registered
Joined
·
2,265 Posts
try removing the battery and unplugging it, then holding down the power button for about 15 seconds. Plug it all back in and see how it runs.
 

·
Registered
Joined
·
1,800 Posts
Quote:
Originally Posted by CaffeineCompSci;13097818
Hiya,
I have a samsung RF510

Intel® Core™ i5 Processor 460M (2.53GHz, 3MB)
nVIDIA GeForce GT 330M (External Graphic card) 1GB gDDR3 (External Graphic)
4GB (DDR3 / 2GB x 2) System Memory

But every time I run a game on it (dragon age, mass effect 2 etc) it just turns off randomly - anywhere between instantly and 30 mins in.The game runs smoothly till then. I have checked the temp (75 highest), updated all the drivers and the BIOS, reinstalled win 7 (I also have ubuntu on a partition), turned the graphics to low and tried DirectX9. I played wow for ages when I first got the laptop with no problems (I have no game time to test now).

I spoke to Samsung, but they said as I had deleted the recovery partition it was out of warranty.... only got it at xmas. This is very frustrating, please help!
Call Samsung back and keep demanding to talk to someone higher up, it's absurd that they would deny your warranty based on the removal of the recovery partition. Keep at it until they agree to take the laptop.

As far as your problem goes, if it's hardware it sounds like either a bad GPU or perhaps your power prick is going.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Thanks for your replies, samsung directed me to a local samsung repair place but said they will probably charge. He also said I should take ubuntu off first as that could also void the warranty!

Anyway I will try taking the battery out later. I have recalibrated it, but i dont see how that will help much.

Thanks.
 
1 - 5 of 5 Posts
Top