Overclock.net banner

Linux to Linux file transfer issues

872 Views 10 Replies 2 Participants Last post by  Bennylava
I'm using manjaro kde on my office computer, so when it came time to build a new HTPC I figured I'd give it a try on that computer too. I want a GUI way to just click and drag movie files to the desktop of the HTPC, that's all I'm looking to accomplish here. So naturally, I set up a shared folder on the desktop of my office computer. Now I should just be able to put video files in the shared folder, and then gain access to the video files when I'm on the HTPC. It's real simple in KDE, you just open the Dolphin file manager, and then click on the "Network" tab on the left.

When you click the network tab, it lists everything on the network. Then you just open the computer with the shared folder on it, get into the shared folder, and finally click and drag the desired file out of that folder, and onto the desktop of the HTPC. This starts the file transfer process, and you even get a nice little progress bar you can watch. Right? Well I can't get into the shared folder. I'm given the window in the pic, that is the bane of my existence. If I could make this window go away, my problems would be solved.

It's just your standard username/password prompt... only it appears to be broken. I created a username and password using a guide. It won't accept them. The window doesn't bother to tell why it won't accept them, it just flickers and remains, not letting you into the shared folder. Even if you select "anonymous guest" or whatever, it still just flickers and changes that setting back. Being a linux newb I'm quite confused. And I find it odd that I can tranfer files flawlessly this way, from windows 10 to manjaro linux, or vice versa. No problems whatsoever. But linux to linux? Nope, it's giving me grief. Anyone know what I can do to get rid of that stupid password prompt window forever?

1 - 11 of 11 Posts

· BOINC Cruncher
Joined
·
1,972 Posts
The way to get rid of the password prompt would be to mount the drive on your local machine and/or not put a password on the shared directory.

Is the user name and password you're using the user and password for the remote machine or the local machine?
It should work out of the box, but did you follow the necessary sections in the Manjaro Wiki?
 

· Registered
Joined
·
1,091 Posts
Discussion Starter · #3 ·
Well according to the people over at the Manjaro forums, I shouldn't use Samba as that's for windows file transfers. Since. Which does work fine when transferring from Manjaro to Windows 10. Since you seem to know a bit about that password prompt, do you know where I go to turn it off?
 

· BOINC Cruncher
Joined
·
1,972 Posts
NFS is better than Samba but could be problematic when trying to access from Windows. Microsoft at one time, or maybe still does limit NFS access to PRO versions of Windows.

First we have to find out why you can't access the share. I need the answers to the questions I asked in my previous post.
 

· Registered
Joined
·
1,091 Posts
Discussion Starter · #5 ·
Well I have looked through the wiki, but at this point I'm such a networking newb that it's hard to tell exactly what I'm doing wrong. I've been studying up a bit though, and it looks like part of the problem is that linux doesn't really come set up to do this. You've got some things to install and some settings to enter. That's why you have to install samba, as well as ssh.

As for the username and password I'm using, the password is the same on both machines. But the machines have different names. One is Linux_Rig the other is HTPC. To me it seems like a malfunction that it won't accept the proper username and password here.
 

· BOINC Cruncher
Joined
·
1,972 Posts
Did you do this?

Code:
User Accounts

If you are getting permission denied when connecting to a new share, one common cause of this is that samba does not have access to Linux user passwords by default. To remedy this, create a samba password for your user account:

sudo smbpasswd -a theusername


This will create a password for the user.
You have to give your user access to the samba share. This would be done on the samba host, not on the client.

Posting your /etc/samba/smb.conf would be helpful.
 

· Registered
Joined
·
1,091 Posts
Discussion Starter · #7 ·
Here is what my samba config file looks like:

[global]
workgroup = WORKGROUP
dns proxy = no
log file = /var/log/samba/%m.log
max log size = 1000
client min protocol = SMB2
server role = standalone server
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = New*UNIX*password %n\n ReType*new*UNIX*password %n\n passwd:*all*authentication*tokens*updated*successfully
pam password change = yes
map to guest = Bad Password
usershare allow guests = yes
name resolve order = lmhosts bcast host wins
security = user
guest account = justin
usershare path = /var/lib/samba/usershare
usershare max shares = 100
usershare owner only = yes
force create mode = 0070
force directory mode = 0070

[homes]
comment = Home Directories
browseable = yes
read only = yes
create mask = 0700
directory mask = 0700
valid users = %S

[printers]
comment = All Printers
browseable = yes
path = /var/spool/samba
printable = yes
guest ok = yes
read only = yes
create mask = 0700

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
browseable = yes
read only = yes
guest ok = no

[Share]
path = /mnt/Share
read only = no
browseable = yes
writeable = yes

create mask = 0644
directory mask = 0755
force user = your_unix_username

guest ok = yes
 

· BOINC Cruncher
Joined
·
1,972 Posts
Backup up your config, then make these changes:

Add this to your [global] section
Code:
hosts allow = 127.0.0.1 192.168.1.0/24
hosts deny = 0.0.0.0/0
If 192.168.1.0/24 isn't your IP range, change it.

Then change
Code:
security = user
to
Code:
security = share
Afterwards, restart samba or reboot the machine. It should no longer ask for a password. I haven't used Samba in a long time and I'm trying to remember what I did to not need a password.
 

· Registered
Joined
·
1,091 Posts
Discussion Starter · #9 ·
Thank you very much for all the help!

Ok two questions:

1. Is the IP range 0/24 because that's just a typical range of numbers allowed on a home network? So maybe you can only have a 24 of total machines? Or is that the router's limit of what it can handle?

2. Some of these config changes weren't in the config file originally, so we're adding new entries. This is just something I always wondered about config files: How does the program know that something new was added? If the program is capable of recognizing this new setting, why didn't they include these settings in the config file? That's like leaving functionality off the table. Good functionality that someone might need.
 

· BOINC Cruncher
Joined
·
1,972 Posts
Thank you very much for all the help!

Ok two questions:

1. Is the IP range 0/24 because that's just a typical range of numbers allowed on a home network? So maybe you can only have a 24 of total machines? Or is that the router's limit of what it can handle?

2. Some of these config changes weren't in the config file originally, so we're adding new entries. This is just something I always wondered about config files: How does the program know that something new was added? If the program is capable of recognizing this new setting, why didn't they include these settings in the config file? That's like leaving functionality off the table. Good functionality that someone might need.
192.168.1.0/24 would be any address between 192.168.1.0 and 192.168.1.255

The new entries we are adding are samba options that just aren't in the default configuration. If you open a terminal and type:

Code:
man smb.conf
You'll see a hundred other options with descriptions. In case you didn't know, many programs in linux come with a manual and "man" is how you access the manual.
 

· Registered
Joined
·
1,091 Posts
Discussion Starter · #11 ·
Yeah I tried to get a GUI for controlling Samba. There seems to be several of them but the one I tried was called smb4k. Got it from the Manjaro repos and it wouldn't start. It just did the little kde bouncing ball thing and then just never started. It's a fairly common problem, but I find that when that happens, installing the flatpack fixes it. There's no flatpak for smb4k, so I'll be moving on to another one at some point.

After making all these changes, it does still ask for a password. But using the username "nobody" and the password "admin" gets you past the password prompt. And it saves them so you don't have to use a keyboard. I'm starting to believe all those people who say samba is quirky and flaky.

I'm also starting to think that maybe what I really need is a tunnel, with a gui that I can install on every pc. Then just open that gui and get in, bypassing any and all network security.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top