Overclock.net banner

Logitech SetPoint 4.80 software

1696 Views 2 Replies 2 Participants Last post by  Daney
It was fine until I reformatted to speed up my OS..

Now I can not change the mouse settings, at all.

This is what I get:

I've tried re-installing the software and rebooting. Nothing.

What do I need to do?
See less See more
1 - 3 of 3 Posts
When i was messing with my G5 and MX518 the setpoint software automatically updated and swapped drivers for me right when i plugged them in without having to press anything. I havent had this problem before but have you tried shutting down, remove the mouse, boot up and then finally plug in the mouse when windows is done loading so setpoint can identify it?

Have you tried the "check for updates"? It is in that tab under the circled I in the top left.
  • Rep+
Reactions: 1
Thanks for that, it actually worked!

I installed it to another USB slot too. Thanks again
See less See more
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.