Overclock.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1
I just got one of these yesterday from Egg, setup to test the voltages with a DMM and I'm getting 11.83v on the 12v rail. Considering there is nothing even connected to the PSU yet should I just RMA this immediately? \\

I mean with my setup then this thing is gonna droop down to like 11.5ish??

This was supposed to replace a neo he 550 for when I eventually go dual gpu.
Funny enough the antec is rock solid at 12.04 even w/ full load.
 

·
Premium Member
Joined
·
10,655 Posts
you need to put it in your system and then test the voltages.... having no load on a psu can do wierd things
 

·
Overclock Failed...
Joined
·
13,565 Posts
Quote:


Originally Posted by soloz2

you need to put it in your system and then test the voltages.... having no load on a psu can do wierd things

What he said.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #4
Thanks guys, I learn something new everyday. This all the voltages are rock solid, should last me a long time to come. I only wish it was modular.
 

·
Premium Member
Joined
·
10,655 Posts
Quote:

Originally Posted by gunner14
I only wish it was modular.
no you don't. modular psus aren't as good.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #6
Quote:

Originally Posted by soloz2
no you don't. modular psus aren't as good.

Really, why is that?

I've had a couple modulars before including an OCZ modstream and and even though it was modular I didn't particularly like the cables they chose.

I'm not complaining too much about this one though since the wires are fairly flexible so I've been able to hide them behind the PSU.
 

·
Premium Member
Joined
·
10,655 Posts
the extra connectors increase resistance thus lowering the actual power the psu can deliver.
 
1 - 7 of 7 Posts
Top