Overclock.net banner
1 - 9 of 9 Posts

·
Premium Member
Joined
·
1,644 Posts
Discussion Starter · #1 ·
I've been playing it for a while and never had any problems. I played it about 4hrs today and now I'm starting to notice that my GPU usage is dropping and not using 100% and making the FPS drop. Here's what I captured from Precision when I minimized the game.

View attachment 205635

Up until that spike at the end is gameplay and then flatline was when I minimized to the desktop. What's going on? Maybe just a restart is needed?
 

·
Premium Member
Joined
·
1,644 Posts
Discussion Starter · #3 ·
Quote:
Originally Posted by thrasherht;13129442
have you changed your cpu speed?
Nope. I just shut down my PC for a while then started it back up to play. Runs fine now. But I wonder what caused it??

Everything is completely defraged and maintained. Ran virus scanner. All clean. Who knows...
 

·
Premium Member
Joined
·
1,644 Posts
Discussion Starter · #7 ·
Quote:
Originally Posted by BallaTheFeared;13133905
Do you have physx running?

Download a system resource monitor and see how much of your cpu Mafia II is demanding when you start getting low gpu usage.
Yes PhysX was using just about all of my GTS 250.

My CPU was around the middle (50-70) when I checked the usage level during that problem.
 

·
Premium Member
Joined
·
14,041 Posts
I saw the exact same thing countless times in Mafia 2. The game is totally buggy/flaky in parts. It especially happened to me when indoors. I've also seen it happen around the Maltese Falcon a bunch of times. You're lucky, for me a restart doesn't always get rid of it ... it was mostly just dependent on being in certain places in the game world for me. I've heard it suggested that certain articles of clothing you can choose from are just bugged, but I've not played it again since I heard that so I can't confirm/deny this supposition.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top