Overclock.net banner

Memory won't show up

765 Views 12 Replies 7 Participants Last post by  Starman27
I know this has been addressed on here before, but all the answers I have seen haven't worked for me. Here is my problem, I have 6gb installed in my computer, but windows says I only have 4gb in the control panel and task manager. CPU-Z is detecting all 6gb though, and yes, I am running 64-bit OS. I tried taking it out and reseating it, and also checked if there was any memory mapping in my bios to turn off, but no such option. I would really appreciate your help guys. Thanks a lot.
1 - 13 of 13 Posts
If CPU-Z says you have 6gb running then thats what I would trust.
That is odd.
For your sake I hope its just Windows being dumb.
you could check your wei rating summary info and see if it is recognizing it there as well. if not, i would try rearranging the ram differently on the mobo while making extra sure everything is seating properly. might try running memtest as well to make sure it isn't bad ram. i have read numerous reviews of people getting 1 bad stick of ram in the 3 when upgrading.
Here is a SS to show you what I am talking about.

I will run Memtest overnight tonight.
See less See more
I ran Memtest for 20 iterations last night, and there wasn't a single error. I meant to take a picture before restarting, but forgot, but here is one to show you the ram information. As you can see, it says I have 4gb ram, but it recognizes all three sticks as 2gb each. Why would it do that?

See less See more
from what you have shown us, it looks like everything checks out. my only guess is that it is a weird windows error. it will probably get fixed with an update.
Here is what my bios says

See less See more
Bump. Am I just stuck hoping it's using all my ram?
A problem similar to this was supposibly fixed from RC1 to the final retail release, but I have seen on some upgrades that have 4gbs still reporting 3.25 gbs in win 7 x64. Your problem is a little different in that you have 6gb showing 4gb.

But it couldn't hurt to try a fix that works for the previous problem.

Start up msconfig from the run command.
Go to the Boot tab, Click on "Advanced"
uncheck the box for "Maximum Memory"
Close Msconfig and reboot.

Don't know if it will help your situation, but it can't hurt.

Originally Posted by Starman27 View Post
Here is what my bios says

Your BIOS shows only 4GB as well. You must have some option in the BIOS that is limiting your RAM, or all the sticks aren't inserted properly. If all the sticks are installed properly...then it IS in your BIOS somewhere, since it shows 4GB there.
See less See more
About 100% sure you have one bad DIMM. The BIOS does more than just read the SPD it runs a quick test. If module is bad it refuses to recognize. Windows either does test itself also or goes with BIOS. Short of some BIOS setting limiting, it is a hardware issue. Run DIMM's one at a time you will find the bad stick. Or two at a time and after two tests one will report 2GB.

Good luck.
Thanks for the help everyone. Time for some turkey, and i will try these out this evening. I appreciate it.
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.