Overclock.net banner

1 - 20 of 21 Posts

·
Registered
Joined
·
384 Posts
Discussion Starter #1
Hello guys,

I have been trying to help a friend out with his new rig.

When i install the catalyst drivers and restart, the sceen stays black after the windows loading screen.

just now i'm trying to install the drivers in my own rig, but i'm getting the same..

His rig:

AMD FX-4100 3,6ghz
ASrock 970 extreme 4
8GB DDR3-1333 CL9
MSI R7850 Twin frozr 2GB
750w PSU

the only thing i can do is remove the drivers in save mode.

any idea please?

Thanks.
 

·
Registered
Joined
·
384 Posts
Discussion Starter #3
I have reinstalled them multiple times + using driver sweeper

I used catalyst 12.4 and 12.3, my friend used the drivers that came with the card the first time he got it.
 

·
DTR Enthusiast
Joined
·
4,863 Posts
Quote:
Originally Posted by Equinoxe View Post

I have reinstalled them multiple times + using driver sweeper

I used catalyst 12.4 and 12.3, my friend used the drivers that came with the card the first time he got it.
Have you tried possibly older drivers? I'm not too savvy on AMD cards but thats what some people with Nvidia cards do.
 

·
Registered
Joined
·
384 Posts
Discussion Starter #5
ill try to do that, thanks
 

·
Registered
Joined
·
4,217 Posts
if you get blackscreen after you enter windows thats a crash, it happens to me on 12.4 but no on the 12.3 drivers.

I have to go running black screen after blackscreen till i manage to uninstall the drivers,,

Im trying the april 18 beta drivers and havent see a black screen yet so far.
 

·
Registered
Joined
·
384 Posts
Discussion Starter #7
May 18?

Btw, the 7800 series are supported only since AMD Catalyst 12.x 8.950.5. after these came the 12.3
 

·
Registered
Joined
·
384 Posts
Discussion Starter #9
Okay,

Before i start switching my cards again.. Does that driver support the radeon 7800 series?
 

·
You Don't See Me.
Joined
·
887 Posts
Yes, says so on the supported card list.
 

·
Registered
Joined
·
240 Posts
Quote:
Originally Posted by Equinoxe View Post

Okay,

Before i start switching my cards again.. Does that driver support the radeon 7800 series?
Of course, and personally I think it's the best drivers set so far...

12.5 beta ( 8.97 - April 18 )
 

·
Registered
Joined
·
384 Posts
Discussion Starter #12
I just installed it.. Still black screen .....
 

·
Registered
Joined
·
384 Posts
Discussion Starter #14
No luck again
frown.gif

Im starting to think its a dead card
 

·
Registered
Joined
·
4,217 Posts
Quote:
Originally Posted by Equinoxe View Post

No luck again
frown.gif

Im starting to think its a dead card
I dont know, was thinking the same about my card.. The same thing was happening to me, then i manage to stops the black screens with 12.3 or april 18 betas..

So far 2 days without blackscreens since i installed april 18 betas.. 12.3 this problem dont occur either. Only on 12.4 official and that was like within minutes on logging into windows..

Running furmark to see if is heat issues and so far half hour no problems, no throttle either..
 

·
Registered
Joined
·
4,217 Posts
Quote:
Originally Posted by Deo Domuique View Post

My 7950 is extremely heavy card... Does yours sits well in the PCIe slot?
Yes, but my mobo is on a horizontal position because of my thermaltake lanbox.
So is laying down, and the card is sitting right in top of it...
 

·
Registered
Joined
·
384 Posts
Discussion Starter #19
I can't do that since its not my card.
 

·
Registered
Joined
·
6 Posts
Do you have any overclocking software installed?

I had the exact same problem with getting fade to black screen immediately after logging in windows. However, this was due to Asus GPU Tweak. It was even worse for me because a system restore wouldn't even fix it, I had to do a image restore to get it working again.
 
1 - 20 of 21 Posts
Top