Overclock.net banner

1 - 4 of 4 Posts

·
Registered
Joined
·
280 Posts
Discussion Starter · #1 ·
I recently bought new gpus, crossfire msi 7850s, and now when ever I try and load up magic the gathering, duels of the planeswalkers 2013, the game crashes right before I can hit the start button to enter the game. I found one thread with people having similar issues here:

http://forums.steampowered.com/forums/showthread.php?t=2761268

I don't have shark007 installed though (or any custom codec as far as im aware), and I've already tried deleting all the movies like one person suggested in that forum.

Has anyone else experienced this problem and fixed it? Im really upset because its one of my favorite games right now and I'd really like to play it again. The problem started right after I installed these 7850s, which makes me think its a video card driver issue. The game ran fine with sli gtx480s and a gtx660ti which i had installed and was playing the game on 2 days ago. Anyone who can solve this for me will definitely get a +rep and i will be very grateful.
 

·
Registered
Joined
·
280 Posts
Discussion Starter · #2 ·
Well I can definitely confirm its something to due with drivers. When I broke crossfire and ran the game off one card it started up just fine. All other games have worked in crossfire though. This is going to be really annoying if I need to disable crossfire every time i want to play this game, then re-enable after I exit and load my OC profile.
thumbsdownsmileyanim.gif
 

·
Registered
Joined
·
354 Posts
no problems on my end, ive used gtx 680, gtx 670, gtx 660ti, and 7970 with that game on steam.

the game seems simple yet makes my gpus go whirl at 70% fanspeed and getting 200-1000 fps
 

·
Registered
Joined
·
280 Posts
Discussion Starter · #4 ·
Im assuming that 7970 wasn't in crossfire right? It works fine with just one card. The game is just poorly optimized and neither wizards nor AMD seem to care about about supporting it. I was hoping someone might know if a way that I could constantly disable crossfire in the game by adding a script line into the binary of the game or something.

You should definitely turn vsync on for the game though, that will keep your power usage and temps down.
 
1 - 4 of 4 Posts
Top