Overclock.net banner

1 - 20 of 34 Posts

·
Registered
Joined
·
2,431 Posts
Discussion Starter · #1 ·
Hello , i have myself a 6950 flashed to 6970 . In some benchmarks when overclocked 920/1400 my computer will just turn off like i pressed the power switch .. Now im assuming my 665w generic psu cant take the beating im giving it with all my components and my cpu overclock ... Would it be wise to get myself a new psu ? do you think it would solve my problem ?

This is my psu , it claims to be 665w but it says max is 550w
http://www.jw.com.au/widetech-650w-silent-psu-120mm-fan-support-pci-ex-p-674

At default settings , it runs fine but a little overclock and my whole computer turns off :s i dont understand .

Help please , rep given .

34586670.jpg


full load i think my cpu does 192w + 270w+ for the gpu .. that doesnt leave much for the rest of the compnents i have .. all the fans , leds etcc
 

·
Registered
Joined
·
1,503 Posts
Quote:
Originally Posted by Xristo;12036759
Hello , i have myself a 6950 flashed to 6970 . In some benchmarks when overclocked 920/1400 my computer will just turn off like i pressed the power switch .. Now im assuming my 665w generic psu cant take the beating im giving it with all my components and my cpu overclock ... Would it be wise to get myself a new psu ? do you think it would solve my problem ?

This is my psu , it claims to be 665w but it says max is 550w
http://www.jw.com.au/widetech-650w-silent-psu-120mm-fan-support-pci-ex-p-674

At default settings , it runs fine but a little overclock and my whole computer turns off :s i dont understand .

Help please , rep given.

full load i think my cpu does 192w + 270w+ for the gpu .. that doesnt leave much for the rest of the compnents i have .. all the fans , leds etcc
Because your computer shuts off ONLY during stress testing, AND it shuts right off, I'm sure this points to your PSU. You don't have visual anomalies on screen, and it only happens during stress test.

As you said yourself, it's a generic, so it most likely doesn't put out enough amps on it's 12v rail.

As for a new PSU suggestion, I would recommend any Corsair, SeaSonic, XFX, or Antec PSU in the 600 - 650w range, just to give yourself some headroom for future Crossfire / overclocking.

Also, I wouldn't trust the software voltage readings. The only true way to tell your power draw is with a volt meter.

Again, sounds like 100% the PSU is shutting off due to over current protection.
 

·
Registered
Joined
·
5,508 Posts
Quote:
Originally Posted by CovertCover;12036875
Because your computer shuts off ONLY during stress testing, AND it shuts right off, I'm sure this points to your PSU. You don't have visual anomalies on screen, and it only happens during stress test.

As you said yourself, it's a generic, so it most likely doesn't put out enough amps on it's 12v rail.

As for a new PSU suggestion, I would recommend any Corsair, SeaSonic, XFX, or Antec PSU in the 600 - 650w range.
This.
 

·
Premium Member
Joined
·
3,352 Posts
Assuming your overclocks are stable and nothing is overheating, i'm fairly confidant that your psu is to blame. I've lost count of the number of generic psus that have been professionally reviewed and found to be able to only supply half of their rated wattage.
 
  • Rep+
Reactions: Xristo

·
Premium Member
Joined
·
16,520 Posts
That PSU is a piece of crap.

Got a budget for a replacement? You only need a quality 550W at most--yours is probably a 300W or less.
 
  • Rep+
Reactions: Xristo

·
Premium Member
Joined
·
13,796 Posts
It sounds like the PSU hits it overcurrent protection and shuts off. You are probably only getting 300W max out of that PSU.

You should probably buy at least a 500W PSU for your rig. 550W should be more than enough. Get a good brand/model too.
 

·
Registered
Joined
·
2,431 Posts
Discussion Starter · #8 ·
Intel burn test says im fully stable at 4.2ghz under 75c load so that isnt the problem ..

it only cost me $60 i think for the psu , money isnt an issue i think ill go buy a decent $150+ psu for my rig .. My psu is the cheapest thing in my case and i admit i have alot of things running off it uncluding the push fan on my h50 overvolted to either 17 or 24v not too sure .. whatever the blue - wire is on the 24pin
 

·
Registered
Joined
·
1,503 Posts
Quote:
Originally Posted by jellis142;12036985
Thank goodness it's shutting off and not taking your components with it to the grave. Seasonic, Corsair, Antec, any reputable manufacturer with at least 500W will be a good place to start.
+1 to this, at least your Cheap PSU has some kind of OCP, or you might had smelt some burning.
eek.gif
 

·
Registered
Joined
·
2,431 Posts
Discussion Starter · #12 ·
Yeah it is a new psu so i assume it has over current protection etc , to be honest it isnt that bad of a psu ..with my 5850 at 1ghz core it ran butiful but now i changed that for th 6950 and overclock that a little it switches off so i guess its just lacking that little bit of power the 6950 is asking for considering i flashed it to 6970 aswel.
 

·
Premium Member
Joined
·
16,520 Posts
SeaSonic X series are the best around. 400W through 850W. Go with the X560 or X650.
 

·
Registered
Joined
·
1,503 Posts
Quote:
Originally Posted by Xristo;12037104
thanks dude i will , i will be buying my psu from this store ..Can anyone suggest a good one ? i want nice cables also and they have to be abit long for cable managment in my antec 1200 .
This stupid psu has the shortest wires it was a nightmare hiding it all .

http://www.jw.com.au/power-supply-units-c-42

thanks all
Modular cables or non-modular?

Modular: http://www.jw.com.au/seasonic-650w-80plus-gold-modular-psu-p-661

Non-Modular: http://www.jw.com.au/seasonic-620w-s12ii-80-bronze-power-supply-p-899

But a price range would help
biggrin.gif
 

·
Registered
Joined
·
2,497 Posts
I see only 1v-2v on +12, that isn't right. As the others have said get a better PSU from Seasonic, Corsair, XFX...
 
  • Rep+
Reactions: Xristo

·
Registered
Joined
·
1,503 Posts
1 - 20 of 34 Posts
Top