Overclock.net banner

My PS3 controller is having this problem...

2229 Views 2 Replies 2 Participants Last post by  kmo_9000

It's not exactly the same problem. I say this because once I press and hold the PS button to get that menu, and go back the buttons work again, but if I go to a game or the internet browser, all buttons except the PS button stop working. It also seems to be controller related, because I can navigate around the XMB fine with the controller until I enter an application. Also, with my USB keyboard, everything works, on every menu, and doesn't stop working. I've already tried resetting the controller, and it doesn't work... This started happening yesterday, and I didn't do anything special to it. Sure, about a day or before this problem it fell from my hands to the floor while I was standing, and a very small bit of plastic broke around the USB connector spot and got inside the controller. On that day, if I just shaked it a little, I could hear the piece of plastic moving around inside the controller. Now, if I shake it, you don't hear anything, so maybe it got stuck somewhere and it's causing this problem?
1 - 3 of 3 Posts
Nevermind, I fixed it by opening the controller and removing the small piece of plastic I had inside, which was causing the problem. Now it works fine
See less See more
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.