Overclock.net banner

1 - 20 of 28 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hey guys,
I've got crossfire issues with two WF3 290X cards.

I've got:
-4790K
-MSI Z97S Krait Sli motherboard
-16GB RAM
-Seasonic 1000W PSU
-Windows 8.1 x64
-AMD 15.11.1 Beta Crimson drivers

-Both cards running at stock clocks and PCIe 3.0 x8.0 (tested via gpu-z tool)
-ULPS disabled in afterburner.

Both cards work fine individually. There are a lot of frame drops in games like CSGO and Witcher 3 (<60) that otherwise wouldn't occur with a single card. Unigine Valley scores ~4000.
I suspect the second 290X runs at PCIe 3.0 x1.1 or similar in these situations.

Does anybody have an idea on how to test and fix this?
 

·
pass the lortabs
Joined
·
5,004 Posts
Try Unigine Heaven 4.0 at these settings:
 

·
Registered
Joined
·
173 Posts
You might have already tried this, but I would strongly recommend downloading a good vitals monitoring software program, like GPU-Z, which is what everyone uses, myself included.
From here, you'll be able to see if your cards are dropping in clock speed due to over-temp, and you'll be able to see a ton of other cool stuff as well.
With that PSU, you're definitely not starving the cards for power. Honestly, IMO, you are probably having this issue due to temperatures.
Go head over to AMD's website, just to make sure you've got all the latest drivers and stuff, just in case.
Finally, if you do, I would try cranking up the fans to 100% for a few minutes to see if that fixes it. If it does, then you are definitely having thermals issues.
Also, if you overclocked the cards any, I'd turn it back down just to see if that does any good.

Good luck!

(On a side note, this is why I love Sapphire Vapor-X cards. Use them in all my builds. Faster than hell, quiet as a mouse)
thumb.gif
 

·
Registered
Joined
·
1,690 Posts
I was getting massive frame drops as well in CS:GO while running crossfire I would go from 200 to 20 randomly making the game unplayable. After about a week of trying every solution I could think of the only one that ended up working was to switch from "fullscreen" to "windowed fullscreen". I have no idea if that will work for you but it did wonders for me.
 

·
Registered
Joined
·
112 Posts
R9 290 crossfire have the same problem with the witcher 3, my fix is lower the game setting from ultra to high, still stuttering but less than before
 

·
Goodbye
Joined
·
10,269 Posts
Quote:
Originally Posted by Craiga35 View Post

I was getting massive frame drops as well in CS:GO while running crossfire I would go from 200 to 20 randomly making the game unplayable. After about a week of trying every solution I could think of the only one that ended up working was to switch from "fullscreen" to "windowed fullscreen". I have no idea if that will work for you but it did wonders for me.
So you effectively disabled crossfire for the game.
 

·
Premium Member
Joined
·
6,456 Posts
Try enabling DirectX triple buffering, dynamic vsync and, if necessary, increasing the flip queue to 4 or 5 with RadeonPro. With triple buffering, you basically trade a little bit of input latency for more smoothness, and with higher flip queues you trade even more... It's fine for games like Witcher 3, but it may be less than ideal for twitch games like CSGO.

FYI RadeonPro works fine on Windows 10 and the latest beta drivers, despite its age. You just have to run it as an administrator to detect newer games.
 

·
Registered
Joined
·
1,690 Posts
Quote:
Originally Posted by Penicilyn View Post

So you effectively disabled crossfire for the game.
Effectively yes, but the weirdest thing was trying to disable it in the Crimson driver's profile for CS:GO did not produce the same result. I was still getting stutters all over the place. Like I said I tired everything before finding that odd workaround.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #10
Quote:
Originally Posted by p4inkill3r View Post

Try Unigine Heaven 4.0 at these settings:
Quote:
Originally Posted by PontiacGTX View Post

Check the vrm temperature
And unpark cores
Quote:
Originally Posted by Macgyverman1123 View Post

From here, you'll be able to see if your cards are dropping in clock speed due to over-temp
With cores unparked, those Heaven settings, 1440p screen, and "crossfire enabled for applications without a profile":

Run 1:
FPS: 75.2
Score: 1894
Min FPS: 20.4
Max FPS: 198.6

Card 1 VRMmax = 80C
Card 2 VRMmax = 68C

Run 2:
FPS: 69.0
Score: 1738
Min FPS: 17.8
Max FPS: 199.7

Card 1 VRMmax = 80C
Card 2 VRMmax = 70C

I don't remember what core temps are, but they're normal too (ie <85-90C)
 

·
Registered
Joined
·
32 Posts
Discussion Starter #11
Quote:
Originally Posted by brucethemoose View Post

Try enabling DirectX triple buffering, dynamic vsync and, if necessary, increasing the flip queue to 4 or 5 with RadeonPro. With triple buffering, you basically trade a little bit of input latency for more smoothness, and with higher flip queues you trade even more... It's fine for games like Witcher 3, but it may be less than ideal for twitch games like CSGO.

FYI RadeonPro works fine on Windows 10 and the latest beta drivers, despite its age. You just have to run it as an administrator to detect newer games.
Thanks for the response, but that solution isn't optimal especially since the system is used for games like League of Legends too
 

·
Registered
Joined
·
173 Posts
Are you serious?
Those temps are insane.
Cooling is your issue. Crank up the gpu fans, and buy some more intake fans for your case.
You're lucky you haven't toasted those cards or something else.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #13
Quote:
Originally Posted by Macgyverman1123 View Post

Are you serious?
Those temps are insane.
Cooling is your issue. Crank up the gpu fans, and buy some more intake fans for your case.
You're lucky you haven't toasted those cards or something else.
The R9 2XX's run hot, core temps of 90C are normal on stock clocks. I will underclock them and see how it fares though
 

·
Registered
Joined
·
173 Posts
I'm not up on regular temps for those cards, but somehow, 194 degrees Fahrenheit, which, might I add is just below boiling, seems borderline a fire hazard, much less good, proper temps.
I'm on a different die entirely, but I have to beat the piss out of my cards to get them to hit even 50 Celsius. You seriously need to cool them properly before they damage themselves. I can guarantee this is why you are having stuttering in game.
 

·
Registered
Joined
·
1,690 Posts
95c is normal for a 290x. Despite how crazy it sounds AMD set the 290x's target temperature to 95c so anything below that is considered safe on the 290x's. If he's only hitting 85-90 he still has a few degrees before the fans even speed up never mind it thermal throttling.

Something with the Crimson driver seems to have screwed with crossfire in some games because CS:GO worked fine for me until I made the switch. Maybe it has something to do with AMD's implementation of frame pacing?
 

·
Registered
Joined
·
32 Posts
Discussion Starter #16

·
Iconoclast
Joined
·
30,639 Posts
Quote:
Originally Posted by KmhK View Post

Hey guys,
-Both cards running at stock clocks and PCIe 3.0 x8.0 (tested via gpu-z tool)

I suspect the second 290X runs at PCIe 3.0 x1.1 or similar in these situations.
Are you running anything that caps the frame rate? The only reason I can think of for the second card to drop to a lower PCI-E lane count or speed is if it's under utilized and goes into a power saving mode.
Quote:
Originally Posted by Macgyverman1123 View Post

Are you serious?
Those temps are insane.
Cooling is your issue. Crank up the gpu fans, and buy some more intake fans for your case.
You're lucky you haven't toasted those cards or something else.
His temperatures are normal and not remotely dangerous for 290X parts running at specified clocks.

Target temp is 94C and the fan won't even ramp up until this point.
Quote:
Originally Posted by Macgyverman1123 View Post

I'm not up on regular temps for those cards, but somehow, 194 degrees Fahrenheit, which, might I add is just below boiling, seems borderline a fire hazard, much less good, proper temps.
Boiling point of water has no bearing on the safe temperature of electronics.

Nothing these cards are made of will melt before 160C.

The auto ignition temperature of the most combustible substances that should be anywhere near a powered on computer are in excess of 200C.
Quote:
Originally Posted by Macgyverman1123 View Post

You seriously need to cool them properly before they damage themselves. I can guarantee this is why you are having stuttering in game.
You are completely incorrect.
Quote:
Originally Posted by KmhK View Post

Crossfire wasn't working properly before I switched to crimson.
Here's a pic of 290x activity during a Heaven benchmark (score ~1900):


The 0-100% usage on the second card is the problem, I have no idea what's causing it
Have you tried forcing the optimize 1x1 profile for CFX in the driver settings?

Also, what do the card's clock speeds look like? Are they fluctuating during load?
 

·
Registered
Joined
·
606 Posts
I was getting terrible fps in csgo when I upgraded to the crimson beta drivers, sometimes it would drop down to 30fps. After reverting back to the 15.11.1 drivers with catalyst control center instead of crimson, I dont have any more fps problems.
 

·
pass the lortabs
Joined
·
5,004 Posts
Quote:
Originally Posted by KmhK View Post

With cores unparked, those Heaven settings, 1440p screen, and "crossfire enabled for applications without a profile":

Run 1:
FPS: 75.2
Score: 1894
Min FPS: 20.4
Max FPS: 198.6

Card 1 VRMmax = 80C
Card 2 VRMmax = 68C

Run 2:
FPS: 69.0
Score: 1738
Min FPS: 17.8
Max FPS: 199.7

Card 1 VRMmax = 80C
Card 2 VRMmax = 70C

I don't remember what core temps are, but they're normal too (ie <85-90C)
ULPS is disabled in Afterburner, I'm assuming too, right?
 

·
Registered
Joined
·
133 Posts
Quote:
Originally Posted by Craiga35 View Post

95c is normal for a 290x. Despite how crazy it sounds AMD set the 290x's target temperature to 95c so anything below that is considered safe on the 290x's. If he's only hitting 85-90 he still has a few degrees before the fans even speed up never mind it thermal throttling.

Something with the Crimson driver seems to have screwed with crossfire in some games because CS:GO worked fine for me until I made the switch. Maybe it has something to do with AMD's implementation of frame pacing?
I agree with the Crimlson driver problem on CS:GO. I had to disable crossfire for this game since I use Crimson.
 
1 - 20 of 28 Posts
Top